LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   I have a problem with the Konsole(Terminal Program).I dont get all those commands (https://www.linuxquestions.org/questions/linux-newbie-8/i-have-a-problem-with-the-konsole-terminal-program-i-dont-get-all-those-commands-471490/)

martini1991 08-07-2006 03:02 AM

I have a problem with the Konsole(Terminal Program).I dont get all those commands
 
I installed Linux SUSE 10.1 recently and it recognized most of my Windows XP settings, but not my Wi-Fi. Than i looked it up in google.com and it said i needed to use NDISwrapper. However :mad: it said i needed to use the Konsole(Terminal Program) to install it( tell me if there is another way please:cry:!!!) , but im absolutely new to Linux so im completely lost. Here's a sample of what I ran into...


# ndiswrapper -i filename.INF

This causes ndiswrapper to create a configuration directory in /etc to hold the driver file and configuration pertaining to the driver and install the driver to it. Now if you issue the command:
# ndiswrapper -l

you should see something like the following:
dessa@holly:~> /usr/sbin/ndiswrapper -l
net8180 driver present, hardware present

To load the module, type modprobe ndiswrapper as the root user. To set up the ndiswrapper module to be loaded on boot, type:
# ndiswrapper -m...

...and so no...

Can someone please help me in some way, becomes my wireless is driving me mad?

Nylex 08-07-2006 03:39 AM

Have you actually downloaded NDISWrapper? You haven't actually said what you've done.

b0uncer 08-07-2006 03:42 AM

Well do as it says. If you're having # in console (rather than $) as the last letter, you're already "as root". If you're not (i.e. you get $ as the last letter on the command line), do
Code:

su
and give root password. Now load the module:
Code:

modprobe ndiswrapper
as your guide says. If you want that module loaded at boot so you don't have to load it manually every time, use
Code:

modprobe -m ndiswrapper
I think..well of the last I'm not 100% sure since you only posted "..." but I could guess so.

I would prefer a native driver over ndiswrapper. Ndiswrapper doesn't use native drivers, and...well, why the heck would people even use Linux then - they could just emulate it. But if it's your only choice, go ahead..

martini1991 08-07-2006 10:25 PM

Ok so i downloaded the NDISwrapper, and my wireless device is a Netgear WG111 v2, and i have the drivers on the cd, but dont actually know what to do from that point on. Do i just copy and paste the .sys and .inf files. Even when i do use the guidelines and instruction given by different websites it still doesnt seem to work!
Please help!

Nylex 08-08-2006 12:43 AM

Firstly, you're not meant to use the drivers from the CD, you're supposed to look at the list on the NDISWrapper wiki and choose the driver for your card based on what running "lspci" tells you. Secondly, you need to tell us exactly what isn't working - error messages and anything else. We can't see what's on your monitor! The instatllation instructions aren't that hard to follow.

martini1991 08-10-2006 11:15 PM

The system im running on right now is SUSE 10.1.
I went to the wiki, like you told me to and followed the instructions under installation prerequisites.
The first step i had to do was what the wiki said ,"Make sure there is a link to the kernel source from the modules directory. /lib/modules/VERSION/build should be a link to the kernel source, where VERSION is the version of the kernel you are running. If there is no link, you'll get an error at the make install step. To create a link, assuming the kernel sources are present, use the command
ln -s /usr/src/linux-<kernel-version> /lib/modules/VERSION/build ".Well i used the command /lib/modules/VERSION/build, but the Konsole said the following "bash: /lib/modules/VERSION/build: No such file or directory" So i tried the next command which was " ln -s /usr/src/linux-<kernel-version> /lib/modules/VERSION/build ". but the Konsole said the following " bash: kernel-version: No such file or directory ". So if i am stuck on the Prerequisites, which is the first step the wiki asked me to do, what chance do i have of completing the rest of the installation, and yes it is hard to follow. Im starting to hate Linux because of that NDISwrapper. Can you please provide me with easy to follow steps for installing the NDISwrapper because i cant seem to understand the instructions offered or it just doesnt work on WG111 v2. I hope you can help. :scratch:

Thanks a lot!
Oh yeah forgot to tell you I am such a :newbie:

Nylex 08-11-2006 01:57 AM

You know you're supposed to replace kernel-version and VERSION with the version of the kernel you're running, right? You can get that with "uname -r".

martini1991 08-11-2006 10:54 PM

I used the command uname -r .It gave me the following 2.6.16.13-4-default .What does this mean? And can you tell em what kerenel means?

Nylex 08-12-2006 01:53 AM

Again, that tells you the version of the kernel you're running. The kernel is essentially the core of the operating system.

martini1991 08-12-2006 04:05 PM

So i figured out my kernel version. Now that is pretty clear but im stuck on, after i downloaded it from sourceforge and saved it on the desktop. And now the wiki is asking me to extract it with the following command " tar zxvf ndiswrapper-version.tar.gz ". Am i supposed to write the version of the NDISwrapper where it says "version" in the command. Is it supposed to look like this the following " Major:/home/martini # tar zxvf ndiswrapper-1.23.tar.gz ". I typed it in the Konsole, but it gave me the following response " tar: ndiswrapper-1.23.tar.gz: Cannot open: No such file or directory
tar: Error is not recoverable: exiting now
tar: Child returned status 2
tar: Error exit delayed from previous errors "
So im stuck again and just cant seem to get how to do it, but if you colud walk me through step by step it would be much easier.

Nylex 08-12-2006 04:47 PM

Yes, you need to put the version there, obviously. Did you save the file in that directory (i.e /home/martini), or did you save it somewhere else? If so, change to whatever directory you saved to using cd. For example, I usually save stuff I download in a directory called "Downloads" in my home directory, so I'd just do "cd Downloads" (without quotes of course). Be aware that you don't need to be root to untar things. You only need to be root from the "make install" step onwards.

martini1991 08-13-2006 11:19 PM

Ok so i did everything but how do you install the drivers. Do you just copy and paste them or is there a specific command.

Nylex 09-07-2006 12:25 PM

If you read the NDISWrapper installation instructions, you'll see that the drivers are installed with "ndiswrapper -i filename.inf", replacing filename.inf with the Windows driver file.


All times are GMT -5. The time now is 04:18 AM.