LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   i got the new mozilla 1.4! but... (https://www.linuxquestions.org/questions/linux-newbie-8/i-got-the-new-mozilla-1-4-but-78252/)

lejakl 08-02-2003 02:11 AM

i got the new mozilla 1.4! but...
 
I successfully installed Mozilla 1.4 (yay for me!) and I got the shortcuts in the menu to work too (took me a while, I was being a klutz)

So now I have the new 1.4 .. I no longer need Mozilla 1.2.1 (right?)

I was wondering if there was some special procedure to uninstall (there is no readme file in the directory...)

thanks in advance to everyone! :)

by the way, for the people who read my other thread, I got the shockwave plugin to install correctly.

man, i love this OS :D

zer01 08-02-2003 09:51 AM

I would like the answer to this also, I got 1.4 installed and got the shortcut to work, hehe took me a while aslo as was being a klutz, and your right O/S does Rock!!

ksgill 08-02-2003 09:54 AM

You should have upgraded the existing mozilla 1.2.

koyi 08-02-2003 10:15 AM

try to issue a find like this:

# find / -name "mozilla"

and see if you have 2 different versions of mozilla. Normally the mozilla came with the distro is located in /usr/bin/ but the one installed later will be located in /usr/local/bin.

I dont know how to uninstall it, though.

ksgill 08-02-2003 10:25 AM

rpm -ev mozilla1.2
mozilla1.2 is just a name, replace it with the one that you want to remove

Kasperisa 08-02-2003 11:28 AM

Hey, I had the exact same problem. What i did to uninstall the older mozilla, is that i went to the add/remove applications (im using redhat 9) and i just removed mozilla. :D worked like a charm

Kasperisa 08-02-2003 12:07 PM

Does anyone have any problems with the new 1.4 mozilla browser? Some websites, like msnbc.com have really huge text now, and in the mozilla options, i do not see how to shrink it.

my other option is to remove the 1.4 version, but try as i might the command
rpm -ev mozilla doesn't exist, and i don't know how to find the proper name. can anyone help me please

could i just delete the files and folders containing mozilla? or woult that be a problem

ksgill 08-02-2003 01:31 PM

dont delete the folder just like that, try this command
locate mozilla | more
or
rpm -q mozilla
to find the version installed
and you will see a list. Find out which one you want to remove and then do rpm -e mozilla (it will work only if its an rpm package). Which distribution are you using?

Disruptor 08-02-2003 02:08 PM

Hehe ... basing on the posts of this thread it seems that you have installed
mozilla from source or from precompiled source. Well, sorry, `rpm -ev
<package>' and the `rpm' command in general apply only for programs that
you have installed via rpm :) Can sources or even precompiled sources be
turned in rpms?? Sure!! But this would require some reading and work on your
behalf which I guess you (just like me when I was in your shoes) don't even
want to hear about at this stage. Thankfully for us, there is a workaround for
these situations (keep on reading).

Now, about the problems that you are facing with the fonts and so on,
you should be prepared for this kind of stuff when you install from source or
from precompiled source (mere - not refering to rpm packages). Why??' Cause
many times, compilation of sources needs fine-tuning: some finishing touches here and there, special compilation parameters, that kind of stuff. The greater
the sources the more this rule applies (like here with mozilla). Other major
problems with compiling and installing mere sources is that they are hard to
uninstall and upgrade, they may break silently some programs on your system
leaving you in the dark without notice and so on. So avoid sources (the .tar.gz
, tar.bz2 ones - not the `src.rpm' ones you will see below) until you really get to
know what you are doing. As for rpm packaging system, it has adressed, in a
99.9% rate, all these and many other difficult problems. In fact, as far as I
know at least, it's the most advanced packaging system out there.

Now about acquiring a more fine-tuned mozilla: Before you uninstall
your new mozilla use it to download a mozilla .src.rpm (the site to download it
is below). Note the `.src' before the ending `.rpm' here: just have in mind it
denotes a quitte different type of package from the common `.rpm'
package. Follow this link to download the package:

ftp://rpmfind.net/linux/rawhide/1.0/...1.4-12.src.rpm

When done open a console and just login as root:

su
password: <your password>

now `cd' to the directory where you downloaded the mozilla package and issue:

Note: Make sure first you have at least 1.6G available space on you HD in order this to work: mozilla is a beast and unlike usual programs it needs a lot of
space to compile.

rpmbuild --rebuild mozilla-1.4-12.src.rpm

Now let your computer to compile mozilla. On an intel's Pentium 1.9Ghz
compilation took about 4/5 hours. So, be patient. By the time compilation will
finally be over, several rpms (not src.rpms) will have been created. Where??
Well it depends: If you are using mandrake you will find them in:

/usr/src/MDK/RPMS/i386 or something

if you are using redhat, you will find them at:

/usr/src/redhat/RPMS/i386

if you are using SuSE:

(you get the picture)

Now once you've switched to the directory where these RPMs are located just
do:

rpm -Uvh *.rpm (it's OK if you don't understand)

Now type at the command line: mozilla and voila: you will have the ultimate browser up and running at your disposal!! Isn't FS cool!?
Anyway, I hope these to prove helpful.

Cheers,
Dominique

P.S.1: I know that I am asking you to wear your clothes inside-out with all this
stuff, but if you really want to use Linux, instead of start hitting your head
against the wall for using it, you must become accustomed to these things

P.S.2: An excellent, must-read tutorial for using Rpm is here:

ftp://rpmfind.net/linux/PLD/current/...429.noarch.rpm

install the rpm and reach the index of the documentation it provides via path:

/usr/share/doc/maximum-rpm-1.0/index.html

read chapters 1 through 7 and you will never have problems with rpms.

ksgill 08-02-2003 03:03 PM

holy crap..Disruptor, dont you think thats an overkill :) :P? He's using redhat..so most likely its an rpm hes trying to remove. Even if it isnt than there are easier/simpler ways of uninstalling programs like
make uninstall
for example.....:)

Kasperisa 08-02-2003 03:07 PM

thanks for the tips, but I think you misunderstood. The problem isn't installing the sucker, it's getting rid of it. Its not an RPM that I installed, so i figure the RPM command won't work, Ive done so much installing these last few days, i don't remember what was an RPM or a tar.gz or whatever.. :P
In the mean time, i just removed the shortcut on my desktop, and renamed the folder, and am using the 1.2 version again, as i don't have a size font problem. I'll stick with it until i figure it out. :D

Kasperisa 08-02-2003 03:09 PM

Quote:

Originally posted by Jatt_thugz

make uninstall
for example.....:)

OMG.. uninstall.. It was too simple I would have never thought about it for linux

(1 minute later...)

ack... just tried it, didn't work

ksgill 08-02-2003 03:19 PM

If you wanna remove the mozilla browser preinstalled in linux than all you have to do is-
rpm -ev mozilla
have you tried this command?

ksgill 08-02-2003 03:33 PM

you have to be in the directory which has Makefile (source directory) in order to do
make uninstall
I am almost sure that to remove older version of mozilla, all you have to do is:
rpm -e mozilla

lejakl 08-02-2003 06:49 PM

Quote:

[lejakl@localhost lejakl]$ rpm -q mozilla
mozilla-1.2.1-26
[lejakl@localhost lejakl]$ rpm -e mozilla
error: Failed dependencies:
mozilla = 1.2.1-26 is needed by (installed) mozilla-mail-1.2.1-26
mozilla = 1.2.1-26 is needed by (installed) mozilla-psm-1.2.1-26
The error is pretty simple. (i think) This is my interpretation, let me know if Im reading Linux wrong :P
mozilla-mail and mozilla-psm need mozilla-1.2.1, therefore mozilla-1.2.1 cannot uninstall.

emmm.. what do I do now?

update: did a man rpm and learned a couple things :P i can use the nodeps option and not have it do a dependency check. I was wondering if I can just do that... (since I probably wont use mozilla mail 1.2.1 or mozilla psm 1.2.1 since i already have mozilla 1.4)

just wanna double check before i do something rash and have the system go up in smoke :P

thanks again guys :)

---

Disruptor, I really do appreciate your long post. I didn't install Mozilla 1.2.1 myself, so I dont know if it applies to me, therefore I tried what some others posted. However, I will read through your long post, just for the education :D thank you!


All times are GMT -5. The time now is 07:38 AM.