LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-15-2003, 01:42 AM   #1
mjl3434
Member
 
Registered: Sep 2003
Location: Los Angeles, CA
Distribution: Fedora 8
Posts: 108

Rep: Reputation: 15
I dont even know what my problem is?!


Okay I'm as new as they get so if this has some answer that I could have found by doing some detailed search I apologize for wasting your time with this. Here it goes:

Background:
I just installed red hat linux 9. When I tried to do the graphical user installation the monitor went blank. I rebooted and was successful to install it with the text installation. It detected my monitor and video card, a ViewSonic VX900 and a Gefroce4 respectivly. This is what I chose for those options...for the monitor settings I chose 1280x1024 and I had no idea what the refresh rate settings were supposed to be so I left it at what it said.

I can now pick either Linux or Windows XP. WinXP works fine. When I select Red Hat Linux it boots up and the monitor goes blank. I can hit a button to go into a text mode for grub but this is different than actually being in linux at least I believe.

Question:
What do you think my problem is? Is it that I need to install a driver for the Geforce4? If so point me in the right direction. I cant even get into the linux OS at all...any idea on how I can do that, even a non graphical text mode?
 
Old 09-15-2003, 01:52 AM   #2
djbanaan
Member
 
Registered: Aug 2003
Location: Haarlem, The Netherlands
Distribution: Slackware, FreeBSD
Posts: 178

Rep: Reputation: 30
Try passing "vga = normal" as an option in grub.
 
Old 09-15-2003, 01:59 AM   #3
maroonbaboon
Senior Member
 
Registered: Aug 2003
Location: Sydney
Distribution: debian
Posts: 1,495

Rep: Reputation: 48
Here's another possibility to look into:

http://forums.devshed.com/archive/33/2003/8/3/77098
 
Old 09-16-2003, 12:04 AM   #4
mjl3434
Member
 
Registered: Sep 2003
Location: Los Angeles, CA
Distribution: Fedora 8
Posts: 108

Original Poster
Rep: Reputation: 15
status...

I tried the first suggestion it was an unrecognized command...Im working on the second...how to i set to the runlevel to 3 before i reboot? the man command and the help command dont seem to come up with anything.
 
Old 09-16-2003, 01:17 AM   #5
koyi
Member
 
Registered: Jul 2003
Location: Osaka, Japan
Distribution: Arch, Ubuntu
Posts: 421

Rep: Reputation: 31
In the grub menu where you can select between Windows and Linux, highlight linux and hit "e", this will let you edit the command to boot. Now, select the entry that starts with "kernel" and hit "e" again. You are now able to edit the line. Add "init 3" to the end of the line, hit "enter" to return to the previous screen. Hit "b" to boot linux.

You don't have to do anything if you failed to boot this way, or when you want to boot with your normal runlevel again becoz this only temporarily changes your runlevel to 3. Just reboot your computer if anything weird happens.
 
Old 09-16-2003, 02:48 AM   #6
mjl3434
Member
 
Registered: Sep 2003
Location: Los Angeles, CA
Distribution: Fedora 8
Posts: 108

Original Poster
Rep: Reputation: 15
status...

Excellent I can get into linux. woot! Now am I correct to assume that the reason I cannot see in the graphical linux is because I need to get a driver for my GeForce4 ti 4600? That is my guess, which leads into my next question. Is this the site that has the appropriate driver...

http://www.nvidia.com/object/linux_d..._1.0-4363.html

If No where do I go from here so I can see something? If yes do I then download this file and put it on a floppy, to be installed off of the floppy in the text linux? Once again what are the exact commands I need to type? Any help is greatly appreciated I'm excited about getting my first linux installation working, so far you have all been a great help.
 
Old 09-16-2003, 07:28 AM   #7
maroonbaboon
Senior Member
 
Registered: Aug 2003
Location: Sydney
Distribution: debian
Posts: 1,495

Rep: Reputation: 48
I hope somebody stops me if I'm giving you bad advice. I have not done this myself, so be warned! That seems to be the site and the installer seems to be the file

NVIDIA-Linux-x86-1.0-4363.run

There is also a huge README (2Mb/100+pages PDF) which might be worth glancing through. Anyway, it seems you have to get this installer file on your linux PC. This may be a bit of a problem, as it is 6.3Mb.

Does your linux PC dual boot to MSwin? If so you download in MSwin, reboot and copy to linux.

Alternatively there might be some MSwin utility that chops files into floppy size pieces, which linux can recombine.

Several more extreme measures occur to me, but maybe you have some suggestion yourself based on your setup.

Anyway, once you have the file you 'run it' (or rather get the shell to execute it) by logging in as root and doing

# sh NVIDIA-Linux-x86-1.0-4363.run

Maybe you then have to run xf86config, or maybe the installer takes care of setting up your config files. The docs or install messages should tell you (let's hope so anyway).
 
Old 09-16-2003, 11:44 AM   #8
Genesee
Member
 
Registered: Dec 2002
Distribution: Slackware
Posts: 927

Rep: Reputation: 30
you should also be able to grab the file from within Linux using "wget" - iirc RH includes it - after logging in type "wget" followed by the entire filename.

you can read more about it by typing "man wget" at the prompt.

you may also have to make some config file changes, but I'm not sure - there are a lot of threads around on installing the nvidia drivers, and a good site/forum for nvidia help (along with this one, of course ) is nvnews.net


Last edited by Genesee; 09-16-2003 at 11:45 AM.
 
Old 09-16-2003, 03:02 PM   #9
mjl3434
Member
 
Registered: Sep 2003
Location: Los Angeles, CA
Distribution: Fedora 8
Posts: 108

Original Poster
Rep: Reputation: 15
another status...

Okay I managed to install a new driver for the video card. I found out there is another new one, so I'll install that after I finish this post. I still dont know how to enter any sort of setup for XF86 typing xf86config doesnt do anything. When I try to start the full blown XFree86 (I think thats the graphical enviornment red hat 9 uses) the screen simply goes blank again. Does anyone know why I cant get my screen to display anything and possibly how to fix it?
 
Old 09-16-2003, 07:39 PM   #10
maroonbaboon
Senior Member
 
Registered: Aug 2003
Location: Sydney
Distribution: debian
Posts: 1,495

Rep: Reputation: 48
You should have a file called /etc/X11/XF86Config-4 (or something very similar). What does the section labelled "Device" say?

In directory /usr/X11R6/bin do you have any files called xf86config or xf86cfg, or something like that?

Anyone know the standard way to configure XFree86 in RH9?
 
Old 09-16-2003, 08:41 PM   #11
koyi
Member
 
Registered: Jul 2003
Location: Osaka, Japan
Distribution: Arch, Ubuntu
Posts: 421

Rep: Reputation: 31
Or perhaps you have set your screen resolution improperly? You can change resolution setting by editting the file /etc/X11/XF86Config (or XF86Config-4). Try drop it to 800 x 600 to make sure whether is this the cause to your problem.
 
Old 09-16-2003, 11:58 PM   #12
mjl3434
Member
 
Registered: Sep 2003
Location: Los Angeles, CA
Distribution: Fedora 8
Posts: 108

Original Poster
Rep: Reputation: 15
more stuff

So I figured managed to open the xf86config file. However, there does not appear to be a setting for the resolution that is selected. Do you know what I should look for? I also found this:

http://www.xfree86.org/current/XF86Config.5.html

It was of some help but without a side by side comparison not all that helpful. I'll try to copy my config file to disk so I can post it later tonight but right now I have to do some diffeq homework...

The odd thing is that it did list 1280x1024 as a supported resolution and i KNOW that that is what I selected when intsalling linux. So the confusing part is I have the new drivers installed, the resolution should be find but I still get a blank screen! Any Ideas still?!
 
Old 09-17-2003, 01:48 AM   #13
koyi
Member
 
Registered: Jul 2003
Location: Osaka, Japan
Distribution: Arch, Ubuntu
Posts: 421

Rep: Reputation: 31
This is what you should look for:
------------------------------------------------------
Section "ServerLayout"
Identifier "Simple Layout"
Screen "Screen 1" 0 0
InputDevice "Mouse1" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
EndSection
-------------------------------------------------------------------

From this section you can find out which screen setting you are using(Screen "Screen 1" 0 0). So I am using "Screen 1". Go to the Screen Section with the identifier "Screen 1".
----------------------------------------------
Section "Screen"
Identifier "Screen 1"
Device "VESA Framebuffer"
Monitor "My Monitor"
DefaultDepth 24
SubSection "Display"
Depth 8
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 32
Modes "1024x768" "800x600" "640x480"
EndSubSection
EndSection
-------------------------------------------------------------------------------
From the setting we see that the default color depth is 24 bit. Then from the "Depth 24" entry we find that the resolution supported are "1024x768" "800x600" "640x480". Yours may start with 1280x1024. Try deleting it to set the default resolution to a lower level to see if it works.(Of course make a backup first. And make sure you know how to edit it again if this fails by either going to a text-based console or reboot with init 3.)
 
Old 09-17-2003, 03:06 AM   #14
mjl3434
Member
 
Registered: Sep 2003
Location: Los Angeles, CA
Distribution: Fedora 8
Posts: 108

Original Poster
Rep: Reputation: 15
nothing will get it to work

Okay I have the newest Nvidia linux driver installed that worked fine. Keep in mind ive always been doing this in runlevel 3 I cant get x to work for runlevel 5. I tried removing the higher resolutions so 800x600 was first, it still goes blank when x starts.

If it's not the driver and its not my settings in the XF86Config file what could my problem be? So far Linux is NOT easy to install and get running (at least in graphical mode where all the good software is) can anyone help me here?
 
Old 09-17-2003, 07:56 AM   #15
maroonbaboon
Senior Member
 
Registered: Aug 2003
Location: Sydney
Distribution: debian
Posts: 1,495

Rep: Reputation: 48
Hi again. Linux fans never run out of suggestions.

You could have a look in your XFree log file. This is /var/log/XFree86.0.log. A good way to examine a text file in a terminal window is to use the 'less' command:

% less /var/log/XFree86.0.log

(the name of this command is a lame unix joke. See the man page to find out more, or less). You can use the arrow keys to scroll up and down. Each line has a code at the beginning, (WW) for warning, (EE) for error etc.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
socket dont get/set values (c problem) alaios Programming 6 09-20-2005 05:51 AM
Suse 9.3 problem (dont know what) giovani_78 Linux - General 6 07-28-2005 05:40 AM
dont bash me for this ;-)- icon problem liljhand Linux - Newbie 8 02-01-2005 01:34 PM
new to linux dont what distro to use dont no much command xman2007 Linux - Newbie 3 01-02-2004 06:32 PM
Things dont work when you dont understand withoutaclue Linux - Newbie 3 03-12-2003 10:51 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 10:10 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration