-   Linux - Newbie (
-   -   I changed video settings & rebooted, now I cant change it back - black screen ?? (

wayneh 10-18-2003 06:28 AM

I changed video settings & rebooted, now I cant change it back - black screen ??

[redhatlinux9] I was playing around with my graphics card settings and now I have the black screen of death :jawa: I cant see anything because my monitors frequency is now out of range -

ie: boots up goes through the 'OK' check list.... and then localhost appears - then atoumaticaly takes me into what is the graphical login screen but the monitor cant handle it and therefore goes black...... arrrgh! :cry:

So bascialy I dont know how to change the settings back?

Can anyone help? :confused:

(the next step would be to take out the video card then hopefully it would detect a new one..?)


mhearn 10-18-2003 06:37 AM

Press Ctrl-Alt-F1 to get to a textual login screen, log in as root, drop to runlevel 3 (init 3) then edit the /etc/X11/XF86Config file (or whatever it's called). There may be a text config program I'm not sure, but editing the text file to get the frequencies back in range will do the trick. Then return to runlevel 5 (init 5)

brijesh 10-18-2003 06:42 AM

login in single user .. then convert run level to --
init 3 by editing /etc/vi initrd
change screen resolution

wayneh 10-18-2003 06:48 AM

Hi mike

Thanks for reply, I tried that and it doesnt seem to give me a textual login screen-

although it does affect my monitor in some way- instead of a dark black it changes it to a gray black
(at this point in time I dont blame you for thinking I am insane but unfortunalty thats what it does :D ) but I still cant see the command prompt?

another piece for the puzzle?

maybe i am pressing Ctrl-Alt-F1 to late?

At what point in the boot up can i press Ctrl-Alt-F1


syedtariq 11-27-2006 06:47 AM

hey waynah

i have the exact same prob
and my monitor is displayin frequency out of range

pls pass on the solution if u stumble on it
wil do the same


soundwave 11-27-2006 07:23 AM

After a faulty "driver" change in the "/etc/X11/xorg.conf" file, I also got a blank "out of range" screen.

After a reboot, linux tried to start X, but showed the "out of range" message. tried again, got "out of range" and so on and so forth, until (after about 2 minutes) I got a message that X-server couldn't be started (duh...:)), and that linux will try to start X with a fresh config.
After that, it worked. (and even let me choose the "driver" to be used out of a list).

I'm using Fedora Core 6... it might be a rescue procedure that exists only on FC6?
I dunno...

Good luck!

johngreenwood 11-27-2006 07:38 PM

The same thing hapened when I installed Slackware 11 to my brothers computer, his monitor couldn't handle the default settings, and I had already changed the default runlevel! I got around this by booting a live CD, any will probably do, but I used SLAX. From there I did xorgconfig, and copied the file saved to RAM over the Slackware 11 file, that worked for me.

foxxxy 12-12-2006 02:51 PM

I have this same problem and I cannot get to the login screen. It just goes completely black on the screen and does not say "out of range" or anything else. I really really like Linux and DO NOT want to give it up but I have had this happen 4 times over a 10 month span and every time I have to reinstall. I can not keep doing this.

1. This happens randomly. I do not alter my settings.

2. I dual boot Windows

3. I cannot get the login text screen.

4. I am using Fedora Core 5. (Will upgrade to 6 provided I can see my screen)

Any help would be greatly appreciated and if you need any additionally information post and I'll reply ASAP

foxxxy 12-12-2006 04:35 PM

Ok oddly.......I reset my BIOS jumper on MB and now I'm good to go. I guess I want to know why this happened now. I did not change any values in my BIOS.

All times are GMT -5. The time now is 07:01 AM.