LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   I can't get fetchmail to work and don't have a fetchmailrc file! (https://www.linuxquestions.org/questions/linux-newbie-8/i-cant-get-fetchmail-to-work-and-dont-have-a-fetchmailrc-file-502866/)

ChrisScott 11-18-2006 07:29 PM

I can't get fetchmail to work and don't have a fetchmailrc file!
 
I'm using a low RAM laptop so I want to use the mail program in BASH to check my emails as GNOME runs very slowly. I am using the Fedora core 5 distrobution.

I tried:

fetchmail pop.ntlworld.com

this seams to be along the right lines but it uses my local username prompting:

enter password for chris@pop.ntlworld.com

whereas I want my ntl username:

<ntlusername>@pop.ntlworld.com

I get the impression that I need to change something in ~/fetchmailrc but the file doesn't exist!

How can I sort this or if I'm barking up the wrong tree what should I be doing? Any help would be appreciated.

bigrigdriver 11-18-2006 08:25 PM

Instead of looking for ~/fetchmailrc, you should be looking for a hidden file: ~/.fetchmailrc. Note the dot in the name, .fetchmailrc.

In Konqueror, click on View - Show hiddef files. From a console, ls -a ~ will show hidden files.

ChrisScott 11-19-2006 05:27 AM

There's a .fetchmail.pid but no .fetchmailrc
 
Thanks I should have thought of that but there is still no .fetchmailrc file. I used ls -a and found a file called .fetchmail.pid but that only contains the number 2810. I also tried

locate .fetchmailrc

as the su and still got no results!

Can I create the file myself?

Nylex 11-19-2006 05:30 AM

You can create the file yourself, I did. Look at the man page for fetchmail and it should tell you about what kinds of things go in it.

ChrisScott 11-19-2006 06:32 AM

Yeah, all sorted now
 
Thanks guys everything is working fine now and I get my mail lightning fast... I'm a happy bunny.

If anyone else hap the same problem here's what I did:

create the file ~/.fetchmailrc in your preffered editor with the line

poll pop.whatever.com protocol pop3 username "whatever"

save it then change the permission as follows

cd ~
chmod 600 .fetchmailrc

#that is read & write for user only

you can also add

password "whatever"

to the end of ~/.fetchmailrc but I prefer to be prompted for my password.

ChrisScott 11-19-2006 06:38 AM

Yeah, all sorted now
 
sorry posted the same message by mistake

ChrisScott 11-19-2006 07:02 AM

Yeah, all sorted now
 
again don't know why but the same message posted - ignore!


All times are GMT -5. The time now is 04:03 PM.