-   Linux - Newbie (
-   -   I cannot get my boot loader to boot Slackware 9.1 (

oreo_masta 06-10-2004 08:05 AM

I cannot get my boot loader to boot Slackware 9.1
My two HDs are set up as follows:

MASTER (:( 74.5 gig [what gives, mate? it's supposed to be 80] ):
Linux Swap area (1 gig)
SuSE 9.1 Pro (9 gig)
Windows XP (64 gig)

SLAVE (19.1 gig [supposed to be 20 gigs]):
Slackware 9.1 (19.1 gig partition)
*The swap partition is shared with SuSE 9.1 on the first HD

Both Windows and SuSE boot up fine, but I cannot get Slackware to boot. My bootloader configuration is as follows:

"Slackware 9.1 | image | (hd1,1)/boot/vmlinuz (/dev/hdf2, root=/dev/hdf1) ......... I don't know where that hdf2 is coming from and don't know how to change it... i know it's not right though... because hdf2 doesn't even exist.

Windows XP | other | (hd0,2) (/dev/hde3)

SuSE 9.1 | image | (hd0,1)/bootvmlinuz (/dev/hde2, root=/dev/hde2

Failsafe (blah)

So Windows and SuSE both boot correctly. When I try to boot Slackware my error message is:

'kernel (hd1,1)/boot/vmlinuz root=/dev/hdf1 vga=0x314 desktop resume=/dev/hde1 splash=silent

Error 22: No such partition"

Now I know that in fdisk while I was setting up my partitions in Slackware, my master HD known as hde by SuSE is known as hda in Slackware. The slave is known as hdf by SuSE and hda in Slackware. I've just tried slapping down a lot of info that hopefully Simon will notice one or twelve errors in ;) My objective is to get Slackware up and running so I can continue with my linux education. I've been experimenting and and messing up my computer so many times over the past month... it's great :Pengy:

blueCow 06-10-2004 08:16 AM

Which boot loader are you using? grub, lilo?

you can just edit the grub.conf or lilo.conf with your favorite text editor to remove the hdf2 problem.

Also, if you just want to try out slackware, maybe you should pick up Slax. It's the Live Version of Slackware.

oreo_masta 06-10-2004 08:43 AM

I'm using a GRUB bootloader.

OK, I'm looking at my configuration in a text editor now... and that /dev/hdf2 doesn't even show up. Here's what the configuration for Slackware is set as in the text editor. Hopefully it will explain my setup more clearly than I can.

###Don't change this comment - YaST2 identifier: Original name: linux###
title Slackware 9.1
kernel (hd1,1)/boot/vmlinuz root=/dev/hdf1 vga=0x314 splash=silent desktop resume=/dev/hde1 showopts
initrd (hd0,1)/boot/initrd

Basically out of all that stuff... the only thing I fully understand it telling it where the root is. What's all that other stuff mean? Can anyone see where I'm going wrong? Thanks.

All times are GMT -5. The time now is 11:28 AM.