LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   i cannot copy a file to a folder in file system with my root account (https://www.linuxquestions.org/questions/linux-newbie-8/i-cannot-copy-a-file-to-a-folder-in-file-system-with-my-root-account-708949/)

realbezo 03-03-2009 06:52 PM

i cannot copy a file to a folder in file system with my root account
 
i think i have a problem with my root account. i open a terminal and i execute nautilus with root permissions through "sudo nautilus" or "gksudo nautilus" command. Then i try to copy just from my home folder some files to a folder in file system (to /usr/share/stardict/dic folder) and when i do right click, i cannot see active paste option, also ctrl+v doesn't work. my question is if root cannot copy files to file system, who does it? it has to be simple but i don't understand this, is it related to file permissions? And why don't have root every rights to do something?

frieza 03-03-2009 06:55 PM

it might not be a permissions issue i've had similar problems in konqueror where it simply takes a few tries to recognize the copy command
try opening two windows, one with the source and one with the destination and dragging the files from the source window to the destination and see what happens

T74marcell 03-03-2009 08:15 PM

My understanding of sudo is that it launches the application as belonging the the current user, only that the permission levels are extended. Even so, it is NOT a real root-launched tool.

Maybe try to switch to root in a terminal with the simple 'su' command, and then launch Nautilus as root. In this case a full root login happens with all the bashrc files read in and correct $PATH - only difference is that the /sbin directory will not be in your path when logged via su.

Give some feedback if this makes a difference on your Linux box.

----------
T74marcell

Arch Linux

realbezo 03-03-2009 08:44 PM

I think i have a problem with browsing my computer. Dragging does not work, it gives still same error, like "you do not have permission to do this" and if i try to run nautilus there is warnings but it seems it doesn't related to my problem.
(nautilus:9038): GnomeUI-WARNING **: While connecting to session manager:
None of the authentication protocols specified are supported.

(nautilus:9038): Eel-WARNING **: GConf error:
Failed to contact configuration server; some possible causes are that you need to enable TCP/IP networking for ORBit, or you have stale NFS locks due to a system crash. See http://www.gnome.org/projects/gconf/ for information. (Details - 1: Failed to get connection to session: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.)

(nautilus:9038): Eel-WARNING **: GConf error:
Failed to contact configuration server; some possible causes are that you need to enable TCP/IP networking for ORBit, or you have stale NFS locks due to a system crash. See http://www.gnome.org/projects/gconf/ for information. (Details - 1: Failed to get connection to session: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.)

(nautilus:9038): Eel-WARNING **: GConf error:
Failed to contact configuration server; some possible causes are that you need to enable TCP/IP networking for ORBit, or you have stale NFS locks due to a system crash. See http://www.gnome.org/projects/gconf/ for information. (Details - 1: Failed to get connection to session: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.)
GConf warning: failure listing pairs in `/apps/nautilus/preferences': Failed to contact configuration server; some possible causes are that you need to enable TCP/IP networking for ORBit, or you have stale NFS locks due to a system crash. See http://www.gnome.org/projects/gconf/ for information. (Details - 1: Failed to get connection to session: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.)


And when i try to run Konqueror it gives an error like this "Could not delete file file:///root/.kde/share/apps/konqueror/autosave/owned_by. " this is a gui error and it keeps opening when i try to close it, like a stupid windows virus. and this one comes from terminal
Qt: Session management error: None of the authentication protocols specified are supported
konqueror(9177) KToolInvocation::klauncher: klauncher not running... launching kdeinit
kdeinit4: preparing to launch /usr/lib/kde4/libexec/klauncher
klauncher(9187) kdemain: No DBUS session-bus found. Check if you have started the DBUS server.
kdeinit4: Communication error with launcher. Exiting!
konqueror(9177): No ksycoca4 database available!

konqueror(9177): No ksycoca4 database available!

konqueror(9177) KToolInvocation::klauncher: klauncher not running... launching kdeinit
kdeinit4: preparing to launch /usr/lib/kde4/libexec/klauncher
klauncher(9229) kdemain: No DBUS session-bus found. Check if you have started the DBUS server.
kdeinit4: Communication error with launcher. Exiting!
konqueror(9177): Couldn't start knotify from knotify4.desktop: "KLauncher could not be reached via D-Bus. Error when calling start_service_by_desktop_path:
empty
"

konqueror(9177): No ksycoca4 database available!
konqueror(9177): No ksycoca4 database available!
........ same way it was going until i closed the terminal
maybe this seems related... Can someone help me...
By the way i have Ubuntu 8.10 desktop version...

ArfaSmif 03-03-2009 10:45 PM

How about this :-

$ su
enter root password ....

# cp /home/username/filename /usr/share/stardict/dic/

If that doesn't work, then the permissions for /usr or /usr/share or /usr/share/stardict or /usr/share/stardict/dic need attention.


All times are GMT -5. The time now is 12:50 AM.