-   Linux - Newbie (
-   -   I can not install Flash Player on a Slackware (

bogdanixx 11-08-2009 02:55 AM

I can not install Flash Player on a Slackware
I have downloaded flash_player.tar.gz from the Adobe site on Desktop.
I went to the terminal and tried to open it with "tar -zxvf (file).tar.gz
but the machine tells me this:

bash-3.1# tar -zxvf install_flash_player_10_linux.tar.gz
tar: install_flash_player_10_linux.tar.gz: Cannot open: No such file or directory
tar: Error is not recoverable: exiting now
tar: Child returned status 2
tar: Exiting with failure status due to previous errors

Plus when Mozilla tries to "install missing updates" it just can't install Flash player.

Can u tell me why is this happening and how am i going to install Flash Player?

EricTRA 11-08-2009 03:02 AM


You'd better get it from here. Slackware is different from other distros. Download the source file and the Slackbuild file. Unpack the Slackbuild file, it will create a directory into which you move the source file. Next execute the Slackbuild script.

For more info read the Howto on

Kind regards,


catkin 11-08-2009 04:15 AM

These notes may help.

Downloaded from to /home/c/d/Repository/SlackBuilds (the Slackbuild) and /home/c/d/Repository (the plugin).


root:~# cd /home/c/d/Repository/SlackBuilds
root:/home/c/d/Repository/SlackBuilds# cp -p flash-player-plugin.tar.gz /tmp && cd /tmp && tar xzvf flash-player-plugin.tar.gz
root:/tmp# cd /home/c/d/Repository
root:/home/c/d/Repository# cp -p install_flash_player_10_linux.tar.gz /tmp/flash-player-plugin && cd /tmp/flash-player-plugin
root:/tmp/flash-player-plugin# ./flash-player-plugin.SlackBuild
root:/tmp/flash-player-plugin# installpkg /tmp/flash-player-plugin-10.0_r32-i386-1_SBo.tgz

mrrangerman 11-08-2009 04:17 AM

Make sure you are in the same directory that the tar file is in. The error you are getting is because tar could not find the file as seen in the first line of the error


tar: install_flash_player_10_linux.tar.gz: Cannot open: No such file or directory

bogdanixx 11-09-2009 03:56 AM

I managed to open the tar.gz archive. Can anyone of u please tell me how and where should i install

bogdanixx 11-09-2009 04:17 AM

i tried this but it says:

bash-3.1# ./
Segmentation fault

EricTRA 11-09-2009 04:22 AM


You don't have to execute that file, just copy it to the correct directory. Did you use the Slackbuild script or the file you downloaded from Adobe website? If you tried using the Adobe file, I advise you to use the Slackbuid as indicated in my last post.

The commands you have to run are listed in the post by catkin.

Kind regards,


brianL 11-09-2009 04:38 AM

Copy to /usr/lib/mozilla/plugins.

bogdanixx 11-09-2009 11:36 AM

i tried but no luck
bash-3.1# cd /usr
bash-3.1# cp /usr/lib/mozilla/plugins

jittles 11-11-2009 04:52 PM

I've been having some trouble with this too... is in the correct directory, and Konqueror should be looking there for plugins, but it doesn't seem to see it. :newbie:

All times are GMT -5. The time now is 04:37 PM.