LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   I can mount but i cant see files ... (https://www.linuxquestions.org/questions/linux-newbie-8/i-can-mount-but-i-cant-see-files-507390/)

dragon1te 12-04-2006 10:28 AM

I can mount but i cant see files ...
 
Ok so i'm able to mount my cdrom but the thing is that i cant see the files on the disk Oo. thats really odd ...

p.s. i'm really sure i mounting it -.- first of all its automaic second i do it manualy and its the same thing.

vargadanis 12-04-2006 10:44 AM

What distro? This is really stange...
Did you try in both /mnt or /media folder to chk out the cdrom? Is there a /cdrom folder? What is in you fstab?

Larry Webb 12-04-2006 10:48 AM

Which distro are you running and what type of files are on the disk?

dragon1te 12-04-2006 10:55 AM

slackware 11.0 and i've tried several disks .. not only one so all kinds of files.

/dev/cdrom /mnt/cdrom auto noauto,owner,ro 0 0


p.s. now i saw some kind of error : "mount: block device /dev/cdrom is write-protected, mounting read-only"

dragon1te 12-04-2006 03:08 PM

come on ppl :/ dont leave me ...

michaelk 12-04-2006 03:21 PM

Quote:

"mount: block device /dev/cdrom is write-protected, mounting read-only"
This is a normal warning message and can be ignored. Are there any other messages besides this one being displayed? The mount command without options will show you if the CD is being mounted. Make sure your not "in" the /mnt/cdrom directory when trying to mount the CD.

pixellany 12-04-2006 03:25 PM

Quote:

Originally Posted by dragon1te
slackware 11.0 and i've tried several disks .. not only one so all kinds of files.

/dev/cdrom /mnt/cdrom auto noauto,owner,ro 0 0


p.s. now i saw some kind of error : "mount: block device /dev/cdrom is write-protected, mounting read-only"

I assume that the above is from your fstab. According to this, it will not be mounted automatically, and can only be mounted by the owner. (Pretty sure that means the owner of the mount point.)

First, how do you know that /dev/cdrom is the right device? Are there some others in /dev? ...or in /dev/usb?

jschiwal 12-04-2006 03:36 PM

Code:

/dev/cdrom /mnt/cdrom auto noauto,owner,ro 0 0
The first auto means the filetype is selected automatically. You might try using "iso9660" and see if that helps. The second "noauto" means that this line is ignored during bootup when the system runs "mount -a". You want this option for all removable media, because if a disc or usb pendrive isn't present, it can't be mounted and would cause the bootup to fail. Consider the possibility that the disc or drive is bad.

What kind of disc are you trying to mount. You don't mount music cd's. A program like xmms plays the disc from the raw device /dev/cdrom.

dragon1te 12-05-2006 03:03 AM

omg ... somehow now its working fine ... i dont know what i was doin wrong ... sorry for wasting your time. and thx to everybody tring to help!!! :>


All times are GMT -5. The time now is 10:57 PM.