LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-26-2008, 10:43 PM   #1
bophster
LQ Newbie
 
Registered: Feb 2008
Posts: 12

Rep: Reputation: 0
I Can't Use the Microphone on The Debian Etch


Please help me. I'm having a hard time trying to get my microphone to work under the Debian Etch OS. Currently, I'm using the HDA Intel card with Sigmatel chips no. STAC9221 A2. I already uninstalled and reinstalled the Alsa driver and the Alsa Oss. I also installed the Kmix and run alsamix but nothing seemed to work. This is driving me crazy. I suspect it's the hardware. If so, should I buy a new sound card? Would it fix the problem? Thank you in advance.
 
Old 02-27-2008, 09:16 AM   #2
Larry Webb
LQ Veteran
 
Registered: Jul 2006
Location: Crystal Beach, Texas
Distribution: Suse for mail +
Posts: 5,100
Blog Entries: 7

Rep: Reputation: 229Reputation: 229Reputation: 229
What type and model computer (Desktop or laptop)?
 
Old 02-27-2008, 02:28 PM   #3
mrrangerman
Member
 
Registered: Oct 2007
Location: MI
Distribution: Debian Slackware
Posts: 528

Rep: Reputation: 59
Have you checked to see if the mic is un-muted in alsamixer?

In a terminal type alsamixer use your arrow keys to navigate to mic, press the m key to unmute if it is muted, esc. to exit.
 
Old 02-27-2008, 03:47 PM   #4
GSX
Member
 
Registered: Feb 2005
Location: Germany
Distribution: Debian Etch, kernel 2.6.18
Posts: 103

Rep: Reputation: 15
Hi...

I have some additional questions to your prob..

-Do your normal sound work on your machine?
-Do you try to get a normal microphone or microphone via headset to work?

Greetz
gsx
 
Old 02-28-2008, 01:18 AM   #5
bophster
LQ Newbie
 
Registered: Feb 2008
Posts: 12

Original Poster
Rep: Reputation: 0
Thank you for all of your help. To answer your questions, I've run alsamixer and unmuted the microphone. I tried this on both the alsamixer and kmix. The sound works fine. I'm able to watch and listen to youtube and mp3 files. I could hear the other person on the other end of Skype but he couldn't hear me. As far as what kind of computer is concerned, I built it myself using ECS motherboard and Intel Celeron 430 processor. Any suggestions? Should I get an extra sound card?
 
Old 02-28-2008, 01:19 AM   #6
bophster
LQ Newbie
 
Registered: Feb 2008
Posts: 12

Original Poster
Rep: Reputation: 0
Oh, I also tried two kinds of microphone that you mentioned.
 
Old 02-28-2008, 08:30 AM   #7
Larry Webb
LQ Veteran
 
Registered: Jul 2006
Location: Crystal Beach, Texas
Distribution: Suse for mail +
Posts: 5,100
Blog Entries: 7

Rep: Reputation: 229Reputation: 229Reputation: 229
In kmix you also have to turn on the capture and if you have the graphical make sure the slide is all the way to the bottom. (You will find this under the "input tab". I doubt if a sound card will solve your problems, I had to work for a couple of days my first shot at it.

Last edited by Larry Webb; 02-28-2008 at 08:33 AM.
 
Old 03-01-2008, 08:53 PM   #8
GSX
Member
 
Registered: Feb 2005
Location: Germany
Distribution: Debian Etch, kernel 2.6.18
Posts: 103

Rep: Reputation: 15
In case you try to use an usb headset, you have two sound devices...to configure the second device configure it using the command
Code:
alsamixer -c 1
 
Old 03-04-2008, 11:05 PM   #9
bophster
LQ Newbie
 
Registered: Feb 2008
Posts: 12

Original Poster
Rep: Reputation: 0
Hi all,
The problem is still there. I can't get my microphone to work. Any more suggestions? I really like my Debian Etch. Should I switch to Ubuntu? Would it solve this problem?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Microphone Doesn't Work with Debian Etch bophster Linux - Newbie 1 02-21-2008 09:20 PM
Microphone doesn't work on Skype under Debian Etch bophster Linux - Newbie 1 02-11-2008 05:24 AM
Can't turn off microphone in Etch Tillus Debian 0 08-29-2007 06:48 AM
Can't get microphone working in Debian Etch (testing) Winter Knight Linux - General 1 03-01-2007 07:14 AM
update Debian testing etch RC1 to etch stable cccc Debian 11 01-08-2007 11:02 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 09:18 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration