LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-22-2017, 01:30 AM   #1
Radocruz
LQ Newbie
 
Registered: Sep 2017
Location: Washington
Posts: 3

Rep: Reputation: Disabled
Question I am having video driver issues with debian based linux systems.


I have a 1080ti Kingpin, free drivers do not yet seem to support it but proprietary drivers do.

Every time I boot a debian based OS the display always ends up turning off and it leaves me with nothing I can do and when I run Kali linux it gets stuck on, "Started Update UTMP about System Runlevel Changes."

I tried Manjaro with Calamares and its options, I first tried free drivers and the display turned off on boot sequence yet when I changed the option to nonfree drivers, the Manjaro live system booted up with no issue and ran flawlessly.

How do I change any current debian based OS booting off of GRUB to use proprietary instead of free?

Thank you for reading.
 
Old 09-22-2017, 01:50 AM   #2
Shadow_7
Senior Member
 
Registered: Feb 2003
Distribution: debian
Posts: 4,000
Blog Entries: 1

Rep: Reputation: 846Reputation: 846Reputation: 846Reputation: 846Reputation: 846Reputation: 846Reputation: 846
nVidia.com

You have to install them (through non-distro means). For relatively new hardware < 2 years old, you might find debian testing or sid to work better for you. You can work around the blanking screen issue though.

$ xset -dpms s noblank s noexpose

And the screen should no longer blank (after 10 minutes). Sometimes you can recover from a blank screen with the Control+Alt+F# keys. Switches to a console, then switches back to a gui (F1 or F7 most times). Technically it's alt+F# from a console (or was it control+?), but the Control+Alt+F# option works too. Although nVidia drivers have always been the most "quirky" IMO when it comes to unix-isms. Not that I've had much nVidia exposure beyond the ge force 6k-ish days.
 
Old 09-22-2017, 02:10 AM   #3
Radocruz
LQ Newbie
 
Registered: Sep 2017
Location: Washington
Posts: 3

Original Poster
Rep: Reputation: Disabled
The screen doesn’t just blank, it turns off. I tried the console keys and nothing worked. I figured that this new card wouldn’t get too much support for the time being. About Debian testing, it seems kind of risky, is it safe enough to use as a desktop?

Last edited by Radocruz; 09-22-2017 at 11:00 AM.
 
Old 09-22-2017, 05:49 AM   #4
pan64
LQ Guru
 
Registered: Mar 2012
Location: Hungary
Distribution: debian/ubuntu/suse ...
Posts: 13,576

Rep: Reputation: 4341Reputation: 4341Reputation: 4341Reputation: 4341Reputation: 4341Reputation: 4341Reputation: 4341Reputation: 4341Reputation: 4341Reputation: 4341Reputation: 4341
you can try ubuntu instead of debian. But if you have no other choices you can try debian testing too.
 
Old 09-22-2017, 06:17 AM   #5
Shadow_7
Senior Member
 
Registered: Feb 2003
Distribution: debian
Posts: 4,000
Blog Entries: 1

Rep: Reputation: 846Reputation: 846Reputation: 846Reputation: 846Reputation: 846Reputation: 846Reputation: 846
The last time I had an issue like that it was an nVidia GPU. But shortly there after the monitor went out. Jumping between consoles and X got it to recover at first. Then less and less, then never. The it was a matter of every other or more boot it worked. The xset command keeps it from blanking in the first place. So if it's working, it should (in theory) stay working.
 
Old 09-22-2017, 06:20 AM   #6
Shadow_7
Senior Member
 
Registered: Feb 2003
Distribution: debian
Posts: 4,000
Blog Entries: 1

Rep: Reputation: 846Reputation: 846Reputation: 846Reputation: 846Reputation: 846Reputation: 846Reputation: 846
There could be other issues too. Like too many things on a single plug. Slap a modern 1000W computer, a 450W display, and 2x 225W studio monitors (speakers) on a single plug, and it's not long before you're wondering who's smoking when you're the only one home and you don't smoke.
 
Old 09-22-2017, 11:14 AM   #7
Radocruz
LQ Newbie
 
Registered: Sep 2017
Location: Washington
Posts: 3

Original Poster
Rep: Reputation: Disabled
News flash: Debian boots at a lower res than my screen. It boots at 10 something x 500

Ubuntu flat out doesnít pro, the screen turns off and everything.

Just about any other Debian based distro has the same issue.

How do I enter that no blank command because it doesnít acknowledge it when I enter the noblank command and it says the command canít be found.

And itís not a power issue as I have had this pc hooked up for some time with windows ten. In Manjaro live boots (I used every flavor with an experiment of trying both free and nonfree.) I could select the graphic propriety drivers with no problems whereas with free drivers I had issues every time.

I checked my electrical connections and everything is just fine. I know itís not electrical because all the errors I get are graphical.

Is there a way I can edit the boot files or use the GRUB command to change the out of the box drivers options?
 
Old 09-22-2017, 11:21 AM   #8
pan64
LQ Guru
 
Registered: Mar 2012
Location: Hungary
Distribution: debian/ubuntu/suse ...
Posts: 13,576

Rep: Reputation: 4341Reputation: 4341Reputation: 4341Reputation: 4341Reputation: 4341Reputation: 4341Reputation: 4341Reputation: 4341Reputation: 4341Reputation: 4341Reputation: 4341
you need to give us more info, otherwise hard to give usable tips. http://catb.org/~esr/faqs/smart-ques...html#beprecise
 
Old 09-22-2017, 02:12 PM   #9
DVOM
Member
 
Registered: Nov 2010
Posts: 223

Rep: Reputation: 48
Quote:
Originally Posted by Radocruz View Post
The screen doesnít just blank, it turns off. I tried the console keys and nothing worked. I figured that this new card wouldnít get too much support for the time being. About Debian testing, it seems kind of risky, is it safe enough to use as a desktop?
What I've done is to set my sources.list to "testing/buster/sid" to find what I need, then when I'm done, I switch it back to stretch.
 
Old 09-22-2017, 02:41 PM   #10
IsaacKuo
Senior Member
 
Registered: Apr 2004
Location: Baton Rouge, Louisiana, USA
Distribution: Debian 9 Stretch
Posts: 2,351
Blog Entries: 8

Rep: Reputation: 384Reputation: 384Reputation: 384Reputation: 384
Honestly, the easiest way to do what you want is to first do a MINIMAL Debian install. At the software selection step uncheck everything.

This will bring up up to a text only console login prompt, with no Xorg video drivers installed at all. This way, you can manually install the nVidia proprietary driver via text commands BEFORE booting up to a graphical X environment. Therefore, my suggested steps are:

1) Do a MINIMAL Debian install. Uncheck all software suites at the software selection step.

2) Log in as root, and do the following command:

Code:
apt-get install xorg xfce4 lightdm
Replace "xfce4" with whatever desktop environment you prefer. This is for a basic xfce4 install, assuming you know specifically what other software you want to install later. If you prefer the default Debian Desktop Environment software suite, install task-xfce-desktop instead.

3) With a text editor (either pico or vi), edit /etc/apt/sources.list using the command pico /etc/apt/sources.list

You will want to add " contrib non-free" after "main" to the end of all lines.

4) Run the following commands:

Code:
apt-get update
apt-get dist-upgrade
dpkg --add-architecture i386
apt install firmware-linux nvidia-driver nvidia-settings nvidia-xconfig
nvidia-xconfig
This will install the proprietary nVidia driver from Debian's non-free software repositories. Note that Debian is fundamentally an open source free software project. Software which is not available under an open source license will always be "second class" within Debian.

5) Reboot with:

Code:
shutdown -r now
The nVidia driver in Debian's non-free software repository might not be the very latest. If you want to install nVidia's latest instead, refer to the bottom part of this reference:

https://linuxconfig.org/how-to-insta...-stretch-linux

So, what's the fundamental source of your problem? The fundamental problem is the way nVidia does not release their video drivers in a way which many linux distributions can readily integrate. In contrast, the way Intel does it is better for linux distributions.
 
1 members found this post helpful.
Old 09-23-2017, 02:22 AM   #11
Shadow_7
Senior Member
 
Registered: Feb 2003
Distribution: debian
Posts: 4,000
Blog Entries: 1

Rep: Reputation: 846Reputation: 846Reputation: 846Reputation: 846Reputation: 846Reputation: 846Reputation: 846
Debian tends to default to the lowest common denominator. Multiple screens and the resolution common to all of them (1024x768). Using xrandr after starting X can adjust resolutions to more native ones in a setup more to your liking.
 
Old 09-30-2017, 11:29 AM   #12
sevendogsbsd
Senior Member
 
Registered: Sep 2017
Posts: 1,361

Rep: Reputation: 538Reputation: 538Reputation: 538Reputation: 538Reputation: 538Reputation: 538
The issue is probably that the Nouveau drivers (open source nvidia driver) do not support your card. Been through this many times - basically, when you boot an installation disk, before you boot you need to edit the grub configuration and add "nomodeset" to the line referencing the kernel you are about to boot. Once you get to a desktop using the terribly slow "vesa" driver, which is what you will be using at that point, is to install the proprietary Nvidia driver, if the distro you are playing with has it in their repos. Manjaro graciously provides the nvidia driver at the time of booting the install image and then installs it automatically if you chose "non-free" at that point.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Consistent video driver issues with Linux Mint 18.1 IceCreamBrownies Linux - Software 1 03-28-2017 03:47 PM
Shell script to compile a custom Linux kernel on Debian-based systems Kenny_Strawn Linux - Kernel 3 09-25-2010 02:29 PM
LXer: Linux buffer overflow issues on Power-based systems LXer Syndicated Linux News 0 01-08-2009 01:40 AM
Debian Etch Nvidia driver issues Quadro nvs290 is the video card bluehaze Linux - Newbie 2 11-06-2008 03:52 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 12:30 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration