LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-27-2014, 02:17 AM   #1
diablo046
LQ Newbie
 
Registered: Jun 2014
Posts: 21

Rep: Reputation: Disabled
HP Proprietary plugin require message showing..


Hi all, My OS is CENTOS 6.5 and i am trying to access a HP printer through CUPS in my lan...i have installed hp-plugin 3.12 version...but when i try to print a test page it ask for propietary binary plugin requires message. However I can print from the same printer using windows machine.My printer is HP 1108 usb printer and it is connected to our cups server.
By the way, the installed printer automatically appears in my printing menu and i can print with no problem if i am on same lan.But if i try to add the printer manually..it adds successfully,but not able to print.My problem is i am moving behind squid proxy network and when i change my network,i am unable to view the printer that appears automatically.So i need to install the printer manually, so if my proprietary plugin problem resolve, i can shift my current network behind the proxy.Please guide.

Last edited by diablo046; 09-27-2014 at 02:27 AM.
 
Old 09-27-2014, 07:22 PM   #2
ferrari
Senior Member
 
Registered: Sep 2003
Location: Auckland, NZ
Distribution: openSUSE Leap
Posts: 2,364

Rep: Reputation: 374Reputation: 374Reputation: 374Reputation: 374
The required proprietary firmware is usually installed automatically when installing using 'hp-setup', but it can be done as a separate step using the 'hp-plugin' utility.

Read the following:

http://hplipopensource.com/node/309

http://hplipopensource.com/node/332

Hope that helps.
 
Old 09-27-2014, 07:42 PM   #3
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 17,243

Rep: Reputation: 2527Reputation: 2527Reputation: 2527Reputation: 2527Reputation: 2527Reputation: 2527Reputation: 2527Reputation: 2527Reputation: 2527Reputation: 2527Reputation: 2527
was the printer pluged in when you installed centos6 ?
if so all the needed hp/hplip software should have been auto installed
( the "HP control center" might be an exception to that)

the best way to set up the printer is using the CUPS web interface
http://localhost:631/
the link above is for your system

just set up the printer
fallow the on screen instructions
 
Old 09-29-2014, 12:52 AM   #4
diablo046
LQ Newbie
 
Registered: Jun 2014
Posts: 21

Original Poster
Rep: Reputation: Disabled
Thank you guys for your answers....I can print directly if i connect the printer usb in my Linux desktop,it wont ask for any plugin...but when i manually try to add the printer (by ipp or https) i face the plugin requiremnet problem.By using windows machine i can successfully print from cups server.I have opened all the required ports ie 631,161,162,9100 (both tcp and udp),but till now no luck
 
Old 09-29-2014, 03:58 AM   #5
ferrari
Senior Member
 
Registered: Sep 2003
Location: Auckland, NZ
Distribution: openSUSE Leap
Posts: 2,364

Rep: Reputation: 374Reputation: 374Reputation: 374Reputation: 374
Strange.... maybe consider reporting the behaviour

http://hplipopensource.com/hplip-web/support.html
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
City of New York to require looking at FOSS before proprietary software jeremy Linux - News 0 05-29-2014 11:44 AM
Slackware 14.1 vs. proprietary NVidia drivers (+ Thunderbird Lightning plugin) kikinovak Slackware 4 12-14-2013 10:13 AM
Installed Ubuntu 13.10 on an Asus 1215T (ATI Avivo). Proprietary drivers not showing Changes Linux - Laptop and Netbook 4 11-26-2013 01:54 PM
ATI Radeon: Do the newer cards require proprietary firmware? hydraMax Linux - Hardware 2 04-19-2013 09:36 AM
Flash Plugin in Opera 7.11. Not showing up on plugin list even. binarynova Linux - Software 4 02-05-2004 08:21 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 09:16 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration