LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   HP Pavilion ze4210 Doesn't recognize all of RAM Upgrade (https://www.linuxquestions.org/questions/linux-newbie-8/hp-pavilion-ze4210-doesnt-recognize-all-of-ram-upgrade-650152/)

philb1 06-18-2008 03:08 PM

HP Pavilion ze4210 Doesn't recognize all of RAM Upgrade
 
I just installed 512MB to my laptop. I originally had 256MB. It will only recognizes 512MB and of course should be reading about 756MB minus the 64MB for video. (actually 768MB minus 64MB)

I tried two sticks of 512MB and it still only reads 512MB. I understand it should be able to handle up to 1GB.

what is my problem. I have swapped sockets and many various combinations with the RAM chips but it will never see more than 512MB.
I have even sent back 512MB chips thinking they were bad and had new ones sent again. still doesnt recognize all the RAM installed.

Help

New Comer,
Philb1

superdog 06-18-2008 05:33 PM

You may need a bios upgrade. I wouldn't upgrade my bios unless I absolutely had to and knew it would solve the problem though.

philb1 06-19-2008 06:43 AM

Where do I find a BIOS upgrade?

philb1 06-19-2008 06:49 AM

HP Pavilion RAM UPgrade
 
I should mention of course that i am useing WinXP.

farslayer 06-19-2008 07:22 AM

it could very well be that that system will not support that much memory..

sometimes lshw will be able to identify how much RAM a system will support, if lshw is not on your system you should be able to add it through your package manager.

Code:

it-etch:~# lshw -C memory
  *-firmware             
      description: BIOS
      vendor: Dell Inc.
      physical id: 0
      version: 1.1.2 (12/04/2006)
      size: 64KiB
      capacity: 448KiB
      capabilities: pci pnp apm upgrade shadowing cdboot bootselect edd int13floppytoshiba
 int5printscreen int9keyboard int14serial int17printer acpi usb ls120boot biosbootspecification
 netboot
  *-cache:0
      description: L1 cache
      physical id: 700
      size: 16KiB
      capacity: 16KiB
      capabilities: internal write-back data
  *-cache:1
      description: L2 cache
      physical id: 701
      size: 2MiB
      capacity: 2MiB
      capabilities: internal varies unified
  *-memory
      description: System Memory
      physical id: 1000
      slot: System board or motherboard
      size: 1GiB
      capacity: 2GiB
    *-bank:0
          description: DIMM DDR Synchronous 533 MHz (1.9 ns)
          product: KHU006-QIA
          vendor: 7F98000000000000
          physical id: 0
          serial: A03XXXXX
          slot: DIMM_1
          size: 1GiB
          width: 64 bits
          clock: 533MHz (1.9ns)
    *-bank:1
          description: DIMM DDR Synchronous 533 MHz (1.9 ns) [empty]
          vendor: FFFFFFFFFFFFFFFF
          physical id: 1
          serial: FFFFFFFF
          slot: DIMM_3
          width: 64 bits
          clock: 533MHz (1.9ns)
it-etch:~#

If you look at the output, this system is telling me it will support at most 2GB of RAM, and I currently have 1 GB installed. There is no BIOS upgrade available for this system to push that to 4GB..

If you don't have Linux installed on that machine, you could try this from a Knoppix LIVE CD. Windows doesn't have any way to provide this information that I have ever found.


Hmm the Specs for that laptop say you can get 1GB installed on that Laptop.. maybe you purchased the wrong type of memory module ? Registered vs. unregistered, or something like that..

I was hoping Kingston would provide a bit more detqail on teh memory specs..


Have you tried booting it with JUST one of the 512MB modules installed ? See if only one is good or worst case you have a BAD memory socket on the motherboard.. I've had brand new notebooks with bad memory sockets :(

BIOS upgrade for ze4210 !! PLEASE VERIFY THIS IS THE CORRECT BIOS BEFORE FLASHING YOUR LAPTOP BIOS !!

alan_ri 06-19-2008 07:28 AM

Quote:

Originally Posted by philb1 (Post 3189169)
Where do I find a BIOS upgrade?

On your BIOS manufacturer web site,if there is a linux package and if it is be very careful with upgrade because you may end up with broken system.
Suggestion,512MB of RAM + swap on Linux is more then enough for almost anything,so keep it that way and you'll be fine.


All times are GMT -5. The time now is 05:39 PM.