LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   howto remote session (kde, ...) on SuSE 9 (https://www.linuxquestions.org/questions/linux-newbie-8/howto-remote-session-kde-on-suse-9-a-162994/)

fdurodie 03-27-2004 10:01 AM

howto remote session (kde, ...) on SuSE 9
 
Hi,

I'd like to be able to start a remote session (e.g. KDE) on my SuSE9 PC from my Windows PC using cgwin. How do I go about or where can I find information on this. I've been able to do this on a RH9 PC through XDMCP but I can't seem to find this on SuSE.

Thanks
Kind regards,
Frédéric

19cool53 04-10-2004 06:26 PM

I use gnome as display manager.
ps aux shows me a running gdm (no kdm)

After changing the following my xdmcp is working:

1) in /etc/inittab
uncomment the line #7:3:respawn:+/etc/init.d/rx.tty7
2) in /etc/opt/gnome/gdm/gdm.conf
change in section [xdmcp]
line: Enable=true (default = false)
3) in /etc/opt/kde3/share/config/kdm/kdmrc
change in section [xdmcp]
line: Enable=true (default = true)
4) in /etc/X11/xdm/Xaccess
removed # in front of #* #any indirect host can get...............
5) in /etc/X11/xdm/xdm-config
put an ! before last line: !Displaymanager.requestport: 0

I use cygwin as an XWindows client and changed the startxdmcp.bat:
SET REMOTE_HOST=%1

Start XWindows from command line: " startxdmcp ip_of_host " [or dns_name]



:study: 19cool53

fdurodie 04-11-2004 11:32 AM

Thanks. Below is a solution from another forum for KDE.
It worked immedialy after that.

Modify the file
/etc/opt/kde3/share/config/kdm/kdmrc
change Enable=false to Enable=true in the XDMCP section.


Frederic


All times are GMT -5. The time now is 12:30 PM.