LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-07-2017, 01:26 AM   #1
p\_/ppy
LQ Newbie
 
Registered: May 2016
Posts: 14

Rep: Reputation: Disabled
how to use Myanmar3 font in slacko64 puppy linux


my layouts are us U.S. English, mm Myanmar.
I have myanmar fonts in my /usr/share/fonts/TTF/.
I wanna type with Myanmar 3 font in LibreOffice but I don't know how to change.
I can choose Myanmar 3 font, but English letters still appear.
Help me and Thank you all.
 
Old 01-07-2017, 09:50 AM   #2
beachboy2
Senior Member
 
Registered: Jan 2007
Location: Wild West Wales, UK
Distribution: Linux Mint 20.1 MATE, MX-19.3, antiX, EndeavourOS
Posts: 3,334
Blog Entries: 17

Rep: Reputation: 1263Reputation: 1263Reputation: 1263Reputation: 1263Reputation: 1263Reputation: 1263Reputation: 1263Reputation: 1263Reputation: 1263
p\_/ppy,

Welcome to LQ.

Open LibreOffice Writer > Tools > Options > Language Settings > Languages > Default Language for Documents > Put “X” in the box next to Complex Text Layout > select Burmese > click on OK.

See attached screenshots.
Attached Thumbnails
Click image for larger version

Name:	Screenshot.png
Views:	26
Size:	128.7 KB
ID:	23904   Click image for larger version

Name:	Screenshot2.png
Views:	19
Size:	128.9 KB
ID:	23905  

Last edited by beachboy2; 01-07-2017 at 10:05 AM.
 
Old 01-08-2017, 10:19 AM   #3
p\_/ppy
LQ Newbie
 
Registered: May 2016
Posts: 14

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by beachboy2 View Post
p\_/ppy,

Welcome to LQ.

Open LibreOffice Writer > Tools > Options > Language Settings > Languages > Default Language for Documents > Put X in the box next to Complex Text Layout > select Burmese > click on OK.

See attached screenshots.
I tried, but no luck.
Attached Thumbnails
Click image for larger version

Name:	Screenshot.jpg
Views:	17
Size:	80.0 KB
ID:	23918   Click image for larger version

Name:	Screenshot(1).jpg
Views:	19
Size:	57.6 KB
ID:	23919  
 
Old 01-08-2017, 10:56 AM   #4
DavidMcCann
LQ Veteran
 
Registered: Jul 2006
Location: London
Distribution: PCLinuxOS, Debian
Posts: 5,791

Rep: Reputation: 2153Reputation: 2153Reputation: 2153Reputation: 2153Reputation: 2153Reputation: 2153Reputation: 2153Reputation: 2153Reputation: 2153Reputation: 2153Reputation: 2153
You've installed the font and told the word processor that you will be using it, but you haven't set up the input. You need to tell the GUI that you want to use two keyboard layouts and to tell it which one you want.

Go to the menu and choose Setup - Mouse/keyboard Wizard.
Click on Advanced and Layouts to add Burmese.
Click on Options and
> select GroupShift. That sets the key to toggle the keyboard drivers: scroll lock is a good choice.
> select Keyboard LED. That enables you to select the scroll-lock light to show when you've switched to Burmese.
> Compose key. That's useful thing to set while you're there (see Wikipedia) and Menu (the thing between right Windows and right Control) is a convenient choice.
 
2 members found this post helpful.
Old 01-09-2017, 12:32 AM   #5
p\_/ppy
LQ Newbie
 
Registered: May 2016
Posts: 14

Original Poster
Rep: Reputation: Disabled
Quote:
You've installed the font and told the word processor that you will be using it, but you haven't set up the input. You need to tell the GUI that you want to use two keyboard layouts and to tell it which one you want.

Go to the menu and choose Setup - Mouse/keyboard Wizard.
Click on Advanced and Layouts to add Burmese.
Click on Options and
> select GroupShift. That sets the key to toggle the keyboard drivers: scroll lock is a good choice.
> select Keyboard LED. That enables you to select the scroll-lock light to show when you've switched to Burmese.
> Compose key. That's useful thing to set while you're there (see Wikipedia) and Menu (the thing between right Windows and right Control) is a convenient choice.
Thanks a lot!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Changing default applications doesn't work Slacko64 6.9.5 alpha Gordie Puppy 2 09-10-2016 06:00 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 01:01 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration