LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-26-2010, 11:08 PM   #1
riller
LQ Newbie
 
Registered: Mar 2010
Posts: 13

Rep: Reputation: 0
Question How to start up a net connection with pure terminal?


I type in ifconfig eth0 up, it says Device not found.

Sys: Fedora12, ethnet, laptop.

When I can get in X, I can manage my network with network-management, or with gnome-terminal. In X, I can start a net with "ifconfig eth0 up", when I type in "ip link", It shows like
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 16436 qdisc noqueue state UNKNOWN
link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP qlen 1000
link/ether 00:26:22:de:c0:94 brd ff:ff:ff:ff:ff:ff
3: wlan0: <BROADCAST,MULTICAST> mtu 1500 qdisc mq state DOWN qlen 1000
link/ether 00:26:c6:4f:79:2a brd ff:ff:ff:ff:ff:ff

BUT right now, I get problems with X and can't get in it. I want to start a net connection in pure terminal and work with it. However, it replys "Device not found" to "ifconfig eth0 up". Answer to "ip link" was
lo: <LOOPBACK,UP,LOWER_UP> mtu 16436 qdisc noqueue state UNKNOWN
link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
and no more.
Where is my eth0 then? How can I start a net with it?
 
Old 03-26-2010, 11:13 PM   #2
Mr-Bisquit
Member
 
Registered: Feb 2009
Distribution: FreeBSD, OpenBSD, NetBSD, Debian, Fedora
Posts: 770
Blog Entries: 52

Rep: Reputation: 68
Code:
$su <or sudo>
Password:
# ifconfig -a
What type of NIC do you have and what laptop model?
Wireless will need the firmware loaded and for iwconfig to be used.
 
Old 03-26-2010, 11:44 PM   #3
saagar
Member
 
Registered: Jul 2008
Location: Chennai, India
Distribution: RHEL5, Ubuntu
Posts: 191

Rep: Reputation: 37
I think Fedora is not able to find a driver for the network card. Post your laptop model, experts will help.

Last edited by saagar; 03-26-2010 at 11:50 PM.
 
Old 03-27-2010, 12:36 AM   #4
riller
LQ Newbie
 
Registered: Mar 2010
Posts: 13

Original Poster
Rep: Reputation: 0
The whole problem is quite complex for me...
about 2 days ago, after a handful of updates and a restart, my Fedora12 refuse to get in X with latest kernel. "module nvidia not found". Reinstall end with
nvidia: Unknown symbol i2c_del_adapter
nvidia: Unknown symbol i2c_add_adapter
in the log.
I edit xorg.conf and enter X with nouveou and a previous kernel, but now I find it has some problem with terminal(gnome-terminal is ok). When I press ctrl+alt+F1-F6, it give me some mosaic.
Right now, I get 3 kernels: latest one can't get in X and can get in terminal.
previous one can get in X, but without a terminal.
the original one, I havn't test yet.

Now it's perfectly OK to connecting net with the previous kernel with X or gnome-terminal. But it don't have a terminal.
I can't get a net with the latest kernel with terminal, as ifconfig can't find a device.
The original kernel works just like the previous one. Seems as if sth is wrong with the nouveou. I want to have a net to reinstall it on the latest kernel.

I don't know whether things above would help.

Last edited by riller; 03-27-2010 at 01:01 AM.
 
Old 03-27-2010, 12:55 AM   #5
Mr-Bisquit
Member
 
Registered: Feb 2009
Distribution: FreeBSD, OpenBSD, NetBSD, Debian, Fedora
Posts: 770
Blog Entries: 52

Rep: Reputation: 68
I'd edit out the new kernel and let the old one boot.
Also, you may need to build the modules for the kernel you are having trouble with.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Script using cnetworkmanager to start a NetworkManager connection from a terminal. PTrenholme Linux - Networking 0 09-07-2009 08:34 PM
Pure-FTPD connection problems zootboy Linux - Server 5 01-13-2009 08:57 PM
Cannot start pure-ftpd kiaraho Linux - Software 2 02-20-2004 12:03 PM
pure-ftpd connection problem bbaum Linux - Software 1 01-07-2004 03:46 PM
idea: sharing net connection, method: iptables..., problem: broken net connection :( danny2055 Linux - Networking 4 06-09-2003 08:00 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 08:17 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration