-   Linux - Newbie (
-   -   How to setup the internet connection on Slackware 12.2? (

legeipsnelU 12-24-2008 04:47 AM

How to setup the internet connection on Slackware 12.2?
Hi guys! Here is the info on the network: my host is connected to a router(via WiFi), router is connected to a DSL modem. A typical dorm network.

I get the signal, connect to the wireless network and the connection is Ok. But I still don't have a connection to the internet. Since it's a Slackware, I think I'd have to "tell" my OS manually where to send the generated packets. So, I guess I have to specify the IP of my edge router as a gateway to the Internet. And I also don't know whether I have to assign myself an IP and if yes then how to do it. From my Ubuntu 8.10 I've run "traceroute" to get the IP of the router and it found out to be

Now, could you, please, tell me which steps exactly do I have to take in order to set the router as a gateway and get connected to the Internet? I have to use "route" somehow. I know that there is info on in in the web, but it's really hard to experiment, since I have to switch between my Slackware and Ubuntu Live Disk. Once I get connected from Slack, I'd be able to practise Slack normally, without asking trivial questions.

Thanks is advance & Happy Xmas.

business_kid 12-24-2008 05:10 AM

Start learning:

There's plenty out there. Make sure of your /etc/hosts, /etc/resolv.conf, and /etc/host.conf - as a last resort read the PPP-HOWTO from chapter 10(when he finally gets to the subject) onwards.

Then you need to connect. presuming your wireless card is automagically set up, try 'dhcpcd wlan0' or whatever it is. Get online and start reading. Put in "your errors" into google and press search. Google will show you previous posts from people who had this.

legeipsnelU 12-25-2008 08:10 AM

Hi again. I haven't got any connection yet, but at least I've understood a bit about that network stuff.

Please correct me if I'm wrong, but what I have to do is:
1) Set my IP address via "ifconfig wlan0 [myIp] netmask [myNetmask]"
2) Set a route to my edge router via "route add -net [routerIp] netmask [routerMask] dev wlan0"
3) Set a default gateway for my packets via "route add default gw [routerIp]"
4) Edit "/etc/resolv.conf" appending there "nameserver [dnsIp]"
5) Activate my WLAN card and connect to a network.
6) Enjoy my web browsing...

Even if all of the steps are correct I still don't understand something. While being able to normally surf in the internet with my "Ubuntu 8.10 Live" I try to get all the IP addresses I need for my configuration of the network in Slackware. So, I run "ifconfig wlan0" and in "inet addr" field it shows me that my IP is "". Then I run "traceroute" to get the IP of my edge router and in the first line of the route it shows me exactly "". Finally I examine "resolv.conf" and what I see there is "nameserver". I'm host & router & DNS. Howcome? How can I get correct values of IP in order to use them in my Slackware network configuration. Thanks in advance.

ErV 12-25-2008 09:37 AM


Originally Posted by legeipsnelU (Post 3386867)
Please correct me if I'm wrong, but what I have to do is:
1) Set my IP address via "ifconfig wlan0 [myIp] netmask [myNetmask]"
2) Set a route to my edge router via "route add -net [routerIp] netmask [routerMask] dev wlan0"
3) Set a default gateway for my packets via "route add default gw [routerIp]"
4) Edit "/etc/resolv.conf" appending there "nameserver [dnsIp]"
5) Activate my WLAN card and connect to a network.
6) Enjoy my web browsing...

Not quite.

IN slackware network configuration (specifying gateway and ip addresses for cards) is done by either:
1) running netconfig as root
2) manually editing /etc/rc.d/rc.inet1.conf . This file has a lot of comments inside, so it isn't difficult to figure out what is what.

To specify nameservers, you still will have to edit /etc/resolv.conf.

After that you'll have to either reboot machine or run "/etc/rc.d/rc.inet1 restart" as root.

Notice that I have no experience with wireless and it might (or might not) require some additional steps.

Drakeo 12-25-2008 10:03 AM

kcontrol center . net settings you will find it. then click admin type your root password. configure your wlan0 dhcpd then apply save what ever. if you do not need to set a password for your wep. then all is cool then click kde internet more then you will see a wifi program click it and set up your conection.if you ned to put in a passphrase then there is where you do it. if you do a scan then and nothing comes up tells me you need a driver.or your device is not being loaded. .look at in a terminal as root. su then password. then type lsmod if you see your devices module cool but then type lspci -n will give you your card. then you will need to get the drivers. if you have bcm or broadcam chip get the open souce one. if not you will need a ndiswraper why a ndiswrapper or firmware. is because 90 percent of todays hardware are for windows. if though your system recognizes the card it still will need a small program that runs there chip on the card. we use ndiswraper ubuntu uses ndiswrapper except for the bcm broadcom chips. either way. you can try to connect all day and never get the connection.
why does this work off a live disk is because the live disk is set up to do limted things but it also is configured for the net. Slack where is very simple but you need to make sure you have your drivers and stuff.the program ndiswrapper is not on the disk. so you need to get it and install if you have cards that are not working with the kernel.
i use a broadcom chip my module comes with slackware but i have to down load the firmware for it to use the chip.

legeipsnelU 12-25-2008 01:40 PM

Hi. I have no luck with it...
There is no problem with the hardware part. My card is recognized and connects to the wireless network normally. What I cannot do is set up all this internal network configuration stuff. I've edited the "rc.inet1.conf" and "resolv.conf" files manually setting up the IPs.
The IP of DNS I got from the ISPs web site. The IP of my edge router I got from running "traceroute" on my Ubuntu 7.10 Live and it was My own IP I've set to This doesn't work.

I've also tried to use "dhcpcd wlan0" and it just stucks broadcasting the message. The "dhcpcd.conf" file is empty.

What should I do?

Drakeo 12-25-2008 02:12 PM

well my card is reconized right out of the box to they all are lspci reads the chip info. that does not mean the module is loaded for it. My broadcom chip is recognized and it even loads the module but the firm ware drivers need to run it are going to have to be down loaded . That is why ubuntu has automatic set ups when you down load the ndiswrapers or bcm-fmcutter programs. it installs them for you. so what is your device products name. you can read this thread my answer to the cable modem wifi problem.

legeipsnelU 12-25-2008 02:44 PM

My card is "Intel Corporation Wireless WiFi Link 5100MC".

Drakeo 12-25-2008 04:19 PM

thing to give us type of computer note book desk top then post your lspci and your lspci -n then do as I asked you to do get ndiswrapper and use the driver that came from the disk or go here and get the driver you will need the inf file for the ndiswrapper program you have hardware made for xp and vista.
this is the company that makes it.

All times are GMT -5. The time now is 08:02 PM.