LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-24-2007, 06:20 PM   #1
Xzander
LQ Newbie
 
Registered: Sep 2007
Posts: 7

Rep: Reputation: 0
How to set the resolution?


Hi,

I am using Debian 4.0r1 in VirtualBox with gnome. I have three resolutions available in Desktop/Preference/SetResolution: 1024x768, 800x600 and 640x480. I am currently at 1024x768. I want to downgrade to 800x600. I select 800x600. 61 Hz is selt and nothing else is available. I press apply. X server restarts and I have to login again BUT, the resolution is still at 1024x768. I have removed display modes in 'Screen' section of xorg.conf but it seems to have no effect as 640x480 is still available:

Code:
Section "Files"
	FontPath	"/usr/share/fonts/X11/misc"
	FontPath	"/usr/X11R6/lib/X11/fonts/misc"
	FontPath	"/usr/share/fonts/X11/cyrillic"
	FontPath	"/usr/X11R6/lib/X11/fonts/cyrillic"
	FontPath	"/usr/share/fonts/X11/100dpi/:unscaled"
	FontPath	"/usr/X11R6/lib/X11/fonts/100dpi/:unscaled"
	FontPath	"/usr/share/fonts/X11/75dpi/:unscaled"
	FontPath	"/usr/X11R6/lib/X11/fonts/75dpi/:unscaled"
	FontPath	"/usr/share/fonts/X11/Type1"
	FontPath	"/usr/X11R6/lib/X11/fonts/Type1"
	FontPath	"/usr/share/fonts/X11/100dpi"
	FontPath	"/usr/X11R6/lib/X11/fonts/100dpi"
	FontPath	"/usr/share/fonts/X11/75dpi"
	FontPath	"/usr/X11R6/lib/X11/fonts/75dpi"
	# path to defoma fonts
	FontPath	"/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
	Load	"i2c"
	Load	"bitmap"
	Load	"ddc"
	Load	"dri"
	Load	"extmod"
	Load	"freetype"
	Load	"glx"
	Load	"int10"
	Load	"vbe"
EndSection
Section "InputDevice"
	Identifier	"Generic Keyboard"
	Driver		"kbd"
	Option		"CoreKeyboard"
	Option		"XkbRules"	"xorg"
	Option		"XkbModel"	"pc105"
	Option		"XkbLayout"	"ca"
EndSection
Section "InputDevice"
	Identifier	"Configured Mouse"
	Driver		"mouse"
	Option		"CorePointer"
	Option		"Device"		"/dev/input/mice"
	Option		"Protocol"		"ImPS/2"
	Option		"Emulate3Buttons"	"true"
EndSection
Section "Device"
	Identifier	"Generic Video Card"
	Driver		"vesa"
	BusID		"PCI:0:2:0"
EndSection
Section "Monitor"
	Identifier	"Generic Monitor"
	Option		"DPMS"
	HorizSync	28-64
	VertRefresh	43-60
EndSection
Section "Screen"
	Identifier	"Default Screen"
	Device		"Generic Video Card"
	Monitor		"Generic Monitor"
	DefaultDepth	16
	SubSection "Display"
		Depth		16
		Modes		"1280x800" "1024x768" "800x600"
	EndSubSection
EndSection
Section "ServerLayout"
	Identifier	"Default Layout"
	Screen		"Default Screen"
	InputDevice	"Generic Keyboard"
	InputDevice	"Configured Mouse"
EndSection
Section "DRI"
	Mode	0666
EndSection
When I login, there's a button 'Actions'. If I choose 'Configure the login manager' and enter my root password, there's 'Configure X Server...' under security tab. The server name is 'Standard name', the command is '/usr/bin/X -dpi 96 -audit 0' and Launch is 'Greeter'.

Any idea on how to fix it??

Thank's
 
Old 10-24-2007, 07:13 PM   #2
LlNUX
Member
 
Registered: Oct 2007
Location: Sydney, Australia
Distribution: Debian
Posts: 63

Rep: Reputation: 15
what I would try is to reconfigure X server and when it comes to a question which resolution I want I will try pick just one which I want. This works for me.:-)

Code:
or you can try edit config manually which is not alway good idea:
	SubSection "Display"
		Depth		16
		Modes		"1280x800" "1024x768" "800x600"
	EndSubSection
 
Old 10-25-2007, 08:21 AM   #3
Xzander
LQ Newbie
 
Registered: Sep 2007
Posts: 7

Original Poster
Rep: Reputation: 0
Thank's, i'll try this out.
 
Old 10-25-2007, 07:27 PM   #4
Xzander
LQ Newbie
 
Registered: Sep 2007
Posts: 7

Original Poster
Rep: Reputation: 0
Didn't work...

Any other idea?
 
Old 10-26-2007, 07:51 AM   #5
Xzander
LQ Newbie
 
Registered: Sep 2007
Posts: 7

Original Poster
Rep: Reputation: 0
I found the problem! I had to press 'peripherals'->'Install guest additions' in virtual box to add drivers for the virtual video card. Now everyting works ok. For mor informations, just read 'Guest addition' in virtualbox manual.

Thank's
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Set shell resolution huwnet Linux - General 5 05-17-2010 09:52 AM
resolution will not set transke Linux - Hardware 8 07-16-2004 05:07 AM
How to set screen's resolution giulio_82 Debian 3 02-15-2004 05:30 AM
set resolution pixelV Linux - General 20 12-28-2002 02:33 PM
How can I set the default resolution? DFrey Linux - Newbie 5 11-19-2001 03:33 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 03:11 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration