LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   how to run program? (https://www.linuxquestions.org/questions/linux-newbie-8/how-to-run-program-75386/)

newbe45 07-23-2003 10:25 PM

how to run program?
 
Ok, How do i run a file in linux RH 9 ? I downloaded limewire extracted it and when i try to run the file i get a bunch of text. I tried to search for an answer online but cannot find it. Somebody please help me!

ksgill 07-23-2003 10:35 PM

okay..now you know that you need java runtime environment (http://www.java.com/en/download/linux_manual.jsp ) in order to install limewire? You should install that and then go to the console and type
./LimeWireLinux.bin
cd LimeWire folder
and thn there should be a readme file which will help you about how to use the program.

newbe45 07-23-2003 10:40 PM

OK thanks Jatt_thugz.

ksgill 07-23-2003 10:41 PM

you are welcome

newbe45 07-23-2003 10:51 PM

ok i am lost. how to i run this (java enviroment)

ksgill 07-23-2003 10:56 PM

Just download self-extracting binary from http://www.java.com/en/download/linux_manual.jsp and do this:
./name_of_rpm
then follow the instructions at http://www.java.com/en/download/help...sp#install-pkg

after you are done with that you need to find the directory you installed the java vm in and then you need to set your path variable(which we will do after you finish installing the rpm).

newbe45 07-23-2003 11:07 PM

I am doing something wrong (sorry i am new to linux as u can tell). I did the ./name of rpm and i get [no such directory or file]

ksgill 07-23-2003 11:11 PM

chmod a+x j2re-1_4_1_<version number>-linux-i586-rpm.bin
./j2re-1_4_1_<version number>-linux-i586-rpm.bin
The script displays a binary license agreement, which you are asked to agree to before installation can proceed. Once you have agreed to the license, the install script creates the file j2re-1_4_1_<version number>-linux-i586.rpm in the current directory.
Become root, and then type this:
rpm -iv j2re-1_4_1_<version number>-linux-i586.rpm
replace the version number with the one you downloaded. I got all this from http://www.java.com/en/download/help...sp#install-pkg
I suggest you read this if my explanation doesnt work.

Profanity 07-23-2003 11:11 PM

yes the ./executable didn't work for me either so i just typed executable as it was, i was logged in as root though :).
Question, could these "problems" be apart of the later Kernels ?
Seems as we're regressing instead of progressing..

-----------------------------------------
Windows Registered User # 854411223

newbe45 07-23-2003 11:13 PM

I read that link all ready let me try this again and let u know what happens. Thanks for helping me out!

ksgill 07-23-2003 11:13 PM

did you do this?
chmod a+x j2re-1_4_1_<version number>-linux-i586-rpm.bin

newbe45 07-23-2003 11:15 PM

yes i get this afterwards

chmod: failed to get attributes of `j2re-1_4_1_03-linux-i586-rpm.bin': No such file or directory

ksgill 07-23-2003 11:17 PM

you should have tried using absolute path to the file for example:
/home/guest/j2re-1_4_1_03-linux-i586-rpm.bin

newbe45 07-23-2003 11:19 PM

ok i did that and it worked.

ksgill 07-23-2003 11:25 PM

hmm..okay now install this and look for your installation, it should be in /usr/java if not than type updatedb in console and then:
locate java | more
to find where it is. After you have found it you type this in console->
export PATH=$PATH://usr/java/j2sdk1.4.2/bin
where /usr/java/j2sdk1.4.2/bin is the location where my java commands are, so you will need to modify it according to your installed files. You can add that line to your .bashrc if you want it to be permanent. After you do that just return to where LimeWireLinux.bin is and type ./LimeWireLinux.bin that should do it.


All times are GMT -5. The time now is 12:30 PM.