-   Linux - Newbie (
-   -   How to run messenger on linux (

IronMaiden 12-05-2003 06:25 PM

How to run messenger on linux
I tried AIM, which is the only program that it came with Mandrake Linux 9.2 as an instant messasing.

I tried to log on unto my messenger account and I couldn't do that.

I am new in Linux. Below I show the process.

JayCnrs 12-05-2003 06:48 PM

Are you just using MSN if so give AMSN a shot, you untar the file in your home directory then cd msn ---> amsn

Works no problem.


The Person 12-05-2003 06:49 PM

you need to get the lastest verison of gaim for it to work. The one that is built in doesn't work very well

GT_Onizuka 12-05-2003 08:10 PM

Man have people forgotten how to Search the forums or Google or go to the source (the developer that is) and look at FAQs and stuff? What you need is SSL, that can be provided my GnuTLS or a combination of Mozilla NSS & NSPR. Go to and learn more about it. But you do need a current version of Gaim (I believe the cutoff is .71 or .72) since M$ recently changed the way to access the network or something.

IronMaiden 12-05-2003 08:16 PM

I tried the search in the forum but couldn't find it. And when I search on the internet it always shows something else.

I tried downloading the latest GAIM version which is .74 and it didnt work.


GT_Onizuka 12-05-2003 09:28 PM

Okay first off, the reason it didn't compile is because you are missing libao (as it said). But the reason why MSN isn't connecting is because you don't have SSL installed. Did you bother to look at the FAQ on Gaim's website? When you searched for your problem on the board, did you search for gaim msn not connecting? If you did I can assure you would get lots of threads, all with people who don't seem to know that Gaim has a webpage. That is why man created FAQ's to be looked at. So I would recommend installing SSL by the step-by-step instructions that can be found on Gaim's website OR searching on the forum for the problem OR trying a different protocol (they will work, trust me) and when you have finished installing SSL recompile your current version. If its 0.71 or above, MSN will work without a hitch. Once again, your problem is you don't have SSL compiled on your system. Go to Gaim's FAQ page and there will be a Question similar to yours, in fact, here is said link.

IronMaiden 12-06-2003 02:44 AM

Why is all this so complicated?? To many files to download for just one aplication, it doesnt make much sense. It should be all in one package.... oh man :o

linux is linux hehe

I looked on the FAQS before but I don't have much time to spend to just make the freaking program to work! There is a real lack of information and organization here. You ask one question and you find like a million ways to do it.

I need at least a week to figure this out by myself then..

Thanks anyway...

GT_Onizuka 12-06-2003 09:44 AM

I hardly consider there to be a lack of information or organization. I can understand how you are distraught from the fact that you need to install lots of additional software to get something to work. But all the documentation is right there. The have a walkthough on everything you need to download, with links, and step-by-step instructions to get SSL working on your system so MSN can work. I honestly cannot see how this is a so called lack of documentation or structure.

IronMaiden 12-06-2003 11:43 AM

I got frustated with GAIM and now I am trying aMSN but still frustated. Now with aMSN i need the tcl/tk whatever.

I unpacked those programs and I can't figure out how to run them.

I read the readme files but like always I get error messages (this reminds me of windows).

I went to the console and I type "./configure" in the unix folder of both programs and it worked. But when I type "make" like it says on the readme file it shows:
"make: *** No targets specified and no makefile found. Stop."

When I type "make install" like it says on the manual it shows:
"make: *** No rule to make target `install'. Stop."

The manual says: "If the make fails then you'll have to personalize the Makefile
for your site or possibly modify the distribution in other ways." I wonder what does that mean.

Don't tell me that I have to download another program :eek: :cry:

GT_Onizuka 12-06-2003 12:56 PM

The problem is ./configure wasn't successful otherwise a Makefile would have been created. Look over the output of ./configure and I'm sure you'll find it complaining about the inexsistance of some app here or some lib there.

h/w 12-06-2003 04:14 PM

And now it is time you installed and figured out how to use Urpmi (apt-clone for mandrake?)
The days when people fought over dependencies are long gone - and you should be using this too.

GT_Onizuka 12-06-2003 05:25 PM

The problem is, SSL isn't required for Gaim to run, just MSN, so it won't download the SSL libs it needs (I think, I'm not positive, but I don't think it will). So I doubt doing that will help. It's really not that hard just follow the directions. Linux isn't always going to hold your hand, programs get a lot harder to install than Gaim, just be thankful you have easily recognizable hardware otherwise, you'd be in a lot more trouble.

Inuyasha-kun 12-07-2003 01:58 AM

This is what I get when I try to run install AMSN:
[root@localhost root]# cd '/usr/local/msn'
[root@localhost msn]# make config
make: *** No rule to make target `config'. Stop.
[root@localhost msn]# make
echo "LIB /usr/share/amsn DATA /usr/share/pixmaps BIN /usr/bin"
LIB /usr/share/amsn DATA /usr/share/pixmaps BIN /usr/bin
mkdir -p /usr/share/amsn
mkdir -p /usr/share/pixmaps
mkdir -p /etc/X11/applnk/Internet
mkdir -p /usr/bin
cat /dev/null >
ls: i: No such file or directory
ls: s: No such file or directory
cp: cannot stat `i/messenger.png': No such file or directory

What's with the stupid .PNG? It's just a picture, it has no real value.
This is what I get when I try to run it:
[root@localhost msn]#[root@localhost msn]# ./amsn
/usr/bin/env: wish: No such file or directory

I even have the newest release of TCL/TK. Does anyone have any help?

IronMaiden 12-07-2003 03:01 AM

You are righ the configure shows an error.

creating cache ./config.cache
checking whether to use symlinks for manpages... no
checking compression for manpages... no
checking for gcc... no
checking for cc... no
configure: error: no acceptable cc found in $PATH

What should I do?

GT_Onizuka 12-07-2003 12:18 PM

IronMaiden apparently you don't have GCC or CC which is the compiler for *nix. Ummm, EVERY distribution on the face of the Earth has this program as it is needed to compile... everything. Without it you can't get any more software unless it comes in binary form. First off, what distribution are you using and why don't you have GCC? It is a very important piece of software so I would recommend putting your install CD in and try and install all the GCC related programs in there, otherwise you will never be able to compile stuff from source (that is unless you have another compiler, which I would find odd but ./configure would have found the other one so I assume you just don't have it. Inuyasha-kun, why didn't you run ./configure?

All times are GMT -5. The time now is 12:40 AM.