LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-21-2011, 08:42 AM   #1
LittlePenguin
Member
 
Registered: Jan 2011
Posts: 52

Rep: Reputation: 3
How to recover my Linux installation?


After installing some drivers I got a black screen in the midle of Debian's Squeeze load, no info, no errors, no nothing.

I can boot in recovery mode but I dont have a clue about what to do.

Is there a way to recover or fix my OS without installing all over again?..

Thx.
 
Old 01-21-2011, 09:05 AM   #2
fbt
Member
 
Registered: May 2010
Distribution: Chakra
Posts: 83

Rep: Reputation: 26
I'm guessing you installed video drivers and didn't complete the task completely. More specific information such as distro, drivers and hardware would help
 
Old 01-21-2011, 09:09 AM   #3
LittlePenguin
Member
 
Registered: Jan 2011
Posts: 52

Original Poster
Rep: Reputation: 3
The distro is mentioned in the OP, Im using Debian Squeeze RC1.

My videocard is Ati Sapphire 5850, drivers, I only ran "aptitude install fglrx", thats all, I looked at the log and every seemed ok, no errors.

So, you say I have one (or more) step missing?... crap.
 
Old 01-21-2011, 10:09 AM   #4
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Germany
Distribution: Whatever fits the task best
Posts: 17,148
Blog Entries: 2

Rep: Reputation: 4852Reputation: 4852Reputation: 4852Reputation: 4852Reputation: 4852Reputation: 4852Reputation: 4852Reputation: 4852Reputation: 4852Reputation: 4852Reputation: 4852
Boot into recovery mode and do a
Code:
aticonfig --initial
Then reboot and look if it works.
 
Old 01-21-2011, 01:07 PM   #5
LittlePenguin
Member
 
Registered: Jan 2011
Posts: 52

Original Poster
Rep: Reputation: 3
Quote:
Originally Posted by TobiSGD View Post
Boot into recovery mode and do a
Code:
aticonfig --initial
Then reboot and look if it works.
Thx, but too late aleady installed all again :P

Now I know I dont have to install my videocard drivers, its ok after all Im installing Linux cuz I need to run a web server.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How to recover lost hard disk of Windows due to linux installation Ravinder Singh Thakur Linux - General 3 11-03-2009 03:47 PM
recover windows os if linux installation is not completed mamtasahai1 General 4 01-22-2007 01:33 PM
how can i recover bootloader of redhat linux after win installation mohammad.rafeeq Linux - General 1 08-09-2006 06:02 PM
how to recover GRUB without original installation CD yumener Linux - Software 5 12-07-2005 11:51 AM
to recover linux after windows installation phanee Linux - Software 3 08-05-2005 11:14 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 03:43 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration