-   Linux - Newbie (
-   -   how to print from Linux cups to a Mac shared Printer (

jjjj12212 08-10-2012 12:36 PM

how to print from Linux cups to a Mac shared Printer
Hi Everyone,

I'm stumped on this problem :(

I read documents online, read about IPP with Cups but I am still unable to solve this problem.

On my Mac I have a shared Printer and when I go to localhost:631 on my Mac, it shows:


I enabled Sharing on the Printer and also enabled :
Share printers connected to this system
Allow printing from the Internet

On the Linux, I tried adding it from the <IP>:631,

and using:
ipp://<MAC IP>/printers/HP_Color_LaserJet_3800__62856C_

I have done a test print and it says:
Printer URI is incorrect or no longer exists

I also tried ipp://<MAC IP>/HP_Color_LaserJet_3800__62856C_

but still no dice.

have anyone successfully be able to share a printer from a Mac to a Linux?
is there anything I am missing?


scheidel21 08-11-2012 02:59 AM

Check the Mac firewall rules make sure it isn't blocking the traffic.

jjjj12212 08-13-2012 06:56 PM

unfortunately, Port 631 is open and can see it open from the remote system.
do you have any other suggestions that I can try out?

guyonearth 08-13-2012 07:14 PM

When you browse for printers on the network, do you see it?

scheidel21 08-13-2012 09:03 PM

Try http://<MacIP>:631/printers/<PrinterName>

jjjj12212 08-14-2012 10:40 AM

tried http://<mac IP>:631/printers/<printer>

got the same message:
URI is incorrect or no longer exsists

if I click discover, I see no printers.

I did a test print on my Mac to the printer and it printed no problem
I did a test print on my Linux to the printer that is connected to my mac and nothing came out :(

scheidel21 08-22-2012 02:01 AM

Sorry it's taken me so long to get back to you, I think I'm just about tapped out. There has to be some reason it's not working. Can you hook up a pritner network or direct the the linux machine and verify that the cups install on it is working ok?

jjjj12212 08-23-2012 11:23 PM

Hi scheidel21,

Thanks for coming back,

I installed a network printer, prints no problem. Windows share printer, no problem. Directly to the linux server, no problem.

we are in a scenario where we need to get the Printer working from a Mac which we are having troubles with.

I'm tapped as well, I mean the setup looks proper from the tutorials I followed from older posts but no dice :(

All times are GMT -5. The time now is 03:13 AM.