-   Linux - Newbie (
-   -   how to mount usb and hdd form usb linux? (

choconlongxu 11-16-2007 08:57 PM

how to mount usb and hdd form usb linux?
Hi all,

I am a newbie, pls. i want to to use USB and hdd in linux, i run from linux usb(linux DSL) in windows sp2, how can i mount usb or hdd?


Dinithion 11-17-2007 06:21 PM

I have never tried DSL, but this way of doing it should work:
Plug inn your USB device. Now, locate what it is called. Do this by typing:
dmesg | tail
There many new lines there, and should be something like this:
sd 7:0:0:0: [sdc] Attached SCSI disk

In this case, /dev/sdc is the device name to use. This disk has one partition, and therefore /dev/sdc1 is the only device that could be used. If you have more then one partition, the names are sdc1 sdc2... To get a complete overview of the partitiontable use fdisk or cfdisk.

Now to the mounting. Most distros have a folder /mnt/hd that is good for this purpose. Which folder you use doesn't matter. Mount the device like this:
mount /dev/sdc1 /mnt/hd

To get som extra info, read man mount/cfdisk

nthillaiarasu 11-21-2007 08:44 AM

enter into ur terminal as superuser
then type fdisk -l in terminal
it will show like this

Device Boot Start End Blocks Id System
/dev/sda1 * 1 1275 10241406 c W95 FAT32 (LBA)
/dev/sda2 1276 4870 28876837+ f W95 Ext'd (LBA)
/dev/sda5 1276 2435 9317668+ b W95 FAT32
/dev/sda6 2436 2566 1052226 82 Linux swap / Solaris
/dev/sda7 2567 3088 4192933+ 83 Linux
/dev/sda8 3089 3218 1044193+ 83 Linux
/dev/sda9 3219 3728 4096543+ 83 Linux
/dev/sda10 3729 4870 9173083+ 83 Linux

Disk /dev/sdb: 8622 MB, 8622931968 bytes
255 heads, 63 sectors/track, 1048 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

Device Boot Start End Blocks Id System
/dev/sdb1 1 538 4321453+ b W95 FAT32
/dev/sdb2 539 1048 4096575 7 HPFS/NTFS

Now choose which partion u want to mount
before mounting create a directory in media .for ex:create as usb

now u cant use mount command to mount ur USB Drive
mount /dev/urusb partition /media/usb

mkenyon2 07-30-2008 10:28 AM

In the DSL I have, I get this in dmesg:

usb 1-1: new full speed USB device using uhci_hcd and address 3

fdisk -l only gives me my hda1 which is the root drive.

This is a hard drive install of DSL.

I searched the /dev folder for anything like uhci or hcd, but nothing like that was there.

All times are GMT -5. The time now is 01:27 PM.