LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   How to mount FAT32 ??? (https://www.linuxquestions.org/questions/linux-newbie-8/how-to-mount-fat32-89223/)

qwijibow 09-04-2003 12:25 PM

How to mount FAT32 ???
 
Hey guys, i was told linux can read-write to fat32 disks.

so i fotmated my windows disk to fat32 so i could use linux to backup music ect ect.

now i want to write it back to the fat32 windows disk but...

mount -t fat32 /dev/hdb1 /mnt/

tells me my kernel (2.4-20-8) does not support fat32

also tried typing it was FAT32 (just incase)

i assume i need a kernel module just like i did for reading ntfs.

where can i find such a module ???

thankyou

aaa 09-04-2003 12:33 PM

FAT32 is called vfat in linux.

Mathieu 09-04-2003 12:36 PM

Type:
Code:

mount -t vfat /dev/hdb1 /mnt/cdrom

qwijibow 09-04-2003 12:44 PM

ahh, lol thanX.
wow, that has to be the easyest problem iever had, thanX

ffang 09-04-2003 03:18 PM

I am looking for the same thing also, but I failed to do so. The error message says:

mount point /mnt/cdrom does not exist.

How to fix this one?

Thanks,

Fang

h/w 09-04-2003 03:27 PM

make a dir under /mnt called 'cdrom'?

mkdir /mnt/cdrom
should be enuff

ffang 09-04-2003 05:54 PM

I did, but got another error message:

Called: mount /dev/hdb5
mount: wrong fs type, bad option, bad superblock on
/dev/hdb5,
or too many mounted file systems
(could this be the IDE device where you in fact use
ide-scsi so that sr0 or sda or so is needed?)

What is this message talking about? Anyway I can fix it?

Thanks,

Fang

Mathieu 09-04-2003 07:36 PM

In the /etc/fstab file, there may be an incorrect entry for /dev/hdb5
Can you post your /etc/fstab ?

Also, what type of partition is hdb5 ? (ext2/ext3, FAT32, NTFS, etc)

ffang 09-04-2003 07:51 PM

Here it is. Looks mess to me.

Thank,
Fang

/dev/hdb4 / reiserfs defaults 1 2
/dev/hdb1 /boot reiserfs defaults 1 2
/dev/cdrecorder /media/cdrecorder auto ro,noauto,user,exec 0 0
/dev/cdrom /media/cdrom auto ro,noauto,user,exec 0 0
devpts /dev/pts devpts defaults 0 0
/dev/fd0 /media/floppy auto noauto,user,sync 0 0
proc /proc proc defaults 0 0
usbdevfs /proc/bus/usb usbdevfs noauto 0 0
/dev/hda1 /windows/C ntfs ro,noauto,user,umask=022 0 0
/dev/hdb5 /windows/E vfat noauto,user 0 0
/dev/hdb6 /windows/F ntfs ro,noauto,user,umask=022 0 0
/dev/hdb3 swap swap pri=42 0 0

Mathieu 09-04-2003 08:21 PM

Take a look at your partition table to make sure you are mounting the correct partition and file system.
Code:

fdisk -l
Also, do you get the same error message if you use the full command ?
Code:

mount -t vfat /dev/hdb5 /windows/E

ffang 09-04-2003 08:39 PM

I got the same error message.
The output from fdisk -l:

Disk /dev/hda: 255 heads, 63 sectors, 14593 cylinders
Units = cylinders of 16065 * 512 bytes

Device Boot Start End Blocks Id System
/dev/hda1 * 1 14592 117210208+ 7 HPFS/NTFS

Disk /dev/hdb: 255 heads, 63 sectors, 19929 cylinders
Units = cylinders of 16065 * 512 bytes

Device Boot Start End Blocks Id System
/dev/hdb1 1 26 208813+ 83 Linux
/dev/hdb3 27 222 1574370 82 Linux swap
/dev/hdb4 223 2433 17759857+ 83 Linux

No hdb5 here.

Mathieu 09-04-2003 08:49 PM

According to fdisk, hdb5 and hdb6 do not exist.
Since these partitions do not exist, you can not mount them.

michaelk 09-04-2003 08:57 PM

ffang,
You don't have any FAT32 partitions.

But what are you really trying to do. Your first post was trying to mount the cdrom. It looks like your running SUSE which uses /media/cdrom instead of /mnt/cdrom.

Are you trying to mount the NTFS partition? Not sure if SUSE has NTFS support in its default kernel.

You could try
mount -t ntfs /dev/hda1 /some_mount_point

ffang 09-04-2003 09:09 PM

Hi Michaelk,

You are right, I am using SUSE 8.0. I am trying to mount vfat hdb5. I can see the info from the tool kDiskFree. It contains hdb5 vfat. Here is the display from kDiskFree:

Device Type Size Mountpoint Free Full%
/dev/hdb5 vfat N/A /windows/E 0B N/A

I can select it and mount, then get error message.
When I install SUSE 8.0 the partition was there. But seems it didn't show up in fdisk for some reason.

Anyone knows how to fix it?

Thanks,

Fang

michaelk 09-04-2003 09:40 PM

Duh, I needed to reread all of the posts.

Well, kdiskfree doesn't show the size so I don't think its reflecting the actual partition info.

From fdisk you are missing /dev/hdb2 which should of been the extended partition containing the logical drives hdb5 & hdb6.

Did you change anything after you installed SUSE?

I would guess if you rebooted windows it wouldn't see the drives either. Your partition table might of been corrupted.


All times are GMT -5. The time now is 08:11 PM.