LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-09-2017, 02:15 PM   #1
DFMoffatt
LQ Newbie
 
Registered: Sep 2017
Posts: 4

Rep: Reputation: Disabled
How to mount a Windows USB drive


I have a fresh USB flash drive onto which I copied some data files using Windows 10; file system is FAT32. Now on a different PC LinuxMint says "Unable to mount USB Disk" "Error creating mount point 'media/douglas/USB DISK'; Read-only file system".
This is not answered by related posts here as far I can tell: it was ejected properly from Windows; it can be accessed properly again in Windows.
Have looked at man mount and solution is unclear (what device? would it work with -r?)
Am trying reformat to NTFS pending an answer.
 
Old 09-09-2017, 03:05 PM   #2
KenJackson
Member
 
Registered: Jul 2006
Location: Maryland, USA
Distribution: Fedora and others
Posts: 756

Rep: Reputation: 144Reputation: 144
Quote:
Originally Posted by DFMoffatt View Post
"Error creating mount point 'media/douglas/USB DISK'; Read-only file system".
The problem isn't with the USB drive, it's with your Linux file system. I don't know why /media would be mounted read-only, but apparently it is. You can either solve that or pick another mount point and mount it manually.

For example, you might try creating a mountpoint in your home directory, something like this:
Code:
cd
mkdir usb
sudo mount /dev/sdb0 usb
Of course, be VERY CAREFUL to specify the correct device. You can find it with this command right after you plug it in:
Code:
dmesg | tail
Or: lsblk

Last edited by KenJackson; 09-09-2017 at 03:08 PM.
 
1 members found this post helpful.
Old 09-09-2017, 03:34 PM   #3
Rickkkk
Senior Member
 
Registered: Dec 2014
Location: Montreal, Quebec and Dartmouth, Nova Scotia CANADA
Distribution: Arch
Posts: 1,253

Rep: Reputation: 467Reputation: 467Reputation: 467Reputation: 467Reputation: 467
I agree with KenJackson - probably an issue with the permissions on /media (where most linux distros mount external devices when inserted).

Read your distro's (Mint) instructions concerning this, but permissions along the lines of 0755 work for me on /media (0775 if you really want to be sure ..).

Otherwise, as suggested by KenJackson, you can create a mount directory in your own home directory tree (ex. /home/dfmoffatt/mnt/usb) ... (replacing "dfmoffatt" with whatever your home directory is called) and use that to manually mount the USB drive (or anything else, for that matter. Caveats mentioned by KenJackson apply.

Cheers - let us know how it goes.
 
1 members found this post helpful.
Old 09-09-2017, 04:58 PM   #4
JeremyBoden
Senior Member
 
Registered: Nov 2011
Location: London, UK
Distribution: Debian
Posts: 1,887

Rep: Reputation: 467Reputation: 467Reputation: 467Reputation: 467Reputation: 467
Quote:
Originally Posted by KenJackson View Post
The problem isn't with the USB drive, it's with your Linux file system. I don't know why /media would be mounted read-only, but apparently it is. You can either solve that or pick another mount point and mount it manually.

For example, you might try creating a mountpoint in your home directory, something like this:
Code:
cd
mkdir usb
sudo mount /dev/sdb1 usb
Of course, be VERY CAREFUL to specify the correct device. You can find it with this command right after you plug it in:
Code:
dmesg | tail
Or: lsblk
I agree - with that very minor correction!
 
1 members found this post helpful.
Old 09-09-2017, 07:08 PM   #5
tofino_surfer
Member
 
Registered: Aug 2007
Posts: 472

Rep: Reputation: 150Reputation: 150
Quote:
Of course, be VERY CAREFUL to specify the correct device
There are many links created by udev in the /dev/disk directory that you could use instead of specifying raw devices, a much safer approach. The following is for a Kingston flash drive.

Code:
$ ll /dev/disk/by-id/usb*
lrwxrwxrwx 1 root root  9 Sep  9 16:48 /dev/disk/by-id/usb-Kingston_DataTraveler_2.0-0:0 -> ../../sdf
lrwxrwxrwx 1 root root 10 Sep  9 16:48 /dev/disk/by-id/usb-Kingston_DataTraveler_2.0-0:0-part1 -> ../../sdf1
The links in /dev/disk/by-id are prefixed by protocol so all USB devices would be usb-*. All SATA drives would be ata-*. If you only have one USB device plugged in there would be no trouble differentiating it from all of your SATA drives. If you have multiple then the device name Kingston_DataTraveler_2.0 in this case would be useful.

Code:
$ readlink -f /dev/disk/by-id/usb-Kingston_DataTraveler_2.0-0\:0-part1
/dev/sdf1
$ lsblk -f /dev/disk/by-id/usb-Kingston_DataTraveler_2.0-0\:0-part1 
NAME FSTYPE LABEL    UUID                                 MOUNTPOINT
sdf1 vfat   KINGSTON 0000-3781
To perform a mount:

Code:
mkdir /mnt/usb_flash
sudo mount /dev/disk/by-id/usb-device-name-0\:0-part1 /mnt/usb_flash
You wouldn't need to type out the full name as you could use tab completion after entering /dev/disk/by-id/usb-. With udev there is no need to specify drive letters at all, a safer approach. There is a thread about an OP who erased their HDD by typing the wrong letter when they were trying to write to a flash drive with dd to create a bootable USB. Using these udev links instead of drive letters would have saved their whole drive.


A permanent solution for a drive you use often would be to create udev rules to give a fixed link name, such as /dev/lexar for a Lexar flash drive and to automount it to a location in your fstab.

Last edited by tofino_surfer; 09-09-2017 at 08:35 PM. Reason: simplified command
 
1 members found this post helpful.
Old 09-10-2017, 06:29 AM   #6
DFMoffatt
LQ Newbie
 
Registered: Sep 2017
Posts: 4

Original Poster
Rep: Reputation: Disabled
I am impressed!

The replies have been prompt and illuminating - thank you all. I shall be following your advice today.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
USB thumb or hard drive fails to mount after use on Windows wjlesaulnier Linux - Hardware 3 08-13-2016 10:53 AM
can't mount external windows formatted usb hard drive markyramone Linux - Hardware 4 01-21-2013 09:36 PM
[SOLVED] "Not Authorized" to mount external USB drive or Windows filesystem from Debian alarazr Linux - Newbie 3 01-15-2013 12:40 PM
when i mount my USB Flash Drive A Messenge has come that mount: can't find /dev/sda/h feda82 Red Hat 2 12-24-2005 02:15 AM
mount usb module then mount usb hard drive guanyu Linux - Hardware 1 10-08-2003 11:50 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 10:32 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration