Welcome to the most active Linux Forum on the web.
Go Back > Forums > Linux Forums > Linux - Newbie
User Name
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!


  Search this Thread
Old 11-19-2010, 08:51 AM   #1
LQ Newbie
Registered: Nov 2010
Location: Eindhoven, NL
Distribution: Ubuntu
Posts: 5

Rep: Reputation: 0
Question How to mount a NAS drive in Linux?

I have bought a NAS and configured this to work under Windows within Microsoft network name HOUKES and device name //CH3MNAS/Volume_1.

Now I want to see this NAS also under Linux. What is the easiest way to do this?

What I want to do: Inside Thunderbird/Windows e-mails+pictures are now this drive... I want to see my them also in Linux.
Old 11-19-2010, 09:52 AM   #2
Registered: Mar 2010
Distribution: Debian
Posts: 180

Rep: Reputation: 31
Install/use samba-client to access your drive.
Old 11-21-2010, 09:06 AM   #3
LQ Newbie
Registered: Nov 2010
Location: Eindhoven, NL
Distribution: Ubuntu
Posts: 5

Original Poster
Rep: Reputation: 0
Not working yet...

I'm really a beginner, experiencing following problems:

Following is working finally:
Add one line to //etc/hosts CH3MNAS nas
>smbclient //nas/Volume_1 -N

Issues: Was not able to change the hosts file, only after "sudo -s" this was possible, because else you have no rights to change this directory.
For this I installed vim, which looks like vi... some people like it, not me!

However, I want to use this NAS with GIT or just read it. So I need to mount it. Then I tried "mount //nas/Volume_1 /work", but I am not the root user grrrrrrrrrrrrr....

Next tried: "sudo mount //nas/Volume_1 /work" and filled in an empty password. But Linux does not like empty passwords.. so I used HTTP to change the password of my NAS... now it is not working anymore...

also smbclient is not working anoymore since I added a password. When I use "smbclient //nas/Volume_1 /work -o password=12345678" I get following errors:
Domain=[HOUKES] OS=[Unix] Server=[Samba 3.0.28]
Server not using user level security and no password supplied.
Server requested LANMAN password (share-level security) but 'client lanman auth' is disabled
tree connect failed: NT_STATUS_ACCESS_DENIED

Still trying...
Old 11-21-2010, 09:24 AM   #4
LQ Newbie
Registered: Nov 2010
Location: Eindhoven, NL
Distribution: Ubuntu
Posts: 5

Original Poster
Rep: Reputation: 0
Smile Finally after 3 days.

Now I found a website on internet, helping me a lot in linux. I made a directory /san

then I did:
"sudo smbmount //CH3MNAS/Volume_1 /nas -o username=mensfort,password=12345678"

then I can do: "cd /nas", "ls" and get data from the right position...
Now to see if there is sth like autoexec.bat... or where to put this so I get this done automatic.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Mount Network Attached Hard Drive (NAS) as Non-Root User undoIT Linux - Software 2 05-01-2010 04:01 PM
Problems using NAS drive from Linux tridral Linux - Networking 3 05-31-2008 04:35 AM
LXer: Linksys Dual Bay NAS Drive has a Hackable Linux OS LXer Syndicated Linux News 0 01-09-2007 01:54 AM
LXer: Dual-drive NAS server runs Linux, supports DLNA LXer Syndicated Linux News 0 07-12-2006 08:54 PM > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 07:10 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration