-   Linux - Newbie (
-   -   How to install Native Debian on Ainol Novo 9 Spark after rooting device? (

jleonardol 10-22-2013 06:21 PM

How to install Native Debian on Ainol Novo 9 Spark after rooting device?

I purchaced an Ainol Novo 9 Spark due to it's hardware with the intention to install Linux in it as it is more convenient than carrying a notebook everywhere I travel

According to some research I've done online it is possible to run Debian Linux natively on tablets.

The best result that I got was about the Onda 812, which has the same processor as mine and managed to install native Debian Linux.(

My questions are:

1) Can I install the image provided by Debian (I downloaded the ARMHF DVD ISO) on imy tablet?
1a) f yes, how can I do that? Any documentation on how to do that on a tablet?

If answer from previous question is NO, than:

2) Is the custom ROM of NOVA 812 compatible with the hardware I have, since both tablets has the exact same processor?
2a) If yes, can I just follow the instructions of that post?

Thank you very much in advance for your help.

Best Regards,

Jorge Leonardo

business_kid 10-23-2013 01:15 PM

You would want the same cpu, gpu, chipset and software revisions all round for any definite/definite answers. You're going to have to gamble with something. I would go for something 'generically spark' rather than a particular manufacturer's one. If you don't share modem and nic specifications, for instance, you might end up with no modem or nic. A generic thing gives you a better choice of drivers.

You've rooted it. Why not go for a 'mod?'I ran Cyanogenmod for some time and it was more suited to the job than any linux would have been. With a mod, they do the thinking for you. You get android with a better busybox (including 'su') and some useful extras.

jleonardol 10-23-2013 03:50 PM

Hello business_Kid,
Thanks for the reply.

I don't understand much about tablets.
And honestly I don't like Android. I can work with MAC, Linux and Windows (If I really have to), but Android is something that I somehow just don't like it/ can't get along, plus I would like to have the tablet as a secondary minimal portable computer, so I'd rather have a Linux in it.

The devices have the same CPU (Allwinner A31 - Quad Core), GPU (PowerVR SGX544MP2), WIFI (Realtek - RTL8188EUS), chipset (AXP221) and SDRAM (SK Hynix - H5TQ2G83CFR).

Flash ROM are different. In Nova v812 is Sk Hynix, on Ainol is Micron).

Motherboard also look slightly different but I don't know where to identify the model.

business_kid 10-24-2013 11:29 AM

Roughly speaking, Android is linux, except:
1. It uses busybox
2. It disables root
3. It levers you into using java based apps.
4. All the gears and dirty stuff gets covered over by a gui
5. Android provides built in apps.
6. Google and Manufacturers are tardy about safety updates.

Once you start thinking of a driver for the wifi, the on screen keyboard, and the screen feedback under linux, you will realise why I suggest a mod. A mod allows root, keeps up with safety bug fixes, and gives you it's own apps as well as google's. You can do linux to yourself if you want to, but then you need to sort all your drivers - whatever that takes.

jleonardol 10-27-2013 12:20 PM

I know Android is Linux.

I tried to install the CyanogenMod 10.2 following this tutorial.

But somehow after every restart the tablet restart in chinese and all apps I had are no longer there. I try reinstalling but it never does.

Also when I choose to restart in recovery mode it never does, it goes straight to Android again in chinese.

Any tips on how to sort this out and get the CyanogenMod10.2 working?

business_kid 10-27-2013 02:08 PM

I would take instructions on Cyanogenmod from the Cyanogenmod wiki, or I had mixed success with it myself (Old htc phone, installed 4.x, failed to install 5.x and skipped it, and went for 6.0 which was a bit much for the phone). But I ran 6.0 for four - five years.

jleonardol 10-30-2013 02:32 PM

Hi, so I tried installing the CyanogenMod 10.2
I installed all needed files accordingly.
I got first to the TWRP recovery wiped all data and everything (unfortunately forgot to make a backup) so I ended up without an OS, and as I flashed the needed roms, after reboot I get stuck at the android logo.
Tried everything to get back to the bootloader without success.
When I use ./adb devices (I use mac) it shows me the device name as "unauthorized".

I've searched a few threads online and didn't find any solution for it :(

Any clues what has happened to the device?

sorry for being such a crood with computers...

business_kid 10-31-2013 01:29 PM


(unfortunately forgot to make a backup)
We all do that to ourselves at least once. I told my kids (when growing up) that they were allowed to break one window, and cut their own hair wrong once. They didnīt all do it - the first one to try showed the others how stupid it was.

Have you access with flashboot, or adb? If so, a search lies ahead of you. You may find some kind soul to give you a backup. As long as it talks to you, thereś hope. Beneath the OS is the rescue OS, and if that survived (which it usually does) you should be ok as long as you do not overwrite it.

Learn what blocks go where.The one Android I had to do this with (years ago) had 5 blocks of memory: /boot; /data; /system; /xbin; & cache(?) and I could fastboot them all from a nandroid backup.

jleonardol 12-29-2013 03:56 PM

Hi, thanks for all the help.

After some research i managed to install Cyanogen Mod, but tablet is very slow, so i followed with my original plan which was installing Linux in it and I've been succesfull :)

I'm now having issues with wi-fi. It show it's connected but I can't browse the web :(
I try to do root access on terminal but it asks me for root password (I don't know the password and never did set one up).
My touchscreen is also not working :( so I'm using external keyboard and mouse.
When I go to system settings to check touchscreen Wacom Graphics Tablet shows "No Tablet detected"

I tryed to boot pressing shift while booting to GRUB to log in as a single user and reset password but no luck...

Any ideas?

Best Regards

business_kid 12-30-2013 02:53 AM

All the drivers you want and all the kernel patches, were in Android. I wouldn't have done what you did. Reinstalling Android is probably an option if all else fails, and you can't sort linux or CM.

There is usually a script in CM that needs to be run which sorts a lot of things.
You can usually set up a soot password with this command.
sudo passwd root

All times are GMT -5. The time now is 02:06 AM.