-   Linux - Newbie (
-   -   How to install deb package (

tstrickland 07-19-2005 11:13 PM

How to install deb package
I just set up Knoppix as a single-user, dual-boot system and I want to install synaptic. I downloaded the synaptic deb package to a file. Here's what I did and the results:

knoppix@1[~]$ su
root@1[knoppix]# dir
Desktop none thunderbird
firefox-1.0.5.installer.tar.gz office thunderbird-1.0.5.tar.gz
firefox-installer synaptic_0-1.57.2-1_i386.deb tmp
root@1[knoppix]# apt-get install synaptic_0-1.57.2-1_i386.deb
Reading Package Lists... Done
Building Dependency Tree... Done
E: Couldn't find package synaptic_0-1.57.2-1_i386.deb

It says it can't find the package which is shown in the directory listing.

What am I doing wrong and what should I do?



xpromisex 07-19-2005 11:20 PM

apt-get is the package handler - meaning it will download and install the files for you. If you want to use that specific package then I suggest "dpkg -i synaptic_0-1.57.2-1_i386.deb". However, if you have an open internet connection faster than say....56k, I would just use Apt-get to download the file. Now - I'm not sure but I do believe that Synaptic has an installation candidate and all you would have to do would be a simple "apt-get install synaptic".

Hope this has helped....If I made no sense - let me know so I can try again.

EDIT - I neglected to mention that Apt-get installs from central repositories, so you don't have to go searching for the file....Just thought I would make that clear.

tstrickland 07-20-2005 09:23 AM


I tried it and here's what I got:

knoppix@1[~]$ apt-get install synaptic
E: Could not open lock file /var/lib/dpkg/lock - open (13 Permission denied)
E: Unable to lock the administration directory (/var/lib/dpkg/), are you root?
knoppix@1[~]$ su
root@1[knoppix]# apt-get install synaptic
Reading Package Lists... Done
Building Dependency Tree... Done
Package synaptic is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
E: Package synaptic has no installation candidate

Now what?

Lleb_KCir 07-20-2005 11:20 AM

as root run the following commands:


apt-get update
apt-cache search synaptic
apt-get install ((what ever the results of the package was from the search))

that should help you install it. apt-cache search is a great tool for figuring out exactly what you can grab and install with the proper name by the respository you are using.

tstrickland 07-20-2005 07:02 PM

Now I Have Another Problem
I followed the recommendations of Lleb_KCir and they worked!! I now have synaptic installed. However, I now have another problem. Synaptic, my printer configuration, and probably other applications are now password-protected. This is a Knoppix system that doesn't have a password, or at least I never set one up. I tried several guesses but none worked. I'm locked out of these applications.

Any suggestions?:(

xpromisex 07-20-2005 09:03 PM

Okay - Try this.

1 - Hit Ctrl + Alt + F1 to go to a nongraphical login.
2 - at the login, type "root" and see if it will let you in (it should - the synaptic install didn't set up a password, just enabled its use)
3 - If it lets you login as root, type "passwd root" and follow the directions
4 - hit Ctrl + Alt + F7 to get back to the X server.

Good Luck.

tstrickland 07-20-2005 10:25 PM

Problem Solved

Your recommendation worked!:) Now I can get in to synaptic, etc. so now I am a happy camper :D

Many thanks! BTW, how did you learn all this stuff? :scratch:

It's people like you that keep me from giving up on Linux.


Lleb_KCir 07-21-2005 12:27 AM

Re: Problem Solved

Originally posted by tstrickland

Your recommendation worked!:) Now I can get in to synaptic, etc. so now I am a happy camper :D

Many thanks! BTW, how did you learn all this stuff? :scratch:

It's people like you that keep me from giving up on Linux.


glad it is working for you.

i learned by doing exactly what you are doing. tring to accomplish a task, coming here asking for help, and following instructions. as i learned more i have started being able to ask questions better of google and LQ to get even faster results in most cases.

xpromisex 07-21-2005 04:47 PM

Much like was stated above, I learned alot through Linux Questions, Google, and Wiki's.

The reason I knew the answer to that particular question was...well, I'd had it happen to me before, that was what I came up with to fix it.

I'm glad we can keep you "on the bandwagon". If you want a customizable OS, this is it. Just keep at it, and I'll help you as much as I can. (granted that you do a bit of the research yourself on google and the like)

tstrickland 07-21-2005 05:34 PM

Thank you
Thank you all for your help! Linux is very complicated, but with all the help available, I keep making slow but steady progress.:study:


Lleb_KCir 07-21-2005 06:39 PM

that is how you grow in skills. nice and steady. you will hit hurdles that seem unsurmountable, but giving time you will get over them.

All times are GMT -5. The time now is 01:10 PM.