-   Linux - Newbie (
-   -   How to get desktop to work in Slackware? (

MurOllavan 06-14-2005 07:30 AM

How to get desktop to work in Slackware?
Hello. Totally new to Linux as of today. I have most things working, but I cannot start the X windowing system. It is slackware 10.1. Linux 2.4.29.
There is no command named xf86config or XF86Setup as the book described, nor SuperProbe. I can startx, but this produces a black screen, a short flicker of light, and finally a black screen and kde and x crash. I press ctr alt backspace to leave this and the messages left are as follows.
There is a slew of error messages I cannot scroll up to see, most ending in "specifiies undefined mimetype/servicetype "insertsomepathhere"...
The rest of it goes:
startkde: Could not start kdeinit. Check installation
Fatal IO error: client killed
kded: Error: Communication problem with kded, it probably crashed
Error: Can't open display :0
kdeinit: Can't connect to X Server
" "
" "
" "
Then it shuts down and exits.
Any suggestions on what I can do?

10xOXR 06-14-2005 07:55 AM

Have you tried the Configuration Help on the Slackware website? It has a great section on getting X to work properly:

Slack X Config Page

Hope this helps,


MurOllavan 06-14-2005 06:34 PM

Man. I must have missed that part. I haven't tried anything yet, but I believe this will do it. Thank you.

mcd 06-14-2005 06:40 PM

yeah, that link looks pretty up-to-date. basically everything changed from xf86 to xorg, so the file and path names changed. let us know if you still have trouble though.

All times are GMT -5. The time now is 02:30 AM.