LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-13-2009, 05:17 PM   #1
corbierre
LQ Newbie
 
Registered: Mar 2009
Posts: 6

Rep: Reputation: 0
How to get a high ID in aMule


I will preface this by letting you know I had never heard of eMule, eDonkey, eHorse etc. before yesterday - so I am not exactly up to speed with the technical side of the interweb.

I have however, downloaded aMule and I'm running it on my mac with osX.5.6 through a Netgear wireless router and I have a low ID that i would like to improve. To do so I am being told lots of stuff about ED2K, ports, TCPs and clients and the only thing I know about "clients" is that they usually don't pay their bills.

Is there any foolproof step by step guide for me to enable these mysterious ports or whatever I have to do.

Cheers,

Corbierre
 
Old 03-13-2009, 05:37 PM   #2
rysiekmus2
Member
 
Registered: Mar 2007
Location: Manchester UK
Distribution: Sabayon
Posts: 30

Rep: Reputation: 17
low id

Corbierre,

in order for your aMule to get a high ID you need to
let your router know, that this application should
let the communication through. You have a low ID because
your are behind your router, not connected directly to
the internet.
So, open the Linux console and login as ROOT:
> su -
<password for root>
> ifconfig
THis is what you will see:
Code:
eth0      Link encap:Ethernet  HWaddr 00:09:6b:7d:34:fc
          inet addr:192.168.1.64  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::209:6bff:fe7d:34fc/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:682155 errors:0 dropped:0 overruns:0 frame:0
          TX packets:651943 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:649917410 (619.8 MiB)  TX bytes:100720536 (96.0 MiB)
inet addr:192.168.1.64 - this is my IP address.
Find your IP address.

Now google on your router name and add "port forwarding".
You may find a manual how to set this up with your router.
You will have to login as an admin of your router,
so find the Login and Password for your router, usually
you just open your browser, type in the URL for your router.
Once you are logged in - follow instructions how to set up
your router to accept your IP address and the ports
TCP and UDP. Usually all routers have manuals how to do that.
Every router may have a different way to do it.

When you find where to change the settings, check aMule.
By default aMule uses 3662 for TCP, 3672 for UDP for
the first computer.

Use this kind of web page, you may find your own router:
http://portforward.com/english/route...THub/iChat.htm
That router is mine, it's a BT HUB.
You can see you can type in your IP address and the web
page will fill in the fields and guide you how to do it.
After that in aMule check the Preferneces -> COnnections.
Make sure the TCP/UDP ports I posted are the same.
If not use those that you have.

Once you change your router settings you simply disconnect/connect in aMule and all is done.

I hope this helps.
RIchard
 
Old 03-13-2009, 05:41 PM   #3
rysiekmus2
Member
 
Registered: Mar 2007
Location: Manchester UK
Distribution: Sabayon
Posts: 30

Rep: Reputation: 17
low id

Corbierre,

in order for your aMule to get a high ID you need to
let your router know, that this application should
let the communication through. You have a low ID because
your are behind your router, not connected directly to
the internet.
So, open the Linux console and login as ROOT:
> su -
<password for root>
> ifconfig
THis is what you will see:
Code:
eth0      Link encap:Ethernet  HWaddr 00:09:6b:7d:34:fc
          inet addr:192.168.1.64  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::209:6bff:fe7d:34fc/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:682155 errors:0 dropped:0 overruns:0 frame:0
          TX packets:651943 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:649917410 (619.8 MiB)  TX bytes:100720536 (96.0 MiB)
inet addr:192.168.1.64 - this is my IP address.
Find your IP address.

MOST IMPORTANT - use a regular Ethernet cable to do such changes, don't do this when you are connected wirelessly.
It's much safer.

Now google on your router name and add "port forwarding".
You may find a manual how to set this up with your router.
You will have to login as an admin of your router,
so find the Login and Password for your router, usually
you just open your browser, type in the URL for your router.
Once you are logged in - follow instructions how to set up
your router to accept your IP address and the ports
TCP and UDP. Usually all routers have manuals how to do that.
Every router may have a different way to do it.

When you find where to change the settings, check aMule.
By default aMule uses 3662 for TCP, 3672 for UDP for
the first computer.

Use this kind of web page, you may find your own router:
http://portforward.com/english/route...THub/iChat.htm
That router is mine, it's a BT HUB.
You can see you can type in your IP address and the web
page will fill in the fields and guide you how to do it.
After that in aMule check the Preferneces -> COnnections.
Make sure the TCP/UDP ports I posted are the same.
If not use those that you have.

Once you change your router settings you simply disconnect/connect in aMule and all is done.

I hope this helps.
RIchard
 
Old 03-13-2009, 05:58 PM   #4
corbierre
LQ Newbie
 
Registered: Mar 2009
Posts: 6

Original Poster
Rep: Reputation: 0
Ok, here's where I exhibit my ignorance... whats a Linux console and how do I open it?
 
Old 03-13-2009, 06:06 PM   #5
rysiekmus2
Member
 
Registered: Mar 2007
Location: Manchester UK
Distribution: Sabayon
Posts: 30

Rep: Reputation: 17
Quote:
Originally Posted by corbierre View Post
Ok, here's where I exhibit my ignorance... whats a Linux console and how do I open it?
Try the Start menu, System, Terminal Program - Konsole.
It's like CMD in Windows.

But you should be able to find your IP addres when you login to
your router, so now worries, better start later with Linux than never.

Every computer connected to the Internet has a unique identificator in the network, this is the IP address.

Regards
 
Old 03-13-2009, 06:19 PM   #6
corbierre
LQ Newbie
 
Registered: Mar 2009
Posts: 6

Original Poster
Rep: Reputation: 0
Thanks for your help but I guess I am totally in the wrong place - I'm on OSX, I don't even know what Linux is - I just googled my query and ended up here. I'll try elsewhere!
 
Old 03-13-2009, 06:26 PM   #7
rysiekmus2
Member
 
Registered: Mar 2007
Location: Manchester UK
Distribution: Sabayon
Posts: 30

Rep: Reputation: 17
Apple - Mac OS X Leopard ?

Whatever the operating system is, an IP address is an IP address.
aMule uses and IP address and ports numbers.

You will have the same procedure.

Good luck.
RIchard.
 
Old 03-13-2009, 06:33 PM   #8
corbierre
LQ Newbie
 
Registered: Mar 2009
Posts: 6

Original Poster
Rep: Reputation: 0
I'm on a mac, I don't have a start menu! I would love to say I know what you are talking about but I dont! I know what an IP address is but how do I talk to my router? (if that is what I have to do).
 
Old 03-13-2009, 06:36 PM   #9
rysiekmus2
Member
 
Registered: Mar 2007
Location: Manchester UK
Distribution: Sabayon
Posts: 30

Rep: Reputation: 17
Find your router manual in the internet.
All routers have manuals.
There you should find the URL.
Open a Web Browser and type the URL.
You will find fields like Login/Password.

What router do you have?
GIve us a name, type.

Cheers.
 
Old 03-13-2009, 07:10 PM   #10
corbierre
LQ Newbie
 
Registered: Mar 2009
Posts: 6

Original Poster
Rep: Reputation: 0
Since my last post I have bypassed the router. I am now connected by ethernet directly to my modem, broadband to the www... still aMule is telling me I have a low ID. KAD now reads as off though, instead of Firewalled.

Cheers
 
Old 03-13-2009, 07:21 PM   #11
rysiekmus2
Member
 
Registered: Mar 2007
Location: Manchester UK
Distribution: Sabayon
Posts: 30

Rep: Reputation: 17
Right, so you connected to your router with an Ethernet?
Or you replaced your router with another device - a modem?
Like in the old days :-)

So how does your connection look like?
You had:
Computer -> Wireless -> Router -> ISDN phone line -> ISP
(ISP - your Internet provider)

Now you have this:
1.
Computer -> Ethernet -> Router -> ISDN phone line -> ISP

Or you have this:
2.
Computer -> Ethernet -> Modem -> Phone line -> ISP

If option 1, then you did not bypass your router.
If option 2, it would be strange, you should have a direct connection.

A router is often called modem/router.
How many devices do you have?
One device , a Modem/Router
Two devices
1. Modem
2. Modem/Router ?

Cheers.
 
Old 03-13-2009, 07:44 PM   #12
khodeir
Member
 
Registered: Feb 2009
Distribution: Debian
Posts: 243

Rep: Reputation: 33
go to portforward.com and u will know how to make it HI ID
 
Old 03-16-2009, 04:53 AM   #13
corbierre
LQ Newbie
 
Registered: Mar 2009
Posts: 6

Original Poster
Rep: Reputation: 0
Thanks rysiekmus2, now I understand what you were saying - Thanks khodeir, I needed pictures!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
amule esaym Debian 2 07-10-2007 10:25 AM
Load Avg High/Phys Mem High teamh Debian 2 12-26-2006 06:03 PM
Amule and NX puntino Linux - Desktop 1 11-22-2006 04:24 AM
amule delta_9 SUSE / openSUSE 1 06-20-2006 12:01 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 08:05 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration