-   Linux - Newbie (
-   -   How to enable ACL in /dev (udev) file system (

aldo_mozzi 03-11-2008 05:51 PM

How to enable ACL in /dev (udev) file system
I am an old time Linux user (since 1994) but I am not especially smart, so please excuse em if my question is trivial.

I am moving from Fedora 7 to 8; with the standard kernel users have access to sound, although /dev/dsp has permissions rw-rw----+ and is root.root. If I compile the kernel myself, using a .config that worked flawlessly on Fedora 7, only root has access to /dev/dsp, whose permissions are now rw-rw---- WITHOUT the final +.
I learned that the final + in permissions means that there is an Access Control List associated with the file, that is what probably makes access possible to standard users with standard kernels. My home-compiled kernel probably lacks the ACL feature, so there is no + at the end of the permissions string, and the access is denied.

I tried to figure out how to enable the ACLs on device files (Fedora uses UDEV) in the configuration file of the kernel, either via menuconfig, xconfig and even using vi on .config. But I did not find where this setting is.

Any pointers to "fine" manuals to read :-)?


Peacedog 03-11-2008 10:22 PM

Hi aldo_mozzi, Welcome to lq, Just a bit of googling on your behalf has produced this. I don't run fedora, in fact, my last Redhat experience or it's derivatives was rh9 so I'm not sure if this will help or not. I hope it does.
Good luck. ;-)

All times are GMT -5. The time now is 08:40 AM.