LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   How to disable screen blank / screen saver on Red Hat Enterprise (https://www.linuxquestions.org/questions/linux-newbie-8/how-to-disable-screen-blank-screen-saver-on-red-hat-enterprise-4175459581/)

jearl28 04-25-2013 02:16 PM

How to disable screen blank / screen saver on Red Hat Enterprise
 
Hello:

I've got a problem here that has been driving me crazy.

We recently updated our Red Hat Linux Enterprise OS from version 4 to version 5. We did all the updates, and it is now stamped version 5.9. We are running this on a Dell PowerEdge 830 server.

uname -r shows: 2.6.18-348.3.1.el5PAE

We are running the GNOME desktop Version 2.16.0

Since the install, the screen keeps blanking after a couple of hours. This is frustrating, as we use this as an alarm monitoring station. We constantly look at alarms, and never want the screen to blank.

Here is what I've tried to keep this from happening:

1) Click on System->Preferences->Screensaver and make sure the "Activate screensaver when computer is idle" is UNCHECKED

2) In my ~/.xinitrc, I've got 'setterm -blank 0 -powersave off -powerdown 0'. Also have 'xset s off' in same file.

3) I put the follow lines in /etc/X11/xorg.conf:

Section "ServerFlags"
Option "blank time" "0"
Option "standby time" "0"
Option "suspend time" "0"
Option "off time" "0"
Option "dpms" "false"
EndSection

Even after all this, it STILL blanks the screen after a couple of hours. I have not timed the exact duration. I don't know what else to try.

I remember having a program that I ran on an MS Windows machine that simulated the SHIFT key press every minute that kept screen savers from activating. But I don't have such a program on Red Hat.

It doesn't appear to be the screen saver. It appears to be more of a power save thing. I don't think it is the monitor, as I can't find anything in the monitor set up that addresses this. And the old version of Red Hat didn't have this issue.

Any help/ideas would be greatly appreciated.

yowi 04-25-2013 03:50 PM

try 'xset -dpms'

chrism01 04-25-2013 08:57 PM

I'm curious why you wouldn't go to v6.4 ie the latest? V5.x is getting old.
Also, when you say 'updated', I hope you mean 'replaced as fresh install', as RH does not support in-place upgrades across major versions https://access.redhat.com/site/docum...ted_Notes.html

John VV 04-25-2013 11:54 PM

that is set for every user in the gnome preferences

for each user
from the gnome desktop
/System/Preferences/Screensaver

now if one of the ss's are running uncheck the checkbox
"Activate the screensaver after the computer is idle for..."

for the "black screen"
click on the "powerManager" button
under "On AC power"
select "never" for both

and if that dose not work ( in ScientificLinux 6.4 it dose not any more -- it did in 5.9 )

install gconf-editor
-- not installed by default
Code:

su -
yum install gconf-editor

then run it as root
Code:

su -
gconf-editor

under the "Apps" on the left
select "gnome-screensaver"
and uncheck " idle_Activation_Enabled"
or set "Idle_Delay" to say 60 min or 360 min.

jearl28 05-01-2013 10:27 AM

Quote:

Originally Posted by chrism01 (Post 4938950)
I'm curious why you wouldn't go to v6.4 ie the latest? V5.x is getting old.
Also, when you say 'updated', I hope you mean 'replaced as fresh install', as RH does not support in-place upgrades across major versions https://access.redhat.com/site/docum...ted_Notes.html

Chris:

We just upgraded from v4 to v5 (not my choice, I have to do what management decides, they weren't ready to go to v6 yet).

v5 was acceptable as RH still supports it. We did not go to v6 because the custom software we run hasn't been tested on v6 yet.

When I say "updated", I just mean that we installed v5, then ran the Package Updater to make sure we had the "latest" of everything.

jearl28 05-01-2013 10:28 AM

Quote:

Originally Posted by yowi (Post 4938858)
try 'xset -dpms'

yowi:

Thanks! I added your command above to my ~/.initrc file. I'll let you know if it works. I assume I have to log out and back in again afterwards?

jearl28 05-01-2013 10:41 AM

Quote:

Originally Posted by John VV (Post 4939029)
that is set for every user in the gnome preferences

for each user
from the gnome desktop
/System/Preferences/Screensaver

I've already done this, as I said in my original post.

now if one of the ss's are running uncheck the checkbox
"Activate the screensaver after the computer is idle for..."

for the "black screen"
click on the "powerManager" button
under "On AC power"
select "never" for both

Where is this "powerManager" button? I don't see it on the System->Preferences->Screen Saver screen.

and if that dose not work ( in ScientificLinux 6.4 it dose not any more -- it did in 5.9 )

install gconf-editor
-- not installed by default
Code:

su -
yum install gconf-editor

then run it as root
Code:

su -
gconf-editor

under the "Apps" on the left
select "gnome-screensaver"
and uncheck " idle_Activation_Enabled"
or set "Idle_Delay" to say 60 min or 360 min.

I'm unable to install this, as yum is complaining that my Python API version doesn't match the module struct version. Yet another thing to check.

John VV 05-01-2013 12:39 PM

Quote:

i'm unable to install this, as yum is complaining that my Python API version doesn't match the module struct version. Yet another thing to check.
if the version of python dose NOT match what is in the RHN update ( or base repo)
yum and part of Gnome -( as in a lot ) will not work .

yum and Gnome BOTH depend on that VERY specific version of python

now
you can install a second NEWER version of python " side by side" with the required version

with a busted yum you will have to manually replace the mismatched version of python with the correct version using " rpm and -force "

and for the older 5.9 that will be "python-2.4.3" from the RHN base repo
manually grab it from RHN and force reinstall it with rpm

then if you need the current python 2.7 or Python 3.3
you can install it side by side with the "must use" 2.4 version

yowi 05-03-2013 11:41 AM

Quote:

Originally Posted by jearl28 (Post 4942648)
yowi:

Thanks! I added your command above to my ~/.initrc file. I'll let you know if it works. I assume I have to log out and back in again afterwards?

I'm not sure, but you may have to enable dpms in your xorg.conf. Yeah, enable it to turn it off, there's logic in there somewhere.

"xset -q" gives you status info and check "man xorg.conf", there's more dpms options.


All times are GMT -5. The time now is 06:32 PM.