LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-21-2012, 05:22 AM   #16
hean01
LQ Newbie
 
Registered: Aug 2012
Location: Norrkoping, Sweden
Distribution: Fedora, Ubuntu, CentOS, RHEL
Posts: 23

Rep: Reputation: Disabled

That looks like you cant ssh to the server, log on to your server console and open
a terminal, run command 'ssh 270.0.0.1',to verify that the sshd is locally working
as expected.

Then from a client verify that you can connect to the server using ssh (putty.exe if
windows client) to iron out if its a firewall issue or not, if first test passed and
this test fails, a firewall is probably preventing access to port 22.

/Henrik
 
Old 09-23-2012, 08:10 PM   #17
weibo6914
LQ Newbie
 
Registered: Sep 2012
Posts: 27

Original Poster
Rep: Reputation: Disabled
Hi Henrik,

When I run the command "ssh 270.0.0.1" , it shows that "name or service not known", what is the problem?

Thanks.
 
Old 09-24-2012, 02:01 AM   #18
hean01
LQ Newbie
 
Registered: Aug 2012
Location: Norrkoping, Sweden
Distribution: Fedora, Ubuntu, CentOS, RHEL
Posts: 23

Rep: Reputation: Disabled
Oh, hold on a sec now, 270.0.0.1 is an invalid ip address, please make sure that
you have your network configuration setup correctly.


Regards,

Henrik Andersson
 
Old 09-24-2012, 02:04 AM   #19
weibo6914
LQ Newbie
 
Registered: Sep 2012
Posts: 27

Original Poster
Rep: Reputation: Disabled
Hi Henrik,

You mean I should change the server "270.0.0.1" to my own IP address here? How to update and modify? Sorry, I am very new to this product.

Thanks.
 
Old 09-24-2012, 02:21 AM   #20
hean01
LQ Newbie
 
Registered: Aug 2012
Location: Norrkoping, Sweden
Distribution: Fedora, Ubuntu, CentOS, RHEL
Posts: 23

Rep: Reputation: Disabled
Hi,

Yes, you should use ofcourse use your own ip addresses, you mentioned 270.0.0.1 in an earlier post and
i overlooked the fact that its just an invalid address in my answers back to you...

I'm not sure what you mean by how to update/modify ?

Do the tests i mentioned using the right server ipaddress to get further.

Regards,

Henrik Andersson
 
Old 09-24-2012, 07:52 PM   #21
weibo6914
LQ Newbie
 
Registered: Sep 2012
Posts: 27

Original Poster
Rep: Reputation: Disabled
Hi Henrik,

Sorry for the mistake, it's "127.0.0.1".

When I key in "ssh 127.0.0.1" at the master workstation, it says" permission denied, pls try again", is it a password problem? How to change my password there?

If the server is not open, I can not connect at the client side. Pls help.

Thanks a lot.
 
Old 09-25-2012, 09:44 PM   #22
EricTRA
LQ Guru
 
Registered: May 2009
Location: Gibraltar, Gibraltar
Distribution: Fedora 20 with Awesome WM
Posts: 6,805
Blog Entries: 1

Rep: Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295
Hi,

127.0.0.1 is localhost so you should try that on your server side. In order to be able to ssh into your server you need the openssh-server package and dependencies installed. Run the following and post output please:
Code:
rpm -qa | grep ssh
if the openssh-server package is in the list, then the server package is installed. Next run:
Code:
chkconfig --list sshd
service sshd status
as root or with sudo. If the sshd daemon reports running, then you need to check your firewall, if active with:
Code:
iptables -L
and if the daemon is listening with:
Code:
chkconfig --list sshd
netstat -tnlp
as root. If all this reports positive then your sshd_config should be checked. If any of the above checks out as negative then take it from there. When in doubt, post output of the commands.

Kind regards,

Eric
 
Old 09-25-2012, 10:32 PM   #23
weibo6914
LQ Newbie
 
Registered: Sep 2012
Posts: 27

Original Poster
Rep: Reputation: Disabled
Hi Eric,
Thanks for the reply.
This is what I get from my workstation.
Rpm –qa / grep ssh: grep – 2.5.1-55.el5
Chkconfig –list sshd: sshd 0: off, 1ff, 2: on, 3: on, 4: on, 5: on, 6: off
Service sshd status: openssh-daemon (pid 4059) is running.

I couldn't use my laptop to access the main station, what I should put there?
server:??
user: admin
password: xxxxxx.

Thanks.
 
Old 09-26-2012, 01:29 AM   #24
weibo6914
LQ Newbie
 
Registered: Sep 2012
Posts: 27

Original Poster
Rep: Reputation: Disabled
when I key in "netstat -tnlp", this is what I get:

Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
tcp 0 0 127.0.0.1:2208 0.0.0.0:* LISTEN 4039/hpiod
tcp 0 0 0.0.0.0:5989 0.0.0.0:* LISTEN 4739/cimserver
tcp 0 0 0.0.0.0:9000 0.0.0.0:* LISTEN 16867/python-thinli
tcp 0 0 0.0.0.0:904 0.0.0.0:* LISTEN 16736/python-thinli
tcp 0 0 0.0.0.0:5900 0.0.0.0:* LISTEN 6238/vncserver-x11-
tcp 0 0 0.0.0.0:43501 0.0.0.0:* LISTEN 4024/socbu
tcp 0 0 0.0.0.0:9999 0.0.0.0:* LISTEN 10225/xoc_session_m
tcp 0 0 0.0.0.0:111 0.0.0.0:* LISTEN 3716/portmap
tcp 0 0 0.0.0.0:80 0.0.0.0:* LISTEN 4151/httpd
tcp 0 0 0.0.0.0:977 0.0.0.0:* LISTEN 3763/rpc.statd
tcp 0 0 0.0.0.0:1010 0.0.0.0:* LISTEN 16828/tlstunnel
tcp 0 0 0.0.0.0:22 0.0.0.0:* LISTEN 4059/sshd
tcp 0 0 127.0.0.1:631 0.0.0.0:* LISTEN 16629/cupsd
tcp 0 0 0.0.0.0:23 0.0.0.0:* LISTEN 4084/xinetd
tcp 0 0 0.0.0.0:27000 0.0.0.0:* LISTEN 4022/lmgrd
tcp 0 0 10.36.50.90:2809 0.0.0.0:* LISTEN 11115/Naming_Servic
tcp 0 0 127.0.0.1:25 0.0.0.0:* LISTEN 4117/sendmail: acce
tcp 0 0 0.0.0.0:443 0.0.0.0:* LISTEN 4151/httpd
tcp 0 0 0.0.0.0:8443 0.0.0.0:* LISTEN 4151/httpd
tcp 0 0 127.0.0.1:2207 0.0.0.0:* LISTEN 4044/python
 
Old 09-26-2012, 12:21 PM   #25
EricTRA
LQ Guru
 
Registered: May 2009
Location: Gibraltar, Gibraltar
Distribution: Fedora 20 with Awesome WM
Posts: 6,805
Blog Entries: 1

Rep: Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295
Hi,

Sorry for the late reply but the latest time I'm swamped in work. Do you by any change have iptables running which might be blocking access? Run:
Code:
iptables -L
as root or with sudo and post output. And are you sure the user 'admin' is a valid user account on the server? Run on the server:
Code:
id admin
Kind regards,

Eric
 
Old 09-26-2012, 08:08 PM   #26
weibo6914
LQ Newbie
 
Registered: Sep 2012
Posts: 27

Original Poster
Rep: Reputation: Disabled
Hi Eric,

When I run "iptables -L", I get so many information comes out, I am not sure which one I should focus on.

When I key in "id admin", it shows no such user, but when I installed " thinlinc" last time, it says user is "admin", so what I should do now? Change to another user? or find out the valid user account in the workstation? what code I should run?

Thanks.
 
Old 09-26-2012, 08:16 PM   #27
weibo6914
LQ Newbie
 
Registered: Sep 2012
Posts: 27

Original Poster
Rep: Reputation: Disabled
This is what I get for "iptables -L":

Chain INPUT (policy ACCEPT)
target prot opt source destination
RH-Firewall-1-INPUT all -- anywhere anywhere

Chain FORWARD (policy ACCEPT)
target prot opt source destination
RH-Firewall-1-INPUT all -- anywhere anywhere

Chain OUTPUT (policy ACCEPT)
target prot opt source destination

Chain RH-Firewall-1-INPUT (2 references)
target prot opt source destination
ACCEPT all -- anywhere anywhere
ACCEPT icmp -- anywhere anywhere icmp any
ACCEPT esp -- anywhere anywhere
ACCEPT ah -- anywhere anywhere
ACCEPT udp -- anywhere 224.0.0.251 udp dpt:mdns
ACCEPT udp -- anywhere anywhere udp dpt:ipp
ACCEPT tcp -- anywhere anywhere tcp dpt:ipp
ACCEPT all -- anywhere anywhere state RELATED,ESTABLISHED
ACCEPT tcp -- anywhere anywhere state NEW tcp dpt:5900
ACCEPT tcp -- anywhere anywhere state NEW tcp dpt:5901
ACCEPT tcp -- anywhere anywhere state NEW tcp dpt:5902
ACCEPT tcp -- anywhere anywhere state NEW tcp dpt:5903
ACCEPT tcp -- anywhere anywhere state NEW tcp dpt:5904
REJECT all -- anywhere anywhere reject-with icmp-host-prohibited
 
Old 09-27-2012, 01:19 AM   #28
hean01
LQ Newbie
 
Registered: Aug 2012
Location: Norrkoping, Sweden
Distribution: Fedora, Ubuntu, CentOS, RHEL
Posts: 23

Rep: Reputation: Disabled
Quote:
Originally Posted by weibo6914 View Post
Hi Eric,

When I run "iptables -L", I get so many information comes out, I am not sure which one I should focus on.

When I key in "id admin", it shows no such user, but when I installed " thinlinc" last time, it says user is "admin", so what I should do now? Change to another user? or find out the valid user account in the workstation? what code I should run?

Thanks.
Hi, again...

It says that the ThinLinc web adminsistration page username is admin, ThinLinc authenticates users
using PAM and in your case this is just local users of your ThinLinc server.


Kind Regards,

Henrik Andersson
 
Old 09-27-2012, 01:21 AM   #29
weibo6914
LQ Newbie
 
Registered: Sep 2012
Posts: 27

Original Poster
Rep: Reputation: Disabled
Hi Henrik,

How to see my thinlinc server name in my workstation?

Thanks.
 
Old 09-27-2012, 01:30 AM   #30
hean01
LQ Newbie
 
Registered: Aug 2012
Location: Norrkoping, Sweden
Distribution: Fedora, Ubuntu, CentOS, RHEL
Posts: 23

Rep: Reputation: Disabled
Hi,

The ThinLinc server name used in the client is the FQDN or ip address of your machine that
runs the ThinLinc server, by the look of the result from 'nestat -tnlp' in previous posts
it might be the address 10.36.50.90.


Regards,

Henrik
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem with setting vnc server with multi-ips whyyyhk Linux - Software 0 01-08-2012 04:26 AM
Using vnc in RHEL canceriandebu Linux - Newbie 2 07-12-2011 11:24 PM
[SOLVED] Multi-hop VNC tunnel over SSH deesto Linux - Networking 6 10-25-2010 07:38 AM
VNC, time-outs, and ports? bezdomny Linux - Software 2 05-01-2007 06:24 AM
VNC firewall ports Joe Donner Red Hat 5 06-20-2006 03:45 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 06:36 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration