-   Linux - Newbie (
-   -   How to create Dual boot disk on IDE & SATA (

bikerle 02-01-2005 08:27 AM

How to create Dual boot disk on IDE & SATA

I'm a new Linux user. I just bought an HP AThlon XP 3200+ which came with XP window and 160GB Seagate hard drive. Due to space limitation inside the PC, I have a SATA Maxtor 120GB drive installed instead of an IDE. So there is no Master and Slave drive. When I tried to install Red Hat 9.0, it only displays the "hda" drive as the only option. How do I configure the Maxtor as the secondary drive (hdb) so Red Hat can be installed ?

Thanx for your help - Bikerle

ganja_guru 02-02-2005 07:37 AM

RH 9 is a pretty old distro now...and it doesnt support SATA by default AFAIK(prob cause the technology wasnt too popular then)...

if u have access to a fast internet connection, try SUSE 9.2 or FEDORA CORE 3 or Mandrake ....all the latestversions have sata support..beleive me its much easier than trying to get it to work on RH 9...(RH 9 in my experience is pretty damn slow and bloated..)

bikerle 02-02-2005 07:45 AM

Ganja Guru,

Thanx a lot for the reply ! Will try as suggested ...

Have a nice day !- Bikerle

ganja_guru 02-02-2005 09:23 AM

also, if u dont want to bother with those huge downloads and still want to get the feel of user friendly linux, try mepis linux a shot...its actually a live cd(which means u can see what its all about without installing it)....if you like it then you just have to click on the 'mepis installation centre' icon on your desktop... believe me, it rocks! its much better than Suse, DC3 or mandrake,IMHO, and its pretty user friendly too...

bikerle 02-04-2005 07:52 AM

I downloaded the Fedora Core 3 onto 4 CDs (FC3-i386-disc1.iso, ... FC3-i386-disc4.iso) from It can detect the Maxtor drive as "sta" so I was able to install Fedora on the Maxtor drive (secondary drive). The installation finished (stopped) at the second disc (?) and it prompted to restart the PC, but there are 4 discs in total (?). Any idea ? It did not boot up all the way anyway, it stopped at midpoint. I had to reboot the PC and selected to boot up from WinXP. And following is the description of the next problem ...

Is it correct to install the GRUB boot loader on the primary drive (hda) ? that when the master boot record is read during the system boot it will prompt the user to boot from Linux or Window. I did just that by following the instructions from the web .... but when the PC was booted from Window, it jumped right into "HP System Recovery mode" . Somehow it tried to recover from the damage (?) It eventually booted up with WinXP with factory default installation ... but it goes back to the same scenario again if it's rebooted !

Thanx - Bikerle

ganja_guru 02-04-2005 10:12 AM

yes u can install the grub boot loader on either drive, but make sure you install it on the MBR of the drive...this might give you some wanings but click thru it...

when booting fedora, what do u mean when you say it doesnt boot all the way? where does it get stuck?

dont worry abt all your info in windows, its most probably intact..fedora probably did not ask you for the next cd cause you would have selected a minimal package all packages and it will probably ask you for all the cd's(though thats highly unnecessary, its the best way for a newbie)

run the installer again and this time select all packages and then select LILO as your boot loader ...ive always found this easier than back any error messages you get..

ganja_guru 02-04-2005 10:13 AM

oh and make sure the drive u install lilo on is the primary boot device in your BIOS...not sure if this will make a diff, but theoretically it should..

bikerle 02-07-2005 08:27 AM

Hi Ganja_Guru,

I've spend many hours try to boot from Federa C3 from the SATA drive. Fedora C3 does not have Lilo. Here is where it stopped ... It seems that it coud not find the kernel to boot ... The Grub is on the MBR on the IDE drive where the Window XP resides. Tried to put Grub on the Sata drive, it came up just "GRUB" on the screen and that was it ! Could not type anything.

Thanx - Bikerle.

Booting Fedora Core (2.6.9-1.667)

root (hd1,0)

Filesystem trype is ext2fs, partition type 0x83
kernel /vmlinuz-2.6.9-1.667 ro root=/dev/VolGroup00/LogVol00 rhgb quiet
[Linuz-bzImage, setup=0x1400, size=0x155da5]
initrd /initrd-2.6.9-1.667.img
[Linuz-initrd @ 0x1bede000, 0x101fca bytes]

Uncompressing Linuz... Ok, booting the kernel.
audit(1107781413.250:0): initialized
Red Hat nash version 4.1.18 starting

- (blinking cursor)


ganja_guru 02-07-2005 10:21 AM

did u try a reinstall with most packages selected? cause th installer doesnt just stop abruptly as you said, so something went wrong...ive heard a lot of problems where burned FC cd's just dont work for some reason or the other...

bikerle 02-07-2005 10:39 AM

I installed with the default, 2discs. If i select with everything option that just meant for all the software application (4 discs). Is that necessary ? I will try now anyway ...

Have a good day ! Bikerle

bikerle 02-07-2005 11:52 AM

Installed with all 4 discs. Same problem !!!!

ganja_guru 02-07-2005 12:11 PM

can you post the entire grub.conf file here?

ganja_guru 02-07-2005 12:18 PM

these might help, cause im not familiar with grub...

and for sata stuff

bikerle 02-07-2005 12:21 PM

How do I do that ? It does not respond to any command ... or return anything ...

ganja_guru 02-09-2005 09:32 AM

doesnt fc3 have some sort of rescue mode...?

All times are GMT -5. The time now is 07:23 PM.