Visit Jeremy's Blog.
Go Back > Forums > Linux Forums > Linux - Newbie
User Name
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!


  Search this Thread
Old 03-10-2004, 05:01 AM   #1
LQ Newbie
Registered: Mar 2004
Location: chennai
Distribution: Red hat 9
Posts: 15

Rep: Reputation: 0
how to connect to internet without using su..?

hello every body

i am using red hat 9 and able to connect to internet using wvdial ..this happens only
when ever i login as root only

as one my friend told not to always use the root login (becaue i always kogin as root) i started using the user login.. but i am not able to connect ...

i get the following error..

--> WvDial: Internet dialer version 1.53
--> Cannot open /dev/modem: Device or resource busy
--> Cannot open /dev/modem: Device or resource busy
--> Cannot open /dev/modem: Device or resource busy

but it is not the case with the root login

and one more question my friends that i face when i login as root is that

i get connected to the net but not getting any pages in mozilla..

so i used to down the eth0 interface by " # if down eth0" and therafter i able to get the pages

so i tried out the command of setting the default gateway by using the command

# /sbin/route add -net default wvdial
but got the error mesage as

SIOCADDRT: No such device

Thanks in advance
Old 03-10-2004, 05:08 AM   #2
Registered: Feb 2004
Location: Australia
Distribution: Ubuntu, Fedora 10
Posts: 632

Rep: Reputation: 31
I know. Everyone gets paranoid when using the root account.

I use it all the time becuase it means you dont have to continually type su everywhere.

I think it is important for people to understand that we are using home desktops, not network servers.

Anyway I think you will have to add your user to the appropriate group to give them access to the modem device. Dont know which one though, muck around a bit.

Old 03-10-2004, 06:59 AM   #3
Registered: Nov 2003
Location: Hyde Park, Ny
Distribution: Ubunta
Posts: 117

Rep: Reputation: 15

I was having the same problem with RH 8.0 however I was using KPPP.
Take a look at this its about KPPP but it might help you..


I did as instructed here and now I am able to use KPPP from my user account rather then the root account.

good luck


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
When i connect on the internet I want root not to access the internet !! skouket Linux - Security 12 07-10-2005 01:17 PM
Messed up my Internet Settings (can't connect to the internet) Almazick Linux - Wireless Networking 0 09-07-2004 07:23 PM
can't connect to the internet:linux dont read my internet address droplsh Linux - General 1 02-29-2004 08:32 PM
Can connect broadband but can't connect Internet satimis Linux - Networking 4 01-31-2004 08:58 PM
Can't connect to Internet Galphar Linux - Newbie 13 08-24-2003 04:14 PM > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 10:08 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration