LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-31-2010, 06:06 AM   #1
c.indrajith
LQ Newbie
 
Registered: May 2010
Posts: 1

Rep: Reputation: 0
Unhappy How to connect to internet using D-Link GLB-802c router in Ubuntu 9.10


Hi,

I'm a newbie to ubuntu, I'm using D-Link GLB-802C router to connect to internet, It has one Ethernet port and USB port. I want to connect to internet in ubuntu using USB port. My PC is P4 machine and it isn't a Ethernet interface.

My router's driver CD includes usb drivers to windows 98, xp OS only.

I want step by step guide to setup the internet connection in ubuntu.

I'm from sri lanka and i using SLT ADSL connection.

I really appreciate your help.
Thank you.
 
Old 05-31-2010, 11:58 AM   #2
Peacedog
LQ Guru
 
Registered: Sep 2003
Location: Danville, VA
Distribution: Slackware, Windows, FreeBSD, OpenBSD, Mac OS X
Posts: 5,296

Rep: Reputation: 168Reputation: 168
Hi c.indrajith, Welcome to LQ. Please post the out put of the following:

Code:
$ sudo ifconfig -a
$ sudo lsmod
$ sudo lsusb
Good luck. ;-)
 
Old 08-28-2010, 01:51 PM   #3
arulkurianraj
LQ Newbie
 
Registered: Aug 2010
Posts: 8

Rep: Reputation: 0
Unhappy Trouble with D-Link GLB-802C

My D-Link GLB-802C router fails to be detected in ubuntu 10.04 (connected via usb as i have a problem with my ethernet card).Help me out...
 
Old 08-28-2010, 01:55 PM   #4
arulkurianraj
LQ Newbie
 
Registered: Aug 2010
Posts: 8

Rep: Reputation: 0
On doing what "Peacedog" sugested
My results are as follows

$ sudo ifconfig -a

eth0 Link encap:Ethernet HWaddr 00:0e:a6:be:a6:26
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)
Interrupt:23 Base address:0xc000

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:44 errors:0 dropped:0 overruns:0 frame:0
TX packets:44 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:3152 (3.1 KB) TX bytes:3152 (3.1 KB)

$ sudo lsmod

Module Size Used by
nls_iso8859_1 3249 1
nls_cp437 4919 1
vfat 8933 1
fat 47767 1 vfat
binfmt_misc 6587 1
via 37920 2
drm 162409 3 via
snd_wavefront 33066 0
snd_via82xx 20058 2
saa7134_alsa 10380 0
snd_cs4236 25514 0
snd_ac97_codec 100646 1 snd_via82xx
ac97_bus 1002 1 snd_ac97_codec
snd_wss_lib 23410 2 snd_wavefront,snd_cs4236
snd_opl3_lib 8966 2 snd_wavefront,snd_cs4236
snd_hwdep 5412 2 snd_wavefront,snd_opl3_lib
snd_seq_dummy 1338 0
snd_pcm_oss 35308 0
snd_mixer_oss 13746 1 snd_pcm_oss
snd_seq_oss 26726 0
snd_pcm 70662 6 snd_via82xx,saa7134_alsa,snd_cs4236,snd_ac97_codec,snd_wss_lib,snd_pcm_oss
snd_page_alloc 7076 3 snd_via82xx,snd_wss_lib,snd_pcm
snd_mpu401 5123 0
snd_mpu401_uart 5617 4 snd_wavefront,snd_via82xx,snd_cs4236,snd_mpu401
snd_seq_midi 4557 0
snd_rawmidi 19056 3 snd_wavefront,snd_mpu401_uart,snd_seq_midi
snd_seq_midi_event 6003 2 snd_seq_oss,snd_seq_midi
saa7134 143391 1 saa7134_alsa
snd_seq 47263 6 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_seq_midi_event
snd_timer 19098 4 snd_wss_lib,snd_opl3_lib,snd_pcm,snd_seq
snd_seq_device 5700 6 snd_opl3_lib,snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_rawmidi,snd_seq
ir_common 38875 1 saa7134
i2c_viapro 5573 0
fbcon 35102 71
tileblit 2031 1 fbcon
font 7557 1 fbcon
bitblit 4707 1 fbcon
softcursor 1189 1 bitblit
v4l2_common 15431 1 saa7134
ppdev 5259 0
snd 54148 22 snd_wavefront,snd_via82xx,saa7134_alsa,snd_cs4236,snd_ac97_codec,snd_wss_lib,snd_opl3_lib,snd_hwdep, snd_pcm_oss,snd_mixer_oss,snd_seq_oss,snd_pcm,snd_mpu401,snd_mpu401_uart,snd_rawmidi,snd_seq,snd_tim er,snd_seq_device
vga16fb 11385 1
vgastate 8961 1 vga16fb
ns558 3056 0
via_ircc 21745 0
videodev 34361 2 saa7134,v4l2_common
v4l1_compat 13251 1 videodev
videobuf_dma_sg 10782 2 saa7134_alsa,saa7134
gameport 9089 3 snd_via82xx,ns558
via_agp 5310 1
parport_pc 25962 1
soundcore 6620 1 snd
videobuf_core 16356 2 saa7134,videobuf_dma_sg
irda 186556 1 via_ircc
crc_ccitt 1339 1 irda
agpgart 31724 2 drm,via_agp
shpchp 28820 0
tveeprom 11102 1 saa7134
lp 7028 0
parport 32635 3 ppdev,parport_pc,lp
usbhid 36110 0
hid 67032 1 usbhid
usb_storage 39425 0
via_rhine 19154 0
mii 4381 1 via_rhine
pata_via 7272 3
floppy 53016 0

$ sudo lsusb

Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 003: ID 0f62:1001 Acrox Technologies Co., Ltd Targus Mini Trackball Optical Mouse
Bus 003 Device 002: ID 0915:0005 GlobeSpan, Inc. LAN Modem
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 002: ID 0951:1607 Kingston Technology DataTraveler 100
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

the device is being listed when using "lsusb".but am unable to detect it.
help
help
help
 
Old 08-28-2010, 02:06 PM   #5
Kenny_Strawn
Senior Member
 
Registered: Feb 2010
Location: /usa/ca/orange_county/lake_forest
Distribution: ArchBang, Google Android 2.1 + Motoblur (on Motortola Flipside), Google Chrome OS (on Cr-48)
Posts: 1,791
Blog Entries: 62

Rep: Reputation: 56
<removed, as the commands were already posted>

Last edited by Kenny_Strawn; 08-28-2010 at 02:11 PM.
 
Old 08-28-2010, 05:10 PM   #6
Peacedog
LQ Guru
 
Registered: Sep 2003
Location: Danville, VA
Distribution: Slackware, Windows, FreeBSD, OpenBSD, Mac OS X
Posts: 5,296

Rep: Reputation: 168Reputation: 168
In both cases try

Code:
modprobe usbnet
.

I'm not sure if the module supports your particular device or not, but it's worth a try.

Good luck. ;-)
 
Old 08-29-2010, 12:40 AM   #7
arulkurianraj
LQ Newbie
 
Registered: Aug 2010
Posts: 8

Rep: Reputation: 0
This is what i get

FATAL: Error inserting usbnet (/lib/modules/2.6.32-24-generic/kernel/drivers/net/usb/usbnet.ko): Operation not permitted
 
Old 08-29-2010, 04:40 PM   #8
Peacedog
LQ Guru
 
Registered: Sep 2003
Location: Danville, VA
Distribution: Slackware, Windows, FreeBSD, OpenBSD, Mac OS X
Posts: 5,296

Rep: Reputation: 168Reputation: 168
My apologies, you should include sudo or su privileges.

Code:
$ sudo modprobe usbnet
Good luck. ;-)
 
Old 08-30-2010, 09:50 AM   #9
arulkurianraj
LQ Newbie
 
Registered: Aug 2010
Posts: 8

Rep: Reputation: 0
I get nothing on doing so.
 
Old 08-30-2010, 10:10 AM   #10
Peacedog
LQ Guru
 
Registered: Sep 2003
Location: Danville, VA
Distribution: Slackware, Windows, FreeBSD, OpenBSD, Mac OS X
Posts: 5,296

Rep: Reputation: 168Reputation: 168
When a commands returns no input it typically executed with out error. Please post the out put from the following.

Code:
$ sudo lsmod | grep usb
Good luck. ;-)
 
Old 08-30-2010, 11:04 AM   #11
arulkurianraj
LQ Newbie
 
Registered: Aug 2010
Posts: 8

Rep: Reputation: 0
This is the result.

usbhid 36110 0
hid 67032 1 usbhid
usb_storage 39425 1
 
Old 08-30-2010, 10:52 PM   #12
Peacedog
LQ Guru
 
Registered: Sep 2003
Location: Danville, VA
Distribution: Slackware, Windows, FreeBSD, OpenBSD, Mac OS X
Posts: 5,296

Rep: Reputation: 168Reputation: 168
How about this.

Code:
$ sudo lsmod
Good luck. ;-)
 
Old 08-31-2010, 10:48 AM   #13
arulkurianraj
LQ Newbie
 
Registered: Aug 2010
Posts: 8

Rep: Reputation: 0
This is the result...

Module Size Used by
nls_iso8859_1 3249 2
nls_cp437 4919 2
vfat 8933 2
fat 47767 1 vfat
nls_utf8 1069 1
isofs 29250 1
via 37920 2
drm 162409 3 via
binfmt_misc 6587 1
snd_wavefront 33066 0
snd_cs4236 25514 0
snd_wss_lib 23410 2 snd_wavefront,snd_cs4236
snd_opl3_lib 8966 2 snd_wavefront,snd_cs4236
snd_hwdep 5412 2 snd_wavefront,snd_opl3_lib
snd_mpu401 5123 0
snd_via82xx 20058 2
snd_ac97_codec 100646 1 snd_via82xx
ac97_bus 1002 1 snd_ac97_codec
snd_mpu401_uart 5617 4 snd_wavefront,snd_cs4236,snd_mpu401,snd_via82xx
snd_seq_dummy 1338 0
snd_seq_oss 26726 0
saa7134_alsa 10380 0
snd_pcm_oss 35308 0
snd_seq_midi 4557 0
snd_mixer_oss 13746 1 snd_pcm_oss
snd_rawmidi 19056 3 snd_wavefront,snd_mpu401_uart,snd_seq_midi
snd_pcm 70662 6 snd_cs4236,snd_wss_lib,snd_via82xx,snd_ac97_codec,saa7134_alsa,snd_pcm_oss
snd_seq_midi_event 6003 2 snd_seq_oss,snd_seq_midi
snd_page_alloc 7076 3 snd_wss_lib,snd_via82xx,snd_pcm
snd_seq 47263 6 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_seq_midi_event
snd_timer 19098 4 snd_wss_lib,snd_opl3_lib,snd_pcm,snd_seq
fbcon 35102 71
tileblit 2031 1 fbcon
saa7134 143391 1 saa7134_alsa
snd_seq_device 5700 6 snd_opl3_lib,snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_rawmidi,snd_seq
font 7557 1 fbcon
bitblit 4707 1 fbcon
softcursor 1189 1 bitblit
i2c_viapro 5573 0
vga16fb 11385 1
vgastate 8961 1 vga16fb
snd 54148 22 snd_wavefront,snd_cs4236,snd_wss_lib,snd_opl3_lib,snd_hwdep,snd_mpu401,snd_via82xx,snd_ac97_codec,sn d_mpu401_uart,snd_seq_oss,saa7134_alsa,snd_pcm_oss,snd_mixer_oss,snd_rawmidi,snd_pcm,snd_seq,snd_tim er,snd_seq_device
ir_common 38875 1 saa7134
v4l2_common 15431 1 saa7134
ns558 3056 0
via_ircc 21745 0
ppdev 5259 0
via_agp 5310 1
videodev 34361 2 saa7134,v4l2_common
v4l1_compat 13251 1 videodev
gameport 9089 3 snd_via82xx,ns558
soundcore 6620 1 snd
irda 186556 1 via_ircc
crc_ccitt 1339 1 irda
parport_pc 25962 1
shpchp 28820 0
agpgart 31724 2 drm,via_agp
videobuf_dma_sg 10782 2 saa7134_alsa,saa7134
videobuf_core 16356 2 saa7134,videobuf_dma_sg
tveeprom 11102 1 saa7134
lp 7028 0
parport 32635 3 ppdev,parport_pc,lp
usbhid 36110 0
hid 67032 1 usbhid
usb_storage 39425 1
via_rhine 19154 0
mii 4381 1 via_rhine
pata_via 7272 4
floppy 53016 0
 
Old 08-31-2010, 11:40 AM   #14
Peacedog
LQ Guru
 
Registered: Sep 2003
Location: Danville, VA
Distribution: Slackware, Windows, FreeBSD, OpenBSD, Mac OS X
Posts: 5,296

Rep: Reputation: 168Reputation: 168
What is the output from the following.

Code:
$ sudo ifconfig -a
$ sudo dmesg | grep -i usb
Good luck. ;-)
 
Old 09-03-2010, 02:23 PM   #15
arulkurianraj
LQ Newbie
 
Registered: Aug 2010
Posts: 8

Rep: Reputation: 0
The Results are:

eth0 Link encap:Ethernet HWaddr 00:0e:a6:be:a6:26
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)
Interrupt:23

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:44 errors:0 dropped:0 overruns:0 frame:0
TX packets:44 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:3152 (3.1 KB) TX bytes:3152 (3.1 KB)



[ 0.135941] usbcore: registered new interface driver usbfs
[ 0.135957] usbcore: registered new interface driver hub
[ 0.135998] usbcore: registered new device driver usb
[ 0.234275] ehci_hcd: USB 2.0 'Enhanced' Host Controller (EHCI) Driver
[ 0.234710] ehci_hcd 0000:00:10.3: new USB bus registered, assigned bus number 1
[ 0.284082] ehci_hcd 0000:00:10.3: USB 2.0 started, EHCI 1.00
[ 0.284328] usb usb1: configuration #1 chosen from 1 choice
[ 0.284381] hub 1-0:1.0: USB hub found
[ 0.284495] ohci_hcd: USB 1.1 'Open' Host Controller (OHCI) Driver
[ 0.284521] uhci_hcd: USB Universal Host Controller Interface driver
[ 0.284703] uhci_hcd 0000:00:10.0: new USB bus registered, assigned bus number 2
[ 0.284870] usb usb2: configuration #1 chosen from 1 choice
[ 0.284902] hub 2-0:1.0: USB hub found
[ 0.285027] uhci_hcd 0000:00:10.1: new USB bus registered, assigned bus number 3
[ 0.285186] usb usb3: configuration #1 chosen from 1 choice
[ 0.285217] hub 3-0:1.0: USB hub found
[ 0.285334] uhci_hcd 0000:00:10.2: new USB bus registered, assigned bus number 4
[ 0.285498] usb usb4: configuration #1 chosen from 1 choice
[ 0.285529] hub 4-0:1.0: USB hub found
[ 0.980103] usb 3-1: new low speed USB device using uhci_hcd and address 2
[ 1.159324] usb 3-1: configuration #1 chosen from 1 choice
[ 1.400043] usb 3-2: new full speed USB device using uhci_hcd and address 3
[ 1.558287] usb 3-2: configuration #1 chosen from 1 choice
[ 1.835087] usbcore: registered new interface driver hiddev
[ 1.848649] input: Acrox USB & PS/2 Mouse as /devices/pci0000:00/0000:00:10.1/usb3/3-1/3-1:1.0/input/input5
[ 1.848847] generic-usb 0003:0F62:1001.0001: input,hidraw0: USB HID v1.10 Mouse [Acrox USB & PS/2 Mouse] on usb-0000:00:10.1-1/input0
[ 1.848898] usbcore: registered new interface driver usbhid
[ 1.848903] usbhid: v2.6:USB HID core driver
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
how to connect 2 router d-link mido Linux - Networking 1 08-19-2008 07:19 PM
Connect D-Link WBR-1310 Router To Ad-Hoc Network tpreitzel Linux - Networking 0 07-04-2008 03:45 PM
Cannot connect to internet or ping router in Ubuntu 5.04 chrisjs162216 Linux - Networking 12 02-26-2006 01:04 PM
internet through d-link router-modem phlppmrtns5 Linux - Networking 1 07-18-2005 05:07 AM
d link router mandrake 10 slow internet Caper Linux - Hardware 1 07-04-2004 01:52 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 03:27 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration