Download your favorite Linux distribution at LQ ISO.
Go Back > Forums > Linux Forums > Linux - Newbie
User Name
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!


  Search this Thread
Old 07-19-2011, 11:18 PM   #1
Registered: Feb 2010
Location: Sri Lanka
Posts: 59

Rep: Reputation: 15
How to connect to Internet slackware 13.1

I installed slackware 13.1 to my laptop.I i use my e220 HSDPA usb dongle to connect internet.I previously i used ubuntu and it auto detected and connect to internet.But i could not connect with slackware .After lot of searching i found wvdial will resolve the problem .
I tried it and i got following output

root@darkstar:~# wvdial
--> WvDial: Internet dialer version 1.61

Cannot get information for serial port.
Initializing modem.

Sending: ATZ
Sending: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0

Modem initialized.

Sending: ATDT*99#

Waiting for carrier.

Carrier detected. Waiting for prompt.

Don't know what to do! Starting pppd and hoping for the best.

Starting pppd at Tue Jul 19 21:04:00 2011

Pid of pppd: 13162
Using interface ppp0

pppd: (加06][08]@Ω06][08]

pppd: (加06][08]@Ω06][08]

pppd: (加06][08]@Ω06][08]

pppd: (加06][08]@Ω06][08]

pppd: (加06][08]@Ω06][08]

pppd: (加06][08]@Ω06][08]

local IP address

pppd: (加06][08]@Ω06][08]

remote IP address

pppd: (加06][08]@Ω06][08]

primary DNS address
pppd: (加06][08]@Ω06][08]

secondary DNS address

pppd: (加06][08]@Ω06][08]

But its not connecting to internet.What should i do.Help me
Old 07-19-2011, 11:34 PM   #2
Registered: Mar 2011
Location: Brisbane
Distribution: Windows 10, Red Hat, Debian
Posts: 183

Rep: Reputation: 22
What's your /etc/wvdial.conf look like ?

And make sure /etc/resolv.conf information is set to the proper nameserver. My wvdial sometimes randomly wipes the file.

Last edited by 0men; 07-19-2011 at 11:43 PM.
Old 07-20-2011, 02:02 AM   #3
LQ Addict
Registered: Jul 2003
Location: London, UK
Distribution: Slackware
Posts: 7,464

Rep: Reputation: Disabled
You should probably remove IP addresses from that output, too.
Old 07-20-2011, 11:37 PM   #4
Registered: Feb 2010
Location: Sri Lanka
Posts: 59

Original Poster
Rep: Reputation: 15

[Dialer Defaults]

Init1 = ATZ

Init2 = ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0

Modem Type = Analog Modem

Phone = *99#

ISDN = 0

Password = ******
Username = 071364572

Modem = /dev/ttyUSB0

Baud = 9600
Old 07-21-2011, 01:49 AM   #5
Registered: Feb 2010
Location: Sri Lanka
Posts: 59

Original Poster
Rep: Reputation: 15

I add relavent information to /etc/resolv.conf and it worked .Thank you very much


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Trying to connect to Internet using Slackware 12.1 darkstar01 Linux - Newbie 23 11-13-2008 07:57 PM
how connect Slackware 12.0 to internet? niceday Linux - Networking 9 07-21-2007 01:45 AM
Can't connect to internet under Slackware 11.0 nisi Linux - Networking 2 02-06-2007 04:00 PM
cant connect to internet with slackware, seemed to have tried everything sgold7878 Linux - Networking 1 06-14-2005 01:16 PM > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 06:44 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration