LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 04-08-2017, 09:07 AM   #1
psyl0cke
LQ Newbie
 
Registered: Apr 2017
Posts: 4

Rep: Reputation: Disabled
Smile How to configure xrandr properly?


Hey!

I'm a linux noob, but I've already used Ubuntu and Backtrack in the past. I installed Kali 64 bit 2016.2 with Windows 10 as dual boot. I could fix the gray and the black screen problems, but I can't get the solution to set the right screen resolution. I've searched on the net, but I'm perfectly lost.

If I run Kali with USB, it works properly. I see 1366x786 LVDS-1 is set and VGA-1, HDMI-1, DP-1 are disconnected.

But my main system shows:
xrandr -q
xrandr: Failed to get size of gamma for output default
Screen 0: minimum 1024 x 768, current 1024 x 768, maximum 1024 x 768
default connected 1024x768+0+0 0mm x 0mm
1024x768 76.00*

cvt 1366 768 60
# 1368x768 59.88 Hz (CVT) hsync: 47.79 kHz; pclk: 85.25 MHz
Modeline "1368x768_60.00" 85.25 1368 1440 1576 1784 768 771 781 798 -hsync +vsync

xrandr --newmode "1368x768_60.00" 85.25 1368 1440 1576 1784 768 771 781 798 -hsync +vsync
xrandr: Failed to get size of gamma for output default

xrandr --output default --mode 1368x768_60.00 --gamma 0:0:0
xrandr: cannot find mode 1368x768_60.00

Please help me, I would like to use linux!
 
Old 04-09-2017, 03:21 AM   #2
ferrari
LQ Guru
 
Registered: Sep 2003
Location: Auckland, NZ
Distribution: openSUSE Leap
Posts: 5,230

Rep: Reputation: 1006Reputation: 1006Reputation: 1006Reputation: 1006Reputation: 1006Reputation: 1006Reputation: 1006Reputation: 1006
It's likely that you have a framebuffer driver in use. Check Xorg.0.log for the active graphics driver. If unsure, run the following

Code:
egrep "LoadModule|UnloadModule" /var/log/Xorg.0.log
Post your graphics hardware details as well. Run
Code:
inxi -Gxz
or
Code:
/sbin/lspci -nnk|grep '\[03' -A3

Last edited by ferrari; 04-09-2017 at 03:24 AM.
 
Old 04-09-2017, 04:01 AM   #3
ondoho
LQ Addict
 
Registered: Dec 2013
Posts: 17,235
Blog Entries: 10

Rep: Reputation: 5160Reputation: 5160Reputation: 5160Reputation: 5160Reputation: 5160Reputation: 5160Reputation: 5160Reputation: 5160Reputation: 5160Reputation: 5160Reputation: 5160
personally, i prefer to use a graphical frontend to xrandr, e.g. arandr (with drag'n'drop functionality :-).
 
Old 04-09-2017, 04:58 AM   #4
psyl0cke
LQ Newbie
 
Registered: Apr 2017
Posts: 4

Original Poster
Rep: Reputation: Disabled
Information

1) egrep "LoadModule|UnloadModule" /var/log/Xorg.0.log
[ 32.357] (II) LoadModule: "glx"
[ 32.426] (II) LoadModule: "modesetting"
[ 32.436] (II) LoadModule: "fbdev"
[ 32.448] (II) LoadModule: "vesa"
[ 32.455] (II) LoadModule: "fbdevhw"
[ 32.456] (II) UnloadModule: "modesetting"
[ 32.456] (II) LoadModule: "fb"
[ 32.474] (II) LoadModule: "shadow"
[ 32.475] (II) UnloadModule: "vesa"
[ 34.618] (II) LoadModule: "libinput"

2) inxi -Gxz
Graphics: Card-1: Intel 3rd Gen Core processor Graphics Controller
bus-ID: 00:02.0
Card-2: NVIDIA GK208M [GeForce GT 720M] bus-ID: 01:00.0
Display Server: X.org 1.19.2 drivers: fbdev (unloaded: modesetting,vesa)
tty size: 80x24 Advanced Data: N/A for root

3) /sbin/lspci -nnk|grep '\[03' -A3
bash: /sbin/lspci: No such file or directory

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
4) arandr
I installed arandr, it sees default instead of LVDS-1 too.
 
Old 04-09-2017, 05:43 AM   #5
ferrari
LQ Guru
 
Registered: Sep 2003
Location: Auckland, NZ
Distribution: openSUSE Leap
Posts: 5,230

Rep: Reputation: 1006Reputation: 1006Reputation: 1006Reputation: 1006Reputation: 1006Reputation: 1006Reputation: 1006Reputation: 1006
The posted output confirms that the fbdev (basic framebuffer) driver is loaded. This limits the display resolution to 1024x768. I'm surprised that the nouveau driver was not loaded for this NVIDIA chipset. Are you using the 'nomodeset' boot parameter perhaps?
Code:
cat /proc/cmdline
I'm not familiar with NVIDIA hardware, but it may be that you can install the propriety 'nvidia' driver for this graphics card model. I'll leave others to advise further about that.

BTW, the lspci command is probably located somewhere else in your distro. If it is in the path, you could just do lspci....
Code:
lspci -nnk
although the inxi command has already given us the necessary information.
 
Old 04-09-2017, 05:47 AM   #6
ferrari
LQ Guru
 
Registered: Sep 2003
Location: Auckland, NZ
Distribution: openSUSE Leap
Posts: 5,230

Rep: Reputation: 1006Reputation: 1006Reputation: 1006Reputation: 1006Reputation: 1006Reputation: 1006Reputation: 1006Reputation: 1006
Quote:
I'm a linux noob, but I've already used Ubuntu and Backtrack in the past. I installed Kali 64 bit 2016.2
Since you mentioned that you're inexperienced with Linux, I was surprised that you're using Kali. I'd choose something a little more mainstream such as Linux Mint as you're likely to get a better "new user experience" with it IMHO.
 
Old 04-09-2017, 07:31 AM   #7
psyl0cke
LQ Newbie
 
Registered: Apr 2017
Posts: 4

Original Poster
Rep: Reputation: Disabled
Thanks for helping me out!
I could fix it.
The solution was that I removed nomodeset with verbose.
The Win2Grub works fine with no parameters or with "quiet splash".

I was using BackTrack for 2 years long, and it was the only installed OS on my notebook.
I shouldn't do complicated linux tasks, just use Internet and do programming - that is why I think that I'm still a noob.

Now I installed Kali because I'm doing a course which uses it.
I could do everything without Kali on Win10 during the course until now, but I felt I should use Kali for try out what the course does under Kali.

Thanks a lot for solving it!
 
Old 04-09-2017, 07:48 AM   #8
Emerson
LQ Sage
 
Registered: Nov 2004
Location: Saint Amant, Acadiana
Distribution: Gentoo ~arch
Posts: 7,231

Rep: Reputation: Disabled
To "use internet" as root is a big no-no. I hope you created a user for your everyday tasks?
 
Old 04-09-2017, 11:12 AM   #9
Shadow_7
Senior Member
 
Registered: Feb 2003
Distribution: debian
Posts: 4,137
Blog Entries: 1

Rep: Reputation: 873Reputation: 873Reputation: 873Reputation: 873Reputation: 873Reputation: 873Reputation: 873
$ xrandr --output LVDS-1 --mode 1366x768 --panning 1366x768 --primary --gamma 1:1:1 --brightness 1

That should be a close to "defaults" as necessary. You probably don't want 0:0:0 as that would be solid black.

$ xrandr --output HDMI-0 --brightness 0.65 --gamma 1.6:1.46:1.53

Is what I use for an HP IPS display that is quite horrid at 1:1:1.
 
Old 04-09-2017, 01:34 PM   #10
ferrari
LQ Guru
 
Registered: Sep 2003
Location: Auckland, NZ
Distribution: openSUSE Leap
Posts: 5,230

Rep: Reputation: 1006Reputation: 1006Reputation: 1006Reputation: 1006Reputation: 1006Reputation: 1006Reputation: 1006Reputation: 1006
Quote:
Thanks for helping me out!
I could fix it.
The solution was that I removed nomodeset with verbose.
Glad to have been of help!
 
Old 04-10-2017, 02:49 PM   #11
psyl0cke
LQ Newbie
 
Registered: Apr 2017
Posts: 4

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by Emerson View Post
To "use internet" as root is a big no-no. I hope you created a user for your everyday tasks?
Yeah, I have one user, which can do sudo su.
Thanks for the idea.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Migrate to IPTABLES, help to configure properly lithos Linux - Security 3 02-10-2012 12:47 PM
How to configure NFS properly without using no_root_squash? Blackhole Linux - Networking 1 09-25-2011 05:06 PM
reverse proxy not able to configure properly tkmsr Linux - Server 3 04-22-2010 12:49 PM
radeon and dual head, to xrandr or not to xrandr, that's the question i92guboj Linux - Desktop 1 06-17-2009 05:48 AM
Help - How can I configure my touchpad properly ? Christof999 Linux - Laptop and Netbook 4 05-12-2007 04:02 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 05:32 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration