LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 11-02-2008, 12:19 AM   #1
quest999
LQ Newbie
 
Registered: Nov 2008
Distribution: Gentoo, Ubuntu, Centos
Posts: 3

Rep: Reputation: 0
How to configure static IP in Backtrack 3 in a VMware?


My partner and I both have difficulties figuring out how to configure static IP in Backtrack 3 in a VMware. He installed Backtrack 3 in a VMware workstation in Windows Vista. I installed Backtrack 3 in a VMware Server in Ubuntu.

We tried to follow slackware's documents on static IP configuration. So far no luck. Could anyone shed some light here? Thank you.
 
Old 11-02-2008, 05:15 PM   #2
harry edwards
Member
 
Registered: Nov 2007
Location: Lincolnshire, UK
Distribution: CentOS, Fedora, and Suse
Posts: 365

Rep: Reputation: 48
Have you tried something like:

ifconfig 192.168.1.10 eth0

This command will set the IP address of 192.168.1.10 for the newtork card eth0.
 
Old 11-14-2008, 01:12 AM   #3
quest999
LQ Newbie
 
Registered: Nov 2008
Distribution: Gentoo, Ubuntu, Centos
Posts: 3

Original Poster
Rep: Reputation: 0
No it doesn't work. This is what I got:

bt ~ # ifconfig 192.168.1.40 eth0
eth0: Unknown host
ifconfig: `--help' gives usage information.
 
Old 07-01-2009, 08:04 AM   #4
Diggy
Member
 
Registered: Jan 2009
Posts: 47

Rep: Reputation: 17
This is way after the fact, but the command to change the IP address is "ifconfig eth0 x.x.x.x". You have the device and the address in the wrong order. I, too, have the Backtrack 3 VM installed, and changed the IP address. Hope this helps someone.

Diggy
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
installing vmware tools in backtrack ?? cyberiapost Linux - Newbie 6 11-02-2008 12:22 AM
configure vmware tuxianD Fedora 8 10-17-2008 08:09 AM
Vmware Workstation and Backtrack 2.0 final Installation Problem musik4u66 Linux - Newbie 2 11-11-2007 10:54 AM
VMWare player + Linux BackTrack v2.0 + Wg111t = Impossible?!?! Linux_Inside_ Linux - Newbie 6 02-21-2007 09:01 AM
Windows Xp static IP in VMware Server; cannot ping google.com fakie_flip Linux - Networking 2 09-18-2006 01:09 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 03:50 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration