LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-19-2011, 12:55 AM   #1
hyousikyou
LQ Newbie
 
Registered: Sep 2011
Posts: 2

Rep: Reputation: Disabled
Question how to compile qemu statically?


when I compile qemu statically,there is a problem like below:
-------------------------------------------------------------------
[root@localhost qemu-0.14.1]# ./configure --static --prefix=/home/fengzhiqiang/bin/qemu-0.14.1 --disable-darwin-user --disable-bsd-user --target-list="arm-softmmu,arm-linux-user,armeb-linux-user" --enable-debug --enable-docs --enable-vnc-thread --disable-vnc-tls --disable-vnc-sasl --enable-system --enable-user --enable-linux-user --disable-sdl
big/little test failed

Error: zlib check failed
Make sure to have the zlib libs and headers installed.

[root@localhost qemu-0.14.1]# yum install zlib*
Loaded plugins: langpacks, presto, refresh-packagekit
Adding en_US to language list
Setting up Install Process
Package zlib-devel-1.2.5-2.fc14.i686 already installed and latest version
Package zlibrary-0.12.10-5.fc14.i686 already installed and latest version
Package zlibrary-devel-0.12.10-5.fc14.i686 already installed and latest version
Package zlib-1.2.5-2.fc14.i686 already installed and latest version
Package zlibrary-ui-qt-0.12.10-5.fc14.i686 already installed and latest version
Package zlib-static-1.2.5-2.fc14.i686 already installed and latest version
Package zlibrary-ui-gtk-0.12.10-5.fc14.i686 already installed and latest version
Nothing to do
-------------------------------------------------------------------
please help me!!!
 
Old 09-19-2011, 05:25 AM   #2
hyousikyou
LQ Newbie
 
Registered: Sep 2011
Posts: 2

Original Poster
Rep: Reputation: Disabled
it is a bug of qemu.
in fact,it is the glibc is not installed,
so intall the glibc,this problem will be solved.
finally it works,thank God.....
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Statically Compile PHP - Not possible then? helptonewbie Linux - Newbie 13 02-10-2011 12:06 PM
compile wget statically iggi Linux - Software 2 11-12-2007 07:50 AM
How to compile statically? futhark Linux - Software 2 04-16-2006 02:39 PM
Can't compile MPlayer statically. Nezzo Linux - Software 3 11-04-2003 07:29 PM
How do I statically compile a src.rpm? WeNdeL Linux - General 1 05-19-2003 11:32 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 09:15 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration