Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back > Forums > Linux Forums > Linux - Newbie
User Name
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!


  Search this Thread
Old 02-23-2003, 04:03 PM   #1
Registered: Jan 2003
Location: Belgium
Distribution: Mandrake 9.2
Posts: 475

Rep: Reputation: 30
Question How to change default desktop on boot?

I feel its a dummy question, but I don't find the ends.

I installed Mandrake and during installation I have choosen KDE as a default environment.

Now I actually use WindowMaker because its faster. I have told the Control Center to start Linux with WindowMaker but it continues to boot up with KDE.

Why is that? Where should I tell it to start with WindowMaker?
Old 02-23-2003, 04:38 PM   #2
Senior Member
Registered: Dec 2002
Location: England
Distribution: Used to use Mandrake/Mandriva
Posts: 2,794

Rep: Reputation: 116Reputation: 116
Can't you select WM from a drop down menu when you log in?
Does it not default to your previous selection?
Old 02-24-2003, 02:49 AM   #3
Registered: Jan 2003
Location: Belgium
Distribution: Mandrake 9.2
Posts: 475

Original Poster
Rep: Reputation: 30
Would you bark yourself if you have a dog?

Unfortunately its a bit more complicated.

During installation I have choosen to login automatically with KDE.

Whatever I do now - KDE starts automatically, even if WM has been choosen in the MCC.

The only way to go to WM, is to logout from KDE and select WM. It's possible, but its a longer way.
Old 02-24-2003, 03:19 AM   #4
Senior Member
Registered: Feb 2003
Distribution: Slackware
Posts: 4,113

Rep: Reputation: Disabled
If it's in your dropdown menu and you select it, it should be the default choice the next time you login. At least, I started in KDE, but downloaded blackbox, added it to my kdmrc, and now it's the default, though I actually never use the graphical login screen - I also switched my default runlevel to 3. But, still, the last selected wm is always the default wm in the graphical login.

If it isn't - you mentioned something about an installation choice and a default - follow out your inittab, which takes you to your rc.gui which takes you to your kdmrc or whatever... just trace out how the files connect to each other on startup. Somewhere in there will be a reference to KDE as a default - switch it to WindowMaker. I can't tell you exactly where, because it sounds like your system's configured differently than mine, but that's the principle, I think.
Old 02-24-2003, 04:14 AM   #5
Registered: Jan 2003
Location: Belgium
Distribution: Mandrake 9.2
Posts: 475

Original Poster
Rep: Reputation: 30
hmm... that needs time which I don't have right now. Thanks anyway. I will try that when my workday is over.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
default system desktop ? how to change? hvinelinux Fedora 5 01-27-2005 02:27 PM
Cannot change default desktop Wopke Fedora 1 06-23-2004 08:40 AM
How do I change the default desktop to KDE? jdruin Linux - Newbie 3 04-26-2004 06:47 PM
How do i change Lilo's default boot? kato678 Linux - General 2 02-21-2002 02:41 AM
How to change default desktop environment???? thegreenearth Linux - Newbie 7 11-15-2001 02:14 PM > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 07:31 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration