LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   How to become a Superuser to install a package that is downloaded (https://www.linuxquestions.org/questions/linux-newbie-8/how-to-become-a-superuser-to-install-a-package-that-is-downloaded-4175665557/)

ozstar 12-07-2019 03:30 AM

How to become a Superuser to install a package that is downloaded
 
Hi,

I am using Zorin 15. I found Xampp and downloaded it okay to the Downloads folder. Through the terminal I tried to run it but got this error.

Quote:

david@david-HP-Compaq-6000-Pro-MT-PC:~/Downloads$ sudo chmod +x xampp-linux-x64-7.3.10-1-installer.run
chmod: cannot access 'xampp-linux-x64-7.3.10-1-installer.run': No such file or directory
david@david-HP-Compaq-6000-Pro-MT-PC:~/Downloads$
I went to the terminal and made myself a Superuser (# at prompt) but it still keeps saying in the GUI that the installer needs Superuser privileges to install.

Quote:

root@david-HP-Compaq-6000-Pro-MT-PC:~/Downloads# sudo chmod +x xampp-linux-x64-7.1.33-1-installer.run
root@david-HP-Compaq-6000-Pro-MT-PC:~/Downloads#
According to the Terminal I am now a Superuser but it seems the GUI doesn't know it yet.

Any tips please?

fatmac 12-07-2019 04:32 AM

Maybe try ./xampp-linux-x64-7.1.33-1-installer.run in the folder that it is in(?).

colorpurple21859 12-07-2019 06:53 AM

Quote:

sudo su -
this will put you in /root.

beachboy2 12-07-2019 07:11 AM

ozstar,

Check the version numbers.
You used two different ones including xampp-linux-x64-7.1.33-1-installer.run.

Use:

Code:

cd Downloads
sudo chmod +x xampp-linux-x64-7.3.10-1-installer.run
sudo ./xampp-linux-x64-7.3.10-1-installer.run


yancek 12-07-2019 07:53 AM

The second command you ran brought you back to the prompt in the terminal which would usually indicate success. Run ls -l on the file will tell you if it is executable. Running a command with sudo in a terminal isn't going to give you root/sudo privileges in a GUI, that's expected behavior. The link below is the Ubuntu documentation on using sudo which might be worth looking at, particularly the Graphical Sudo section on that page. As you can see on that page, the methods vary depending upon the Desktop environment. What are you trying to do in the GUI?

ozstar 12-07-2019 04:29 PM

Thanks again yancek I appreciate the help.

I was trying to install the Xampp package but as you can see it just didn't happen.

I am trying to get my head around the Linux coding but in the meantime found this link which I followed to the dot and it gave installed the package. When I checked localhost via FF it was okay except for phpMyadmin which gave this error.


Quote:

Welcome to phpMyAdmin

Error

MySQL said: Documentation
Cannot connect: invalid settings.
mysqli_real_connect(): (HY000/2002): No such file or directory
Connection for controluser as defined in your configuration failed.
mysqli_real_connect(): (HY000/2002): No such file or directory
phpMyAdmin tried to connect to the MySQL server, and the server rejected the connection. You should check the host, username and password in your configuration and make sure that they correspond to the information given by the administrator of the MySQL server.

ozstar 12-07-2019 05:02 PM

OKAY GOT IT!

Needed to Start mySQL, so now have phpMyadmin okay.

Now to the next steps... :-)


All times are GMT -5. The time now is 01:31 AM.