LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-14-2005, 09:54 AM   #1
polemon
Member
 
Registered: Jun 2005
Distribution: Fedora 18, Ubuntu 11.10, Ubuntu Server 11.10, DamnSmallLinux 3.4.4, FreeDOS 1.1, OpenBSD 5.0
Posts: 194

Rep: Reputation: 31
Unhappy how to activate AUTH (port 113) deamon?


Hi,

I'd like to activate the built in auth deamon, so when i log in to IRC servers, they can authenticate me.

I wanted to activate telnet too.

What i did:

First i checked if ether of one is not allready working (netstat -apA inet).
-none was
I use FC4, so i looked in Desktop > System Settings > Server Settings > Services
and checked:
-auth
-telnet
-xined (was allready checked)

after a reboot, none of them were working.

so i went to /etc/xinetd.d/auth and changed there the status 'disabled = yes' to 'no'
the same i did with /etc/xinetd.d/telnet .

now telnet is working fine, but auth refuses to work.
I thought, maybe i can start it manually from a terminal.
so i entered '/usr/sbin/in.authd'
ok, it seemed to be running, but it was not listening.

I don't really know what to do after starting the deamon (is it really a deamon?)
after i start it, it just does nothing, when i hit the Enter-Key it answers:

0 , 0 : ERROR :INVALID-PORT

When i type '113, 113' it answers (after some time):

113 , 113 : ERROR :NO-USER

I am completely lost. It should be a server but it simply does not behave like one, it does not listen, and that buggs me the most...

please help me, how can i start in.authd so it listens on port 113?
 
Old 10-15-2005, 03:55 AM   #2
routers
Member
 
Registered: Aug 2005
Location: Malaysia - KULMY / CNXTH
Distribution: Slackware, Fedora, FreeBSD, Sun O/S 5.10, CentOS
Posts: 780
Blog Entries: 6

Rep: Reputation: 75
[root@net rou]# locate oidentd |grep /sbin
/usr/sbin/oidentd



if u dont have proceed

yum install oidentd

then then set nat open 113 point to ur machine

good luck
 
Old 10-15-2005, 05:55 AM   #3
init100
LQ Newbie
 
Registered: Oct 2005
Location: Europe
Distribution: Fedora Core 4
Posts: 20

Rep: Reputation: 0
Re: how to activate AUTH (port 113) deamon?

Quote:
I'd like to activate the built in auth deamon, so when i log in to IRC servers, they can authenticate me.
What for? I run FC4, I don't run identd, and the only issue is that I get to wait a little longer while the irc server tries to "authenticate" me. It will let me in anyway after 10-60 seconds.

I found a web page that points out why you don't want to do this: http://www.clock.org/~fair/opinion/identd.html

Quote:
I wanted to activate telnet too.
Don't do this. Use SSH instead. Otherwise your password and all your data will be transmitter in cleartext, allowing anyone who happen to listen on your network to get your user name and password. And you don't want that, do you? In addition, running the SSH daemon allows you to perform secure file transfers (SFTP) and secure X-forwarding, which enables you to run X applications remotely with the window appearing on your desktop as if it was run locally.

To start sshd, you can use the Desktop->System Settings->Server Settings->Services configuration tool. If you have any questions about this, feel free to ask, and I'll be happy to answer.
 
Old 10-15-2005, 06:29 AM   #4
routers
Member
 
Registered: Aug 2005
Location: Malaysia - KULMY / CNXTH
Distribution: Slackware, Fedora, FreeBSD, Sun O/S 5.10, CentOS
Posts: 780
Blog Entries: 6

Rep: Reputation: 75
yes init100 a lot of thing u are right no need me to argue about that

but some people doing this and that is for educational purpose

like me , I dmz my server almost 2 year there nothing happen

there u can learn security . if u think this one cannot that one cannot then u will never learn

if ur server got hacked one time then next step u know where is the weakness of the system

u handle .

i on my identd also nothing happen its because i belive i have good

firewall and i in the workstation not direct to the net w/o shield the only shield is the backend

firewall if i got hacked then i know my firewall is not good then i should change it to others

to be a fast learn is not to scared , scared no need to learn

------(Desktop->System Settings->Server Settings->Services)
somemore i never use this GUI style even my desktop very nice
http://img332.imageshack.us/img332/6...thmovie5mp.png



hope dont mad with me

Last edited by routers; 10-15-2005 at 06:31 AM.
 
Old 10-15-2005, 07:28 AM   #5
init100
LQ Newbie
 
Registered: Oct 2005
Location: Europe
Distribution: Fedora Core 4
Posts: 20

Rep: Reputation: 0
I'm not mad with anyone, I just wanted to point out some serious security issues. Why repeat other people's mistakes when you can make and learn from new ones?
 
Old 10-15-2005, 07:38 AM   #6
routers
Member
 
Registered: Aug 2005
Location: Malaysia - KULMY / CNXTH
Distribution: Slackware, Fedora, FreeBSD, Sun O/S 5.10, CentOS
Posts: 780
Blog Entries: 6

Rep: Reputation: 75
hi dude sorry if u think that way for me u not doing mistake as i state ur point is right
but i belive who come here is the people who want to learn not just want to settle thier problem
and me also i cant say i am good, sometime i open threads to ask the question i dont know

maybe the way i describe is a bit rought , but yeah sometime i admit myself is not perfect , correct me if there something i did wrong either little bit or little more btw sorry my english

i apologize
 
Old 10-16-2005, 02:25 PM   #7
polemon
Member
 
Registered: Jun 2005
Distribution: Fedora 18, Ubuntu 11.10, Ubuntu Server 11.10, DamnSmallLinux 3.4.4, FreeDOS 1.1, OpenBSD 5.0
Posts: 194

Original Poster
Rep: Reputation: 31
routers: lol, got THAT too (even the Q-Time --> MPlayer GUI)

init100:
What i need AUTH for: What routers said is quite right, educational reasons are here the point, plus if you try to log in to EFnet without AUTH, it just doesn't let you log on (I tryed with TELNET to port 6667, and yes, i know the RFC1459).

What I need TELNET for: It's easy to put strings to a telnet server, easier that with SSH, because when you intercept the send packages, you can see what my client (that I'm programming) is sending. So in this case, i actually make use of the fact, that it is not encrypted.
With this, i can see the raw packages _and_ what comes to the server.
(The telnet serv won't understand any of those commands, it's just something to see it the strings are well formated and stuff).

Now.

BUT none of you guys actually answered my question:
How to get in.authd to listen on port 113.

(Like I said in my initial post, Telnet server works now)

cheers,

--polemon
 
Old 10-16-2005, 04:06 PM   #8
routers
Member
 
Registered: Aug 2005
Location: Malaysia - KULMY / CNXTH
Distribution: Slackware, Fedora, FreeBSD, Sun O/S 5.10, CentOS
Posts: 780
Blog Entries: 6

Rep: Reputation: 75
polemon

post no 2 follow that only

there u go

------------------------------------
* Looking up irc.efnet.org
* Connecting to irc.efnet.net (192.116.231.44) port 6667...
* Connected. Now logging in...
* *** Looking up your hostname...
* *** Checking Ident
* *** Got Ident response



and this is inside my computer

[rou@net ~]$ netstat -an |grep 113
tcp 0 0 :::113 :::* LISTEN

[rou@net ~]$ ps awx |grep ident
1932 ? Ss 0:00 /usr/sbin/oidentd -q -u nobody -g nobody
------------------------------------------------

i hope u ok dude otherwise bring me banana let we eat together



Last edited by routers; 10-16-2005 at 04:15 PM.
 
Old 10-16-2005, 07:41 PM   #9
polemon
Member
 
Registered: Jun 2005
Distribution: Fedora 18, Ubuntu 11.10, Ubuntu Server 11.10, DamnSmallLinux 3.4.4, FreeDOS 1.1, OpenBSD 5.0
Posts: 194

Original Poster
Rep: Reputation: 31
/me hands routers a banana

Man, i want in.authd to work on my system!!!!!!111oneoneone
In fact, in the meantime i made it work, and it sits at port 113 and listens...
BUT it only gives out AUTH repsonses for the current connection of AUTH, anyting else, will get a : ERROR : NO-USER.
I and since the IRC server askes for the connection
IRC-Client <--> IRC-Server and not
AUTH-Server <--> IRC-Server, it doesn't work the right way.

But i think i'll figure it out eventually...

in the meantime, i guess i stick with your idea (this oidentd thing), and i'd like to thank you for that.

cheers

--polemon
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Port 113 floppywhopper Linux - Security 7 02-07-2008 07:51 PM
port 113 auth ident, not accepting connectiong green4u Linux - Security 1 07-18-2005 09:15 AM
port 113 pangfai Linux - Security 7 06-06-2002 06:53 AM
why is auth,portmap, 113 needed for? Noerr Linux - Security 2 05-31-2002 05:19 PM
My port 113 (auth?) is open. elconde Linux - Security 3 09-12-2001 04:36 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 09:42 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration