LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   How Embarrasing, root password lost need help (https://www.linuxquestions.org/questions/linux-newbie-8/how-embarrasing-root-password-lost-need-help-98367/)

Jadasin 09-29-2003 06:02 PM

How Embarrasing, root password lost need help
 
:) Well I wont make excuses for myself, there's just no denying it, I truly am a loser... So I left my place for a few months to go on this snowboarding camp thing and the whole time, ok maybe not the whole time, I couldn't wait to get back to my linux box.

When I get back for the life of me I can't seem to get my root password, it's either I've forgotten it or my box has rebelled at my leaving it for so long and changed the password on it's own.

So either way, this sucks and I'm wondering if anyone knows how or even if it's possible to retrieve and or replace a root password without having that intial access.

Before before I get the "just do a search on google response", :) , I'll say that I have, I've read alot of stuff about starting the kernel in lilo using somethin like "linux single" and then at prompt typing in passwd root but when I type linux single and shoves me a command line that asks for user and password, so still not good for me. I've just tried to read previous and didn't really find anything so this is what brings me to making a fool of myself and posting a, I lost my password, post... This sucks.

Please any help would be greatly appreciated, you've all come through for me in the past and I hope someone can think of something this time. TIA

OBTW: running Slackware 9.0
Bootloader: Lilo

Anna.

quatsch 09-29-2003 06:50 PM

you'd need to get into single user mode by
linux 1
at the lilo boot prompt - I'm pretty sure this is the way to do it; I'm sure 'linux single' is not right.. And then do the stuff you read online.

Nechos 09-29-2003 06:53 PM

check this:
http://www.joyoftech.com/joyoftech/j...ives/495b.html

Jadasin 09-29-2003 07:18 PM

Hey quatsch, thanks for tying, I tried the linux 1 instead of linux single and it basically got me to the exact same place, a prompt with login and password. I know the system is going on runtime level 1, which is single mode right ? But for some reason it wants me to log in as root to be able to do anything, I can get in as a normal user but yeahs that's just not good...

Anyways thanks again for trying, hopefully someone else will think of something, I really don't want to have to reinstall and loosing everything I use to have.

Oh and Nechos, thanks for that, don't know if I feel quite that bad but it may get to that.

Anna

quatsch 09-29-2003 07:36 PM

are you sure you're in single user mode? You should just get a prompt - no log in and no possibility to login as a normal user. Is 'linux' actually the label of your slack installation as it appears in the lilo menu?

Doesn't slackware have a rescue mode that you could start from the installation CD?

Jadasin 09-29-2003 08:39 PM

Hi Quatsch, I'm like 99% sure im in single user mode, I mean after I type Linux single or Linux 1 (the both did the same thing for me) it boots up, as it's booting up it clearly states setting to runlevel 1, is this the same as single user mode, I would imagine yes???

And yah I'm sure that Linux is the name of the kernel im trying to start, any more ideas?? I think i may be stuck doing a new install...

quatsch 09-29-2003 09:35 PM

do you ahve knoppix or something like that? Maybe you could start Knoppix, mount the slackaware / partition read-write and then edit /etc/passwd and /etc/shadow of your slackware installation as root (I think these are the two relevant files).

Blag-foo 09-29-2003 10:19 PM

im a newb but is there anyway you could grab a copy of knoppix/similar live distro and edit the passwd file? just a thought, worth looking into id think if it saves you from losing your data

Blag-foo 09-29-2003 10:20 PM

this what i get for posting from work 8)

green_dragon37 09-29-2003 10:37 PM

try this:

at the lilo prompt, enter: linux init=/bin/bash

it should get you a bash shell with root privs, then edit your /etc/passwd file as necessary

from this article(must read!)
http://www.bastille-linux.org/jay/an...rewdriver.html

Ian

Jadasin 09-29-2003 10:54 PM

Hey all, just wanna say thank for the help, after the last posts as I was reading around I found this article:

http://www.linuxgazette.com/issue50/tag/4.html

and did exactly as posted, was a great help and worked like a charm for anyone who might encounter the same problem in the future. Thanks dragon for the help, the article you posted was basically the same idea, I appreciate it.

Now all I have to do is get this w/lan going and I'm laughin all the way to slack heaven...

Anna.


All times are GMT -5. The time now is 11:29 PM.