LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-09-2004, 01:52 AM   #1
ju$tin
LQ Newbie
 
Registered: Mar 2004
Posts: 5

Rep: Reputation: 0
How do you use linux?


I grew up using Macs. I have been using xp for the last 2 years. I found a comp in the garbage and installed Man9.2. All I want to do right now is surf the internet on the thing. All the sites I've read are either too simple or too complicated. I've found more information about installing than I need. Now what? I see screen shots of gui's but I'm staring at this command line with no clue. I typed kde on a whim, and I got some stuff about build date and whatnot. Somewhere in there it says:

Fatal server error:
no screens found

At this point I'm sick of learning more than I need. I'm not completely computer illiterate, but linux sure makes me feel like I am. All I want is the answer, I don't want to understand the question anymore (which is what I get when someone wants to "teach" me something and I end up never getting my question answered). I'd love to get this running. If I can make a little progress, I'll feel like it's worth learning. BTW, I'm connecting through a Netgear 614 Cable Router/Switch. I have my xp box and this other p2/300 connected to the switch.
 
Old 03-09-2004, 02:37 AM   #2
Tih8710
Member
 
Registered: Jan 2003
Location: Finland
Distribution: ElementaryOS Freya as main, every other ubuntu-based as testing
Posts: 124

Rep: Reputation: 15
Well, welcome to Linux.
It's been quite the same for all of us when we started to use it. But off
we go... If the MDK installed the GUI and all that it needs correctly, then
the command to use is "startx"

Enjoy linux, and read the manuals.. (no affence..)
 
Old 03-09-2004, 02:38 AM   #3
jax8
Member
 
Registered: Feb 2004
Location: Australia
Distribution: Ubuntu, Fedora 10
Posts: 632

Rep: Reputation: 31
try typing startx and tell us what happens.

for some reason the computer cannot find your monitor

there is a basic configuration program you can run but I forgot what it is called.

someone else can tell you though

I think it is XFree86 so type

XFree86


in the command prompt

Last edited by jax8; 03-09-2004 at 02:47 AM.
 
Old 03-09-2004, 02:49 AM   #4
bigjohn
Senior Member
 
Registered: Jun 2002
Location: UK .
Distribution: *buntu (usually Kubuntu)
Posts: 2,682
Blog Entries: 9

Rep: Reputation: 45
if you still get the fatal error, no screens found,

after it gets to that stage, you should end up at either
Code:
linux login:
or
Code:
root@ju$tin root
(or something similar), well, the one that you want is the second one, so if you get the first, then just log in as root.

Then as it's mandrake that you installed, I'm gonna guess that it will have installed VIM as it's editor, so again as a guess, you should then type
Code:
vi /var/log/XFree86.0.log
That SHOULD bring up your log file for your x server. And it also should show you if there are any error's cropping up in your XF86Config (maybe suffixed -4) file. You'd have to look at the file to see what it says. To get out of the vi editor type
Code:
:q
The fatal error and no screens found, is a "classic" sign of incorrectly configured XF86Config files.

If you're really into learning, there's a shit load of places to look, but as you don't have nice easy graphic view at the moment, then you could still do it, but with a text based browser - and that's if you got your connection configured ok - the way to do that, is to type either
Code:
lynx
or
Code:
links2
and then you have to mess with it a little i.e. moving the cursor with direction arrows or tab button (you might have got your mouse configured OK, but not the screens bit in the XF86Config file(s), but I don't know if you'd be able to use it).

When I was "straight out of the box" i.e. at your stage, I just used to re-install (not upgrade). It used to take me about 20 to 30 minutes, just that when you get to the install summary screen make sure that you "configure" graphical environment (I think that's what it's called - though if the summary screen is the same as 9.1, it should say "not configured or not yet configured", and then you just hit the button, and try to see what might need changing - whatever you change, from memory, you should be able to test it i.e. to make sure that the banded colour test screen displays correctly - it might help, if you have your monitor instructions handy (as in the horizontal and vertical refresh rates/freq's), and know what your graphics card make/model is - you might not need the info, but it can help to have it handy, if mandy isn't configuring it correctly on it's own.

Oh and if you don't have the monitor info handy, google for it by model name.

regards

John

Last edited by bigjohn; 03-09-2004 at 03:06 AM.
 
Old 03-09-2004, 02:59 AM   #5
Tih8710
Member
 
Registered: Jan 2003
Location: Finland
Distribution: ElementaryOS Freya as main, every other ubuntu-based as testing
Posts: 124

Rep: Reputation: 15
the shell program for configuring Xfree was "xf86config", but since you have MDK9.2 then the "drakconf" is a bit easier..
 
Old 03-09-2004, 03:15 AM   #6
bigjohn
Senior Member
 
Registered: Jun 2002
Location: UK .
Distribution: *buntu (usually Kubuntu)
Posts: 2,682
Blog Entries: 9

Rep: Reputation: 45
but can he use drakconf without graphic access/view - sorry if that's a stupid question, but I've never tried to do that. I've always gone for the XF86Config.


Also, ju$tin's other choice would (presuming he has access to a cdrw/burner) is to download get knoppix (plus the md5sum file, which will need printing off) and md5summer.

Unpack/install the md5summer, then when the knoppix has downloaded, do a "create md5sum" and check that the printed off md5sum and the one produced by md5summer correspond.

If so, burn knoppix to disc. Once that is done, just boot the knoppix disc. If there is a problem with hardware detection using mandrake, then the best likelyhood is to try knoppix, as the hardware detection is superior.

The as it's still running from the cd at this stage, he can either try and get mandrake up and running, or open a terminal and type
Code:
sudo knx-hdinstall
and follow the instructions. I found it as easy as installing mandrake. But what the hell, why install mandrake, if you can have an instant debian based system?

just an idea

regards

John
 
Old 03-09-2004, 03:28 AM   #7
ju$tin
LQ Newbie
 
Registered: Mar 2004
Posts: 5

Original Poster
Rep: Reputation: 0
ok, here we go.

startx gives the same screen plus a couple lines at the beginning.

I do end up with root@justin

vi /var/log/XFree86.0.log returns like 6 screens of yellow text with pink numbers, and some lines in blue. I scrolled down the whole thing and didn't see any -4's, but all -1's. Then, at the bottom, there's that Fatal error/no screens found thing again. I looked through it, and I can't see anything that says error except my new friend at the bottom.

During the install, it identified my monitor as a dell, which it is. The comp I'm installing on is quite old, I have it connected with a kvm switch to my much newer xp box and monitor, so I can check the internet for something if there is something I need to read, but I've been working on this linux thing here and there for two weeks and I've yet to make much progress for all my reading, although I know a lot more about IP addresses than I used to (interesting, but not helpful).

Right now, it's sitting at the bottom of that log file, I can't figure out how to exit it

This really makes me appreciate macs.

I really appreciate your help with this.
 
Old 03-09-2004, 03:33 AM   #8
ju$tin
LQ Newbie
 
Registered: Mar 2004
Posts: 5

Original Poster
Rep: Reputation: 0
bigjohn, I actually already have a knoppix disc (and the 7 debian cd's too). I thought I was savvy enough to do this, but I'm not sure I can do what you're talking about. Eventually, I would like to understand linux, but right now, I just want to get something going go make me feel like it's worth it, so I ditched debian in favor of mandrake since it's for newbies like me, but I'm finding just as much trouble.
 
Old 03-09-2004, 04:01 AM   #9
rvqbl
LQ Newbie
 
Registered: Jan 2004
Location: Oklahoma
Distribution: Ubuntu
Posts: 27

Rep: Reputation: 15
Have you tried it without the KVM switch? I use RH9 and I had some difficulties after I installed a KVM switch. Try booting directly hooked up to the monitor.
 
Old 03-09-2004, 04:15 AM   #10
ju$tin
LQ Newbie
 
Registered: Mar 2004
Posts: 5

Original Poster
Rep: Reputation: 0
Connected the monitor direct, same result
 
Old 03-09-2004, 04:17 AM   #11
jax8
Member
 
Registered: Feb 2004
Location: Australia
Distribution: Ubuntu, Fedora 10
Posts: 632

Rep: Reputation: 31
you exit vi by typing

:q!

note the colen at the front, press ESC if you stuff up and do it again

that tells vi to exit without saving changes


Once you get the gui going I think you will find it a lot more satisfying. The terminal for beginners can be frightning. Dont worry though the GUI is pretty self explanitory.

The only reason you are having these problems is because of the lack of commercial driver support for linux at the moment.
 
Old 03-09-2004, 04:21 AM   #12
jax8
Member
 
Registered: Feb 2004
Location: Australia
Distribution: Ubuntu, Fedora 10
Posts: 632

Rep: Reputation: 31
did you try typing

drakeconf

in a terminal

this will enable you so set up your monitor and graphics card again

then type

startx

Last edited by jax8; 03-09-2004 at 04:25 AM.
 
Old 03-09-2004, 04:56 AM   #13
ju$tin
LQ Newbie
 
Registered: Mar 2004
Posts: 5

Original Poster
Rep: Reputation: 0
Life is good now!!!!

Well, that drakconf (no e, took me a couple tries) was the ticket. I think it was the resolution. It was set to 1280 x 1024 and I brought it down to 1020 x 768. Bam!! The test worked. I exited, and typed startx and I'm swimmin in a nice gui. Finally, some progress. I even went to google.com and it loaded right up!! Sweeettt!!!

Thanks all for all the suggestions.

Actually, I'm running dual monitors on my xp, and the kvm switches between one of them (it's nice, I can bring up a page of instructions on the second monitor, switch to the linux box, and have the instructions right there). Anyway, I connected the viewsonic direct and told the drakconf what it was. After I got it running, I logged out, switched the monitors back, and it still worked. Go figure.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
link dies intermittently-seemingly at random- between win<->linux not linux<->linux?? takahaya Linux - Networking 10 03-09-2007 11:37 PM
triple boot linux/linux/linux No Windows involved toastermaker Linux - Newbie 12 03-02-2006 11:40 PM
Redhat (rhel v2.1) bootup problem with linux (linux vs linux-up) namgor Linux - Software 2 06-24-2004 03:49 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 10:44 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration