Share your knowledge at the LQ Wiki.
Go Back > Forums > Linux Forums > Linux - Newbie
User Name
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!


  Search this Thread
Old 03-28-2003, 02:20 AM   #1
LQ Newbie
Registered: Mar 2003
Posts: 11

Rep: Reputation: 0
Talking How do you enable a swap partition?

What really happened is:

1. My friend mounted a floppy.
2. My friend copied a few files to the mounted floppy.
3. My friend's Mandrake locked up.
4. My friend pressed the computer's restart button.

The next time my friend started his linux, it won't load X.

Another friend told me that the swap partition isn't enabled because the swap partition isn't shown when the command 'mount' is executed.

What are your opinions?

Old 03-28-2003, 02:30 AM   #2
Registered: Oct 2002
Location: Northern Ontario, Canada
Distribution: Slackware 10.0
Posts: 789

Rep: Reputation: 30
He didn't umount the floppy for one. Also, swap should be enabled at boot up I think. To see if swap is mounted do this as root:
root@phrankenstein:~# cat /etc/fstab
/dev/hda1        swap             swap        defaults         0   0
/dev/hda2        /                ext2        defaults         1   1
/dev/hdc1        /mnt/hd          ext2        defaults         1   1
/dev/cdrom       /mnt/cdrom       iso9660     noauto,owner,ro  0   0
/dev/fd0         /mnt/floppy      auto        noauto,owner     0   0
none             /dev/pts         devpts      gid=5,mode=620   0   0
none             /proc            proc        defaults         0   0
Also, having NO swap shouldn't cause a problem loading X if he's got enough RAM. Is he getting any error messages? Have him do:

less /var/log/XFree86.0.log

Hope this helps.
Old 03-28-2003, 01:05 PM   #3
Registered: Feb 2003
Location: NY
Posts: 46

Rep: Reputation: 15
I had this same problem today or yestarday, i wouldn't know, didn't go to sleep. my system locked up because of a tv tuner card. i hit reset button, then i loaded back into mandrake, and then when it was time to load x, a error came up saying it cannot load x. i think i hit the restart button again, then i had to scan hard drive or something to repair it, it said press y and enter, you may lose data i rain it, i i was able to start x, no problem! so just reboot, and press y and enter, if it asks you too, and u should be set!
Old 03-28-2003, 03:05 PM   #4
Registered: Mar 2003
Distribution: Debian
Posts: 158

Rep: Reputation: 30
First of all you have to have a swap partition.

Provided you do you can type swapon or swapoff to enable/disable it respectively.
Old 03-28-2003, 03:13 PM   #5
LQ Guru
Registered: Jan 2001
Posts: 24,149

Rep: Reputation: 252Reputation: 252Reputation: 252
First off, provide error messages and it might give everyone an idea how to fix your X not loading.

Second bahamat, you don't necessarily need or have to have a swap partition in Linux and I don't think that would affect X not loading either.

Provide more details, give us messages from your log file that Texicle asked about and we should be able to be of more help.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Enable quota in a used partition guideweb Linux - Security 1 03-12-2005 01:46 AM
not enough memory to run YaST,enable swap space, but can't ArtsWorks Linux - Newbie 8 09-13-2004 09:59 AM
Fedora boot hang (after Enable swap) Redeye2 Fedora 4 09-10-2004 08:22 AM
enable partition alaios Linux - Hardware 2 05-12-2004 02:44 PM
Newbie Installing Debian3 on m68k w/250M Partition Needs help creating swap partition AppleMac Linux - Newbie 2 11-01-2002 09:45 AM > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 07:38 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration