-   Linux - Newbie (
-   -   How Do I Unlock A Directory (

Roberta 04-21-2002 10:36 PM

How Do I Unlock A Directory
Hi folks!

I am wondering how do I unlock a directory.
For instance, my cdrom directories are locked (cdrom1 and cdrom2- my burner). Even though I login as root, I still cannot open neither because they are locked.

Thanks for the help! ;-)


trickykid 04-21-2002 11:13 PM

what are you referring to when you say locked ?? like you can't access them ?? are they the cdrom directories in the /mnt directory ?? if so, those directories will be empty until you mount a cdrom to them and then try to open/browse them. details on what your exactly trying to do please.

maartengina 06-05-2002 05:13 PM

Hi All,

I just installed mandrake 8.2, and I am having the same problem,
I cannot mount my cdrom drives and floppy, becouse the mount directories are locked, as a root I am also not able to acces the files/directories.

Thanks for your help!

AcidRain 06-05-2002 06:44 PM

Try this

create a directory in /mnt and call it cdrom1

and then type the command at shell

"mount /dev/cdrom /mnt/cdrom1"
or try
"mount /dev/hdc /mnt/cdrom1"


da Perp 06-06-2002 07:38 AM

Yes, it´s a big phat juicy mandrake bug, unless the above steps solve your problem. I used to have a similar problem where i mounted my cdrom and i couldnt acces it when I ran mandrake. I think it has to do with mandrake automounter wich is buggy.

MasterC 06-06-2002 07:56 AM

I don't think it's a bug. But that's just me. Open the file /etc/fstab and see what it says. If there are entries in there for your CDROM drives, then we can move on to other ideas. If not, we can give you lines to add to that file. Also, to check what is mounted on your system you can open a term and type 'mount' and that will at least tell ya if you have actually mounted the discs yet or not.

And if you are trying to copy files to your burner and then thinking it will just burn them as you copy them, that won't work. At least I haven't seen/heard of that working anyway.

How do you know it's locked? Are you in KDE and there are locks on top of the folder icons? This usually means it's not mounted. So open a vterm and type 'mount /dev/cdrom /mnt/cdrom' or something similar. Then refresh the folder view, you should be able to access it now.

jglen490 06-06-2002 08:33 AM

When I run KDE in Mandrake 8.2, the CD-ROM and Floppy icons both, always show locked until I put the appropriate media in each. Then the lock magically disappears. The wonders of supermount!!

rootman147 06-06-2002 05:23 PM

how does supermounting work? is it like autorun in windows? also does it detect floppies?

da Perp 06-07-2002 01:59 AM

Yes, that is what I meant, the supermount function used to be buggy. When I ran mandrake 7.2 and even 8.0 I had the same problem that onc3e in a while I couldnt access the cdrom. It is a known bug, read it at the mandrake site, but perhaps It´s been fixed in their newer distro. For me it was reason enough to switch to another distro. the super mount doesnt work like autorun, it just automaticALLY mounts a cd when youplace it in the drive, I think it´s a crappy system though because half of the time the cdrom drive gets locked and you can´t open it anymore, at least in my experiences with mandrake.

MasterC 06-07-2002 04:50 AM

You can always just type 'eject' at a prompt, and poof! Out comes your cd.

da Perp 06-07-2002 06:41 AM

I know, im not a moron. Ive been using linux longer than today. I said once in a while the cd would lock, no matter how many times i typed eject, no matter how many programs i shut off which may have in any way shape or form been linked to or acessing the cdrom drive directory. And seeing as how i read on a site somwhere that this was due to a bug in mandrakes distro, and they even released a distro without the supermount function due to this bug, im calling it a bug which was ,believe it or not, not something I thought because I didnt know that ´eject´or ´umount /cdrom´ (in my case) would ´unlock´or open the cdrom drive. Please dont insult my intelligence, before i make you say uuuuuuuuuuuh....uuuuuh...nana na naaaaa

MasterC 06-07-2002 06:52 AM

Sorry dude, didn't mean to make you feel like I was insulting your intelligence.

I was just offering a way for you to get your CD's out when it seems like pressing the button on the front of the drive won't work.

Although my 'lame' tip might not help you, it MAY help someone not nearly as wise as you.

da Perp 06-07-2002 07:25 AM

I was just kidding dude, sometimes I have a really long dick which people can easily step on, and yes you are right, it may help the person who started the thread or another newbie. And i wasnt threatening you, I was making a joke about your name. Have you heard of Master P? one of his songs go make you say uuuuuh uuuuh nanna na naaaa........

no hard feelings, i hope you feel the same way.

MasterC 06-07-2002 07:32 AM

Ha ha ha ha (really long dick) ha ha ha

Never any hard feelings buddy. Sorry to make you sound like an idiot without intending too.

jglen490 06-07-2002 08:48 AM

Yeah, Mandrake admitted to a supermount problem in version 8.1 but it seems to be O.K. in version 8.2, and in fact I believe supermount is the default in MDK. I never recall having a problem in 8.0, but any software can burp if it runs up on the right/wrong condition :D !!

All times are GMT -5. The time now is 12:07 PM.