LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 11-20-2003, 11:51 AM   #1
ChopSueyX
Member
 
Registered: Nov 2003
Location: Planet M$
Distribution: Slack....
Posts: 46

Rep: Reputation: 15
Lightbulb how do i turn off read only in knoppix bash


sry bout this but i need to fix my lilo.conf cos i cant boot into linux i tried to edit my lilo.conf but its read only how do i set it so that i can write to it? im using nedit to edit the file
 
Old 11-20-2003, 11:59 AM   #2
ChopSueyX
Member
 
Registered: Nov 2003
Location: Planet M$
Distribution: Slack....
Posts: 46

Original Poster
Rep: Reputation: 15
right ive fixed that problem

i used sudo which i remember some french guy teachin me in #damnsmall irc last night @ 5am but now i dont know what i need to change my lilo.conf to this is what i hav, ive only this drive in the puter now as all my MS HDD are fux0red, damn those IBM peices of shit

boot=/dev/hdg1
map=/boot/map
vga=normal
default="linux"
keytable=/boot/uk.klt
prompt
nowarn
timeout=100
message=/boot/message
menu-scheme=wb:bw:wb:bw
disk=/dev/hdg bios=0x80
image=/boot/vmlinuz
label="linux"
root=/dev/hdg1
initrd=/boot/initrd.img
append="quiet devfs=mount hda=ide-scsi hdb=ide-scsi hdc=ide-scsi acpi=off"
vga=788
read-only
image=/boot/vmlinuz
label="linux-nonfb"
root=/dev/hdg1
initrd=/boot/initrd.img
append="devfs=mount hda=ide-scsi hdb=ide-scsi hdc=ide-scsi acpi=off"
read-only
image=/boot/vmlinuz-enterprise
label="linux-enterpris"
root=/dev/hdg1
initrd=/boot/initrd-enterprise.img
append="devfs=mount hda=ide-scsi hdb=ide-scsi hdc=ide-scsi acpi=off"
read-only
other=/dev/hdg1
label="windows"
table=/dev/hde
other=/dev/fd0
label="floppy"
unsafe
image=/boot/vmlinuz-2.4.21-0.13mdk
label="old_linux"
root=/dev/hdg1
initrd=/boot/initrd-2.4.21-0.13mdk.img
append="quiet devfs=mount hda=ide-scsi hdb=ide-scsi hdc=ide-scsi acpi=off"
vga=788
read-only
image=/boot/vmlinuz
label="failsafe"
root=/dev/hdg1
initrd=/boot/initrd.img
append="failsafe devfs=nomount hda=ide-scsi hdb=ide-scsi hdc=ide-scsi acpi=off"
read-only
 
Old 11-20-2003, 12:03 PM   #3
Mikhail_16
Member
 
Registered: Oct 2003
Distribution: Gentoo rules them all
Posts: 279

Rep: Reputation: 31
you have to chroot first to your hd, once you do that, then you will be able to access the REAL lilo.conf. the one you are seeing is the one on knoppix cd.

basically go like this:
terminal:

'sudo chroot /dev/[your linux / drive]'
once you do ls you should get the whole contents of your linux drive
now
'sudo vi /etc/lilo.conf'

edit what you need. save and reboot. you are all set now.
 
Old 11-20-2003, 01:59 PM   #4
ChopSueyX
Member
 
Registered: Nov 2003
Location: Planet M$
Distribution: Slack....
Posts: 46

Original Poster
Rep: Reputation: 15
i tried but it says "chroot: cannot change root directoryto hdg1: not a directory"

but if i went to the '/mnt/hdg1/etc/lilo.conf wouldnt it bee the same

boot=/dev/hdg1
map=/boot/map
vga=normal
default="linux"
keytable=/boot/uk.klt
prompt
nowarn
timeout=100
message=/boot/message
menu-scheme=wb:bw:wb:bw
disk=/dev/hdg bios=0x81
image=/boot/vmlinuz
label="linux"
root=/dev/hdg1
initrd=/boot/initrd.img
append="quiet devfs=mount hda=ide-scsi hdb=ide-scsi hdc=ide-scsi acpi=off"
vga=788
read-only
image=/boot/vmlinuz
label="linux-nonfb"
root=/dev/hdg1
initrd=/boot/initrd.img
append="devfs=mount hda=ide-scsi hdb=ide-scsi hdc=ide-scsi acpi=off"
read-only
image=/boot/vmlinuz-enterprise
label="linux-enterpris"
root=/dev/hdg1
initrd=/boot/initrd-enterprise.img
append="devfs=mount hda=ide-scsi hdb=ide-scsi hdc=ide-scsi acpi=off"
read-only
other=/dev/fd0
label="floppy"
unsafe

and it still doesnt work

Last edited by ChopSueyX; 11-20-2003 at 02:13 PM.
 
Old 11-20-2003, 04:55 PM   #5
Mikhail_16
Member
 
Registered: Oct 2003
Distribution: Gentoo rules them all
Posts: 279

Rep: Reputation: 31
Your linux drive IS NOT hdg1, thats your cdrom.

MOST likely your harddrive is /mnt/hda3. you can figure it out from knoppix easily. its one of the shortcuts on the desctop.
 
Old 11-20-2003, 06:44 PM   #6
ChopSueyX
Member
 
Registered: Nov 2003
Location: Planet M$
Distribution: Slack....
Posts: 46

Original Poster
Rep: Reputation: 15
i might be a but i know its hdg
 
Old 11-20-2003, 07:56 PM   #7
quatsch
LQ Addict
 
Registered: Aug 2003
Location: New York, NY
Distribution: gentoo, gentooPPC
Posts: 1,661

Rep: Reputation: 48
right click the icon for your harddrive on the desktop. Then go to properties and there should be a little box somewhere that allows you to change the readonly permission to read-write. Maybe it wasn't properties - been a while since I used Knoppix the last time - but I do remember being able to change the permissions by right clicking the icon and then checking or unchecking something.
 
Old 11-20-2003, 09:20 PM   #8
crashmeister
Senior Member
 
Registered: Feb 2002
Distribution: t2 - trying to anyway
Posts: 2,541

Rep: Reputation: 47
To write anything you want anywhere with knoppix you need to go to the 'root console' in the 'knoppix' menu and type passwd.Then you should be able to set a root password and read/write.
Then you do chroot /mnt/hdg1 /bin/bash and run lilo.If you got a seperate /boot partition you'll have to mount that from the chroot environment.

Or so
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Computer will not turn on after using Knoppix. surfbass Linux - General 8 11-15-2005 02:15 PM
Knoppix and read/write Hanj Linux - General 3 06-01-2005 11:36 AM
Is there a way in Linux/Unix bash to turn off output or redirect to a file jimwelc Linux - Newbie 6 01-06-2005 04:56 AM
Knoppix Debian 3.6 Read-only pb dicou Debian 0 01-05-2005 12:43 PM
Cygwin:How do you turn the bash shell bell off? petercool Linux - Newbie 8 05-23-2003 11:48 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 07:40 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration