LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-01-2014, 04:17 PM   #16
schneidz
LQ Guru
 
Registered: May 2005
Location: boston, usa
Distribution: fc-15/ fc-20-live-usb/ aix
Posts: 5,135

Rep: Reputation: 876Reputation: 876Reputation: 876Reputation: 876Reputation: 876Reputation: 876Reputation: 876

Quote:
Originally Posted by Shadowmeph View Post
hmm so I installed sshfs but I am not sure where it is and how t oload it up, dam linux networking is so anoying to me right now .
ok... next step would be to try to connect to yor other pc... to test it out first please try to ssh in from the terminal. e.g.:
Code:
ssh user@ip-address
substituting where necessary. (you can find the others ip-address from running ifconfig from the other pc's terminal; heres mine as an example:
Code:
[schneidz@hyper ~]$ ifconfig
eth3      Link encap:Ethernet  HWaddr 90:FB:A6:xx:xx:xx  
          inet addr:192.168.1.25  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: 2601:c:5840:1c:92fb:a6ff:fe2a:5b68/64 Scope:Global
          inet6 addr: fd18:f3d:bc4e:0:92fb:a6ff:fe2a:5b68/64 Scope:Global
          inet6 addr: fe80::92fb:a6ff:fe2a:5b68/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:2382298 errors:0 dropped:0 overruns:0 frame:3
          TX packets:1192675 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:2300744132 (2.1 GiB)  TX bytes:290869809 (277.3 MiB)
          Interrupt:23 Base address:0x8000 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:4398 errors:0 dropped:0 overruns:0 frame:0
          TX packets:4398 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:310932 (303.6 KiB)  TX bytes:310932 (303.6 KiB)

Last edited by schneidz; 02-01-2014 at 04:21 PM.
 
Old 02-01-2014, 04:24 PM   #17
Shadowmeph
Member
 
Registered: May 2008
Location: West Coast Canada
Posts: 260

Original Poster
Rep: Reputation: 29
with samba I am lost are you all telling me that I have to go through this whole hassle just so I can move files from one PC to another or to my media player I could have totally removed my harddrive and transfered file that way faster and I still have know clue as to what I am doing.
I opened up a terminal and typed in sshfs then the ip address which then I found out I had to type in sshfs -h to find help which doesn't help me at all because I don't understand the help file grrr I ama very close to just giving up on linux I have know clue as to how I lasted over a year jusst using linux a few years back. I have forgotten every thing it seems.
 
Old 02-01-2014, 04:33 PM   #18
Shadowmeph
Member
 
Registered: May 2008
Location: West Coast Canada
Posts: 260

Original Poster
Rep: Reputation: 29
ok so Ityped in ssh then the ip which then asked for a password which I thought was right but recieved a connection refused after trying a couple of passwords I and getting the same message "Permission denied (publickey,password)"I went to my other PC and try to go from there to my laptop which just timed out.

Last edited by Shadowmeph; 02-01-2014 at 04:35 PM.
 
Old 02-01-2014, 04:45 PM   #19
The_Real_Contra
LQ Newbie
 
Registered: Feb 2014
Location: Texas
Distribution: Ubuntu 13.10 32 bit
Posts: 3

Rep: Reputation: Disabled
does your desktop have a blue tooth dongle?
that is the usual way I do it


also did you not want to do the moving of the HDD like I suggested earlier?


you could also do FTP, or E-mail
 
Old 02-01-2014, 07:08 PM   #20
schneidz
LQ Guru
 
Registered: May 2005
Location: boston, usa
Distribution: fc-15/ fc-20-live-usb/ aix
Posts: 5,135

Rep: Reputation: 876Reputation: 876Reputation: 876Reputation: 876Reputation: 876Reputation: 876Reputation: 876
ssh is a protocol which allows you to log into another pc remotely:
Code:
ssh username@ip-address
substitute where appropriate
the username and password should be for the remote machine. once logged in, any command you run will be executed on the remote machine (although the results will show up in your local terminal screen). there is also a way to set it so that it looks at an encrypted key to log you in automatically but lets concentrate on this first step. various transfer utilities (scp/sftp/sshfs) run on top of this protocol; once we log you in successfully you'll be able to attempt to transfer files.
Quote:
Originally Posted by Shadowmeph View Post
ok so Ityped in ssh then the ip which then asked for a password which I thought was right but recieved a connection refused after trying a couple of passwords I and getting the same message "Permission denied (publickey,password)"I went to my other PC and try to go from there to my laptop which just timed out.
please copy and paste the command you are running as well as any errors you are getting so that we may attempt to troubleshoot.


i dont know opensuse much but i found this:
Quote:
SSHD
This is the SSH Daemon. This daemon is run on the server side. As a default this program is already installed in openSUSE, but does not start during the boot process. Starting SSHD during boot can be set in Yast2 > System Services (Runlevels). Select “sshd” in the list and click enable.
The default listening port of SSHD is 22. Make sure this port is open in the Firewall. For configuration possibilities read "Configure openSSH"
http://en.opensuse.org/OpenSSH#SSHD

or maybe its the firewall blocking the connection:
Quote:
Enter YaST->Network Services->SSHD Configuration, you can configure sshd there.
This contains a checkbox labelled "Open Port in Firewall", enable this and you should be able to connect.
http://forums.opensuse.org/showthrea...nto-new-client

Last edited by schneidz; 02-01-2014 at 07:49 PM.
 
Old 02-01-2014, 09:02 PM   #21
TroN-0074
Senior Member
 
Registered: Dec 2011
Location: Michigan USA
Distribution: OpenSUSE 13.2 64bit-Gnome on ASUS U52F
Posts: 1,444

Rep: Reputation: 340Reputation: 340Reputation: 340Reputation: 340
in Linux Mint right click on the folder you want to share, and thik the option share this folder, allow the permissions you want, to be able to copy and paste files to that directory.

In OpenSUSE go into YaST, open up your firewall to allow that computer to connect to other computer, also allow your samba to star during boot.

re start your laptop and check on network again
 
Old 02-02-2014, 01:22 PM   #22
btmiller
Senior Member
 
Registered: May 2004
Location: In the DC 'burbs
Distribution: Arch, Scientific Linux, Debian, Ubuntu
Posts: 4,284

Rep: Reputation: 371Reputation: 371Reputation: 371Reputation: 371
To the OP:

I'm not sure how much this will help, but if your media server is set up to export a CIFS share, you should be able to mount it on your Linux machine by issuing the following:

mount -t cifs -o user=<username> //<IP of media server>/<sharename> /mnt

You will be prompted for the password, and the contents of the CIFS share should be available under /mnt (you can mount them to any different directory that you want). Note that this command must be run as root, and the files will be owned and may only be readable/writable by root. To change that, use the uid and gid options to mount to set them to belong to your primary user. You can find out your user's id and group id (gid) by using the "id" cinnabd. Suppose your user id is 1000 and group id is also 1000 and the user name on the media server is "foobar" -- the command would look like:

mount -t cifs -o user=foobar,uid=1000,gid=1000 //<IP of media server>/<sharename> /mnt

In principle mounting any CIFS share works more or less the same way.
 
Old 02-02-2014, 01:42 PM   #23
Shadowmeph
Member
 
Registered: May 2008
Location: West Coast Canada
Posts: 260

Original Poster
Rep: Reputation: 29
Quote:
Originally Posted by schneidz View Post
ssh is a protocol which allows you to log into another pc remotely:
Code:
ssh username@ip-address
substitute where appropriate
the username and password should be for the remote machine. once logged in, any command you run will be executed on the remote machine (although the results will show up in your local terminal screen). there is also a way to set it so that it looks at an encrypted key to log you in automatically but lets concentrate on this first step. various transfer utilities (scp/sftp/sshfs) run on top of this protocol; once we log you in successfully you'll be able to attempt to transfer files.

please copy and paste the command you are running as well as any errors you are getting so that we may attempt to troubleshoot.


i dont know opensuse much but i found this:
http://en.opensuse.org/OpenSSH#SSHD

or maybe its the firewall blocking the connection:http://forums.opensuse.org/showthrea...nto-new-client
ok this is wha tI did and wha tI recieve when trying to conect from my Suse (laptop) to my linux mint PC
Code:
 to host 192.168.0.14 port 22: Connection refused
lap@suse:~> ssh usr@192.168.0.14
The authenticity of host '192.168.0.14 (192.168.0.14)' can't be established.
ECDSA key fingerprint is 37:4c:32:60:40:23:8d:c2:b7:7c:4b:b9:20:05:a0:4a.
Are you sure you want to continue connecting (yes/no)? yes
Warning: Permanently added '192.168.0.14' (ECDSA) to the list of known hosts.
Password: 
Password:
I noticed the "Can't be established" message but I continued anyway and typed in what I thought was the Password and of course it didn't work most likely because some setting on the recieving endd ( Linux mint)

when I try to share a folder in linux mint I recieve
Quote:
'net usershare' returned error 255: net usershare add: cannot share path /mnt/4A46B00946AFF3BB/Videos as we are restricted to only sharing directories we own.
Ask the administrator to add the line "usershare owner only = false"
to the [global] section of the smb.conf to allow this.
which I don't seem to remember how to change those permissions so that I can share that folder

Last edited by Shadowmeph; 02-02-2014 at 01:46 PM.
 
Old 02-02-2014, 02:05 PM   #24
Shadowmeph
Member
 
Registered: May 2008
Location: West Coast Canada
Posts: 260

Original Poster
Rep: Reputation: 29
Crap ok so now if I type in ssh lap@192.168.0.14 I think I am connected to my linuxmint machine because after I type in the pw I get "Last login: Sun Feb 2 11:58:32 2014 from 192.168.0.14
Have a lot of fun...
"
so now what what are the commands so that I can see the dir I want to look at or move files to? I am going to say that I am a terrible typer and do allot of typing mistakes
 
Old 02-02-2014, 02:06 PM   #25
schneidz
LQ Guru
 
Registered: May 2005
Location: boston, usa
Distribution: fc-15/ fc-20-live-usb/ aix
Posts: 5,135

Rep: Reputation: 876Reputation: 876Reputation: 876Reputation: 876Reputation: 876Reputation: 876Reputation: 876
Quote:
Originally Posted by Shadowmeph View Post
ok this is wha tI did and wha tI recieve when trying to conect from my Suse (laptop) to my linux mint PC
Code:
 to host 192.168.0.14 port 22: Connection refused
lap@suse:~> ssh usr@192.168.0.14
The authenticity of host '192.168.0.14 (192.168.0.14)' can't be established.
ECDSA key fingerprint is 37:4c:32:60:40:23:8d:c2:b7:7c:4b:b9:20:05:a0:4a.
Are you sure you want to continue connecting (yes/no)? yes
Warning: Permanently added '192.168.0.14' (ECDSA) to the list of known hosts.
Password: 
Password:
I noticed the "Can't be established" message but I continued anyway and typed in what I thought was the Password and of course it didn't work most likely because some setting on the recieving endd ( Linux mint)
...
I'm kinda stumped... Try doing ssh username@localhost on the mint machine.


The authenticity key warning happens every time you attempt to log into a new host.
 
Old 02-02-2014, 02:12 PM   #26
273
LQ Addict
 
Registered: Dec 2011
Location: UK
Distribution: Debian Sid AMD64, Raspbian Wheezy, various VMs
Posts: 6,740

Rep: Reputation: 1920Reputation: 1920Reputation: 1920Reputation: 1920Reputation: 1920Reputation: 1920Reputation: 1920Reputation: 1920Reputation: 1920Reputation: 1920Reputation: 1920
Quote:
Originally Posted by Shadowmeph View Post
so now what what are the commands so that I can see the dir I want to look at or move files to? I am going to say that I am a terrible typer and do allot of typing mistakes
On most systems you can open up your file manager and type something like the following in the location.
Code:
sftp://lap@192.168.0.14/home/lap
This would ask you for your password then open your home directory on the other machine.
That's how I use SSH to transfer files most of the time though I have also set up passwordless login which can be a bit confusing to set up but saves typing a password when wanting to access the other machine.
 
Old 02-02-2014, 02:24 PM   #27
schneidz
LQ Guru
 
Registered: May 2005
Location: boston, usa
Distribution: fc-15/ fc-20-live-usb/ aix
Posts: 5,135

Rep: Reputation: 876Reputation: 876Reputation: 876Reputation: 876Reputation: 876Reputation: 876Reputation: 876
Quote:
Originally Posted by Shadowmeph View Post
Crap ok so now if I type in ssh lap@192.168.0.14 I think I am connected to my linuxmint machine because after I type in the pw I get "Last login: Sun Feb 2 11:58:32 2014 from 192.168.0.14
Have a lot of fun...
"
so now what what are the commands so that I can see the dir I want to look at or move files to? I am going to say that I am a terrible typer and do allot of typing mistakes
OK... Seems like we've been using the wrong password for the wrong user all along. Can you please copy and paste these commands on both machines and paste them in your next reply.
Code:
uname -a -m -p
whoami
ifconfig
 
Old 02-02-2014, 02:38 PM   #28
Shadowmeph
Member
 
Registered: May 2008
Location: West Coast Canada
Posts: 260

Original Poster
Rep: Reputation: 29
Quote:
Originally Posted by schneidz View Post
OK... Seems like we've been using the wrong password for the wrong user all along. Can you please copy and paste these commands on both machines and paste them in your next reply.
Code:
uname -a -m -p
whoami
ifconfig
turned out that I was actually going into my own directories because I was getting my ipaddress's mixed up

Code:
lap@suse:~> uname -a -m -p
Linux suse.site 3.11.6-4-desktop #1 SMP PREEMPT Wed Oct 30 18:04:56 UTC 2013 (e6d4a27) x86_64 x86_64 x86_64 GNU/Linux
lap@suse:~> whoami
lap

lap@suse:~> su
Password: 
suse:/home/lap # ifconfig
enp9s0    Link encap:Ethernet  HWaddr 00:1C:23:96:7C:89  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)
          Interrupt:17 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:638 errors:0 dropped:0 overruns:0 frame:0
          TX packets:638 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:86890 (84.8 Kb)  TX bytes:86890 (84.8 Kb)

wlan0     Link encap:Ethernet  HWaddr 00:1C:26:68:00:F2  
          inet addr:192.168.0.14  Bcast:192.168.0.255  Mask:255.255.255.0
          inet6 addr: fe80::21c:26ff:fe68:f2/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:16465 errors:0 dropped:0 overruns:0 frame:0
          TX packets:5163 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:3095169 (2.9 Mb)  TX bytes:1087822 (1.0 Mb)
on my linux mint ;
Code:
mediapc@mediapc-desktop ~ $ uname -a -m -p
Linux mediapc-desktop 3.11.0-12-generic #19-Ubuntu SMP Wed Oct 9 16:20:46 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux
mediapc@mediapc-desktop ~ $ whoami
mediapc
mediapc@mediapc-desktop ~ $ su
Password: 
mediapc-desktop mediapc # ifconfig
eth0      Link encap:Ethernet  HWaddr f4:6d:04:52:d3:bb  
          inet addr:192.168.0.11  Bcast:192.168.0.255  Mask:255.255.255.0
          inet6 addr: fe80::f66d:4ff:fe52:d3bb/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:56526 errors:0 dropped:0 overruns:0 frame:0
          TX packets:27147 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:40242788 (40.2 MB)  TX bytes:3784086 (3.7 MB)

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:2352 errors:0 dropped:0 overruns:0 frame:0
          TX packets:2352 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:220939 (220.9 KB)  TX bytes:220939 (220.9 KB)

mediapc-desktop mediapc #

Last edited by Shadowmeph; 02-02-2014 at 02:41 PM.
 
Old 02-02-2014, 02:56 PM   #29
Shadowmeph
Member
 
Registered: May 2008
Location: West Coast Canada
Posts: 260

Original Poster
Rep: Reputation: 29
oh wow ok I have it figured out ow to connect to my inux mint using filezilla.
but how do I link a folder from linuxmint PC to my opensuse pc and vice versa?
 
Old 02-02-2014, 03:07 PM   #30
schneidz
LQ Guru
 
Registered: May 2005
Location: boston, usa
Distribution: fc-15/ fc-20-live-usb/ aix
Posts: 5,135

Rep: Reputation: 876Reputation: 876Reputation: 876Reputation: 876Reputation: 876Reputation: 876Reputation: 876
Quote:
Originally Posted by Shadowmeph View Post
ok this is wha tI did and wha tI recieve when trying to conect from my Suse (laptop) to my linux mint PC
Code:
 to host 192.168.0.14 port 22: Connection refused
lap@suse:~> ssh usr@192.168.0.14
The authenticity of host '192.168.0.14 (192.168.0.14)' can't be established.
ECDSA key fingerprint is 37:4c:32:60:40:23:8d:c2:b7:7c:4b:b9:20:05:a0:4a.
Are you sure you want to continue connecting (yes/no)? yes
Warning: Permanently added '192.168.0.14' (ECDSA) to the list of known hosts.
Password: 
Password:
...
Do either of your computers have a user named usr ? If not, from your response post #28 your whoami's return different usernames. Why are you trying to login as usr ?

Last edited by schneidz; 02-02-2014 at 03:15 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
The Best Way to support 100 client PCs to transfer files to one Server? sscn Linux - Server 3 01-20-2012 09:45 AM
How to transfer files from a linux machine to a windows machine which are not in the same network Lakshmi Yallampalli Linux - Networking 6 07-16-2010 04:50 AM
How can I transfer files from network combilli Linux - Software 2 02-12-2007 08:18 PM
transfer between 2 linux pcs Elim Linux - Networking 1 07-03-2004 10:43 AM
connecting two PCs for file transfer via Ethernet cables jax Linux - General 4 02-22-2002 01:39 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 11:26 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration