-   Linux - Newbie (
-   -   How do i switch keyboard layout in Gnome? (

z-vet 10-14-2004 09:08 PM

How do i switch keyboard layout in Gnome?
Hi all.
I just started to use Gnome (for reasons that not relevant now) and have a little problem: keyboard layout does not switch, it's english all the time. I tried to configure a switcher, it shows that everything is ok and changing a flag when i click on it or use keyboard shortcut, but it remains english. In KDE i configured it without a problem and it worked, how do i do it in Gnome?

jimdaworm 10-15-2004 05:02 AM

When I get these sorts of problems I find the easiest thing is to start from the ground up. Edit your /etc/X11/xf86config (I think that Madrake has xf86) and find something like

Option "XkbRules" "xfree86"
Option "XkbModel" "pc104"
Option "XkbLayout" "es"
# Option "XkbVariant" ""
# Option "XkbOptions" ""

and change the XkbLayout to what ever it should be.... give it a go anyway.

Good luck

All times are GMT -5. The time now is 11:21 AM.